CVE-2014-2852
OpenAFS before 1.6.7 delays the listen thread when an RXS_CheckResponse fails, which allows...
OpenAFS before 1.6.7 delays the listen thread when an RXS_CheckResponse fails, which allows remote attackers to cause a denial of service (performance degradation) via an invalid packet.
Exploit likelihood
What each source reports
NVD Score used
5.0
OpenAFS before 1.6.7 delays the listen thread when an RXS_CheckResponse fails, which allows remote attackers to cause a denial of service (performance degradation) via an invalid packet.
- Record
CVE-2014-2852- CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
OpenAFS before 1.6.7 delays the listen thread when an RXS_CheckResponse fails, which allows remote attackers to cause a denial of service (performance degradation) via an invalid packet.
- Record
CVE-2014-2852- Updated
- 2026-11-02
EUVDEUVD-2014-2877 No score
OpenAFS before 1.6.7 delays the listen thread when an RXS_CheckResponse fails, which allows remote attackers to cause a denial of service (performance degradation) via an invalid packet.
- Record
EUVD-2014-2877- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-p26q-362x-wgpw No score
OpenAFS before 1.6.7 delays the listen thread when an RXS_CheckResponse fails, which allows...
OpenAFS before 1.6.7 delays the listen thread when an RXS_CheckResponse fails, which allows remote attackers to cause a denial of service (performance degradation) via an invalid packet.
- Record
GHSA-p26q-362x-wgpw- Weakness
- CWE-20
- Updated
- 2026-11-02
OSV No score
OpenAFS before 1.6.7 delays the listen thread when an RXS_CheckResponse fails, which allows remote attackers to cause a denial of service (performance degradation) via an invalid packet.
- Record
CVE-2014-2852- Updated
- 2026-11-02
OSVDEBIAN-CVE-2014-2852 No score
OpenAFS before 1.6.7 delays the listen thread when an RXS_CheckResponse fails, which allows remote attackers to cause a denial of service (performance degradation) via an invalid packet.
- Record
DEBIAN-CVE-2014-2852- Updated
- 2026-11-02
OSVMGASA-2014-0515 No score
Updated openafs packages fix security vulnerabilies
Updated openafs packages fix security vulnerabilities:
Buffer overflow in the GetStatistics64 remote procedure call (RPC) in OpenAFS before 1.6.7 allows remote attackers to cause a denial of service (crash) via a crafted statsVersion argument (CVE-2014-0159).
OpenAFS before 1.6.7 delays the listen thread when an RXS_CheckResponse fails, which allows remote attackers to cause a denial of service (performance degradation) via an invalid packet (CVE-2014-2852).
OpenAFS 1.6.8 does not properly clear the fields in the host structure, which allows remote attackers to cause a denial of service (uninitialized memory access and crash) via unspecified vectors related to TMAY requests (CVE-2014-4044).
The OpenAFS package has been updated to version 1.6.10, fixing these issues and other bugs, as well as providing support for newer kernel versions.
- Record
MGASA-2014-0515- Updated
- 2026-11-02
OSVUBUNTU-CVE-2014-2852 No score
OpenAFS before 1.6.7 delays the listen thread when an RXS_CheckResponse fails, which allows remote attackers to cause a denial of service (performance degradation) via an invalid packet.
- Record
UBUNTU-CVE-2014-2852- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
openafsDebian:12 |
before 1.6.7-1 | 1.6.7-1 |
openafsDebian:13 |
before 1.6.7-1 | 1.6.7-1 |
openafsDebian:6.0 From an advisory covering 2 CVEs |
before 1.4.12.1+dfsg-4+squeeze3, plus listed versions 1.4.12.1+dfsg-31.4.12.1+dfsg-41.4.12.1+dfsg-4+squeeze11.4.12.1+dfsg-4+squeeze21.4.12.1+dfsg-4~bpo50+1 |
1.4.12.1+dfsg-4+squeeze3 |
openafsDebian:7 From an advisory covering 2 CVEs |
before 1.6.1-3+deb7u2, plus listed versions 1.6.1-31.6.1-3+deb7u11.6.1-3+deb7u1~bpo60+11.6.1-3+deb7u2~bpo60+1 |
1.6.1-3+deb7u2 |
openafsMageia:4 From an advisory covering 3 CVEs |
before 1.6.10-1.1.mga4 | 1.6.10-1.1.mga4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-2852 is a medium vulnerability (CVSS 5.0) in Openafs, published April 9, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.28%, the 70th percentile. Fixed in openafs 1.6.7-1.
References
openafs.org/frameset/dl/openafs/1.6.7/ChangeLog
debian.org/security/2014/dsa-2899
nvd.nist.gov/vuln/detail/CVE-2014-2852
github.com/advisories/GHSA-p26q-362x-wgpw
security-tracker.debian.org/tracker/CVE-2014-2852
advisories.mageia.org/MGASA-2014-0515.html
Show 15 moreShow less
bugs.mageia.org/show_bug.cgi?id=13188
openafs.org/security/OPENAFS-SA-2014-001.txt
openafs.org/security/OPENAFS-SA-2014-002.txt
openafs.org/dl/openafs/1.6.7/RELNOTES-1.6.6
openafs.org/dl/openafs/1.6.7/RELNOTES-1.6.7
openafs.org/dl/openafs/1.6.7/RELNOTES-1.6.8
openafs.org/dl/openafs/1.6.9/RELNOTES-1.6.9
openafs.org/dl/openafs/1.6.7/RELNOTES-1.6.10
lists.openafs.org/pipermail/openafs-announce/2014/000455.html
lists.openafs.org/pipermail/openafs-announce/2014/000460.html
lists.openafs.org/pipermail/openafs-announce/2014/000467.html
lists.openafs.org/pipermail/openafs-announce/2014/000468.html
lists.openafs.org/pipermail/openafs-announce/2014/000472.html
ubuntu.com/security/CVE-2014-2852
cve.org/CVERecord?id=CVE-2014-2852