Every CVE Search/ Get API key

CVE-2014-6439

Cross-site scripting in Elasticsearch

4.3 MediumFix available

Cross-site scripting (XSS) vulnerability in the CORS functionality in Elasticsearch before 1.4.0.Beta1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Exploit likelihood

2.02%Up 0.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-site scripting (XSS) vulnerability in the CORS functionality in Elasticsearch before 1.4.0.Beta1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
CVE-2014-6439
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in the CORS functionality in Elasticsearch before 1.4.0.Beta1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
CVE-2014-6439
Updated
2026-11-02
EUVDEUVD-2022-3121 No score

Cross-site scripting (XSS) vulnerability in the CORS functionality in Elasticsearch before 1.4.0.Beta1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
EUVD-2022-3121
Updated
2026-11-03
GitHub AdvisoriesGHSA-8699-m855-cwqf No score

Cross-site scripting in Elasticsearch

Cross-site scripting (XSS) vulnerability in the CORS functionality in Elasticsearch before 1.4.0.Beta1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
GHSA-8699-m855-cwqf
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-8699-m855-cwqf No score

Cross-site scripting in Elasticsearch

Cross-site scripting (XSS) vulnerability in the CORS functionality in Elasticsearch before 1.4.0.Beta1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
GHSA-8699-m855-cwqf
Weakness
CWE-79
Updated
2026-11-02
OSVUBUNTU-CVE-2014-6439 No score

Cross-site scripting (XSS) vulnerability in the CORS functionality in Elasticsearch before 1.4.0.Beta1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
UBUNTU-CVE-2014-6439
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.elasticsearch:elasticsearch
Maven
before 1.4.0.Beta1
1.4.0.Beta1
org.elasticsearch:elasticsearch
Maven
before 1.4.0.Beta1, plus listed versions
0.10.00.11.00.12.00.12.10.13.0
Show 45 moreShow less
0.13.10.14.00.14.10.14.20.14.30.14.40.15.00.15.10.15.20.16.00.16.10.16.20.16.30.16.40.16.50.17.00.17.10.17.100.17.20.17.30.17.40.17.50.17.60.17.70.17.80.17.90.18.00.18.10.18.20.18.30.18.40.18.50.18.60.18.70.19.00.19.0.RC10.19.0.RC20.19.0.RC30.19.10.19.100.19.110.19.120.19.20.19.30.19.4
1.4.0.Beta1
elasticsearch
Ubuntu:16.04:LTS
All versions, plus listed versions
1.6.2+dfsg-11.7.3+dfsg-11.7.3+dfsg-21.7.3+dfsg-3
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-6439 is a medium vulnerability (CVSS 4.3) in Elasticsearch, published October 10, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.02%, the 81st percentile. Fixed in org.elasticsearch:elasticsearch 1.4.0.Beta1.

References

This page doesn't list everything

Left out here: 61 versions. The JSON record has them.

MoveEnter Open