Every CVE Search/ Get API key

CVE-2014-8355

PCX parser code in ImageMagick before 6.8.9-9 allows remote attackers to cause a denial of...

5.5 MediumFix available

PCX parser code in ImageMagick before 6.8.9-9 allows remote attackers to cause a denial of service (out-of-bounds read).

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

2.08%Up 0.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.5

PCX parser code in ImageMagick before 6.8.9-9 allows remote attackers to cause a denial of service (out-of-bounds read).

Record
CVE-2014-8355
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

PCX parser code in ImageMagick before 6.8.9-9 allows remote attackers to cause a denial of service (out-of-bounds read).

Record
CVE-2014-8355
Updated
2026-11-02
EUVDEUVD-2014-8192 No score

PCX parser code in ImageMagick before 6.8.9-9 allows remote attackers to cause a denial of service (out-of-bounds read).

Record
EUVD-2014-8192
Updated
2026-11-03
GitHub AdvisoriesGHSA-fwhf-7f2f-3pfm 5.5

PCX parser code in ImageMagick before 6.8.9-9 allows remote attackers to cause a denial of...

PCX parser code in ImageMagick before 6.8.9-9 allows remote attackers to cause a denial of service (out-of-bounds read).

Record
GHSA-fwhf-7f2f-3pfm
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-125
Updated
2026-11-02
OSV 5.5

PCX parser code in ImageMagick before 6.8.9-9 allows remote attackers to cause a denial of service (out-of-bounds read).

Record
CVE-2014-8355
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2014-8355 5.5

PCX parser code in ImageMagick before 6.8.9-9 allows remote attackers to cause a denial of service (out-of-bounds read).

Record
DEBIAN-CVE-2014-8355
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2014-8355 5.5

PCX parser code in ImageMagick before 6.8.9-9 allows remote attackers to cause a denial of service (out-of-bounds read).

Record
UBUNTU-CVE-2014-8355
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2014-0482 No score

Updated imagemagick packages fix security vulnerabilities

ImageMagick is vulnerable to a denial of service due to out-of-bounds memory accesses in the resize code (CVE-2014-8354), PCX parser (CVE-2014-8355), DCM decoder (CVE-2014-8562), and JPEG decoder (CVE-2014-8716).

Record
MGASA-2014-0482
Updated
2026-11-02
OSVMGASA-2014-0484 No score

Updated graphicsmagick packages fix security vulnerability

GraphicsMagick is vulnerable to an out of bounds read / heap Overflow in the function ReadPCXImage in the file pcx.c. This can be exploited by a crafted image file to cause a denial of service (CVE-2014-8355).

Record
MGASA-2014-0484
Updated
2026-11-02
OSVUSN-3131-1 No score

imagemagick vulnerabilities

It was discovered that ImageMagick incorrectly handled certain malformed image files. If a user or automated system using ImageMagick were tricked into opening a specially crafted image, an attacker could exploit this to cause a denial of service or possibly execute code with the privileges of the user invoking the program.

Record
USN-3131-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
graphicsmagick
Debian:12
before 1.3.20-3+deb8u1
1.3.20-3+deb8u1
graphicsmagick
Debian:13
before 1.3.20-3+deb8u1
1.3.20-3+deb8u1
graphicsmagick
Debian:14
before 1.3.20-3+deb8u1
1.3.20-3+deb8u1
imagemagick
Debian:12
before 8:6.8.9.9-1
8:6.8.9.9-1
imagemagick
Debian:13
before 8:6.8.9.9-1
8:6.8.9.9-1
imagemagick
Debian:14
before 8:6.8.9.9-1
8:6.8.9.9-1
imagemagick
Debian:6.0
From an advisory covering 4 CVEs
before 8:6.6.0.4-3+squeeze6, plus listed versions
8:6.6.0.4-38:6.6.0.4-3+squeeze18:6.6.0.4-3+squeeze28:6.6.0.4-3+squeeze38:6.6.0.4-3+squeeze48:6.6.0.4-3+squeeze5
8:6.6.0.4-3+squeeze6
imagemagick
Debian:7
From an advisory covering 33 CVEs
before 8:6.7.7.10-5+deb7u13, plus listed versions
8:6.7.7.10-58:6.7.7.10-5+deb7u108:6.7.7.10-5+deb7u118:6.7.7.10-5+deb7u128:6.7.7.10-5+deb7u2
Show 7 moreShow less
8:6.7.7.10-5+deb7u38:6.7.7.10-5+deb7u48:6.7.7.10-5+deb7u58:6.7.7.10-5+deb7u68:6.7.7.10-5+deb7u78:6.7.7.10-5+deb7u88:6.7.7.10-5+deb7u9
8:6.7.7.10-5+deb7u13
imagemagick
Mageia:3
From an advisory covering 4 CVEs
before 6.8.1.1-2.3.mga3
6.8.1.1-2.3.mga3
imagemagick
Mageia:4
From an advisory covering 4 CVEs
before 6.8.7.0-2.3.mga4
6.8.7.0-2.3.mga4
Show 6 moreShow less
Affected packages
PackageAffectedFixed
graphicsmagick
Mageia:3
before 1.3.17-2.4.mga3
1.3.17-2.4.mga3
graphicsmagick
Mageia:4
before 1.3.18-3.3.mga4
1.3.18-3.3.mga4
graphicsmagick
Ubuntu:14.04:LTS
before 1.3.18-1ubuntu3.1, plus listed versions
1.3.16-1.1ubuntu21.3.16-1.1ubuntu31.3.18-1ubuntu3
1.3.18-1ubuntu3.1
imagemagick
Ubuntu:14.04:LTS
before 8:6.7.7.10-6ubuntu3.2, plus listed versions
8:6.7.7.10-5ubuntu38:6.7.7.10-5ubuntu48:6.7.7.10-6ubuntu18:6.7.7.10-6ubuntu28:6.7.7.10-6ubuntu38:6.7.7.10-6ubuntu3.1
8:6.7.7.10-6ubuntu3.2
imagemagick
Ubuntu:14.04:LTS
From an advisory covering 103 CVEs
before 8:6.7.7.10-6ubuntu3.2, plus listed versions
8:6.7.7.10-5ubuntu38:6.7.7.10-5ubuntu48:6.7.7.10-6ubuntu18:6.7.7.10-6ubuntu28:6.7.7.10-6ubuntu38:6.7.7.10-6ubuntu3.1
8:6.7.7.10-6ubuntu3.2
imagemagick
Ubuntu:16.04:LTS
From an advisory covering 103 CVEs
before 8:6.8.9.9-7ubuntu5.2, plus listed versions
8:6.8.9.9-5ubuntu28:6.8.9.9-68:6.8.9.9-6build18:6.8.9.9-78:6.8.9.9-7ubuntu1
Show 5 moreShow less
8:6.8.9.9-7ubuntu28:6.8.9.9-7ubuntu38:6.8.9.9-7ubuntu48:6.8.9.9-7ubuntu58:6.8.9.9-7ubuntu5.1
8:6.8.9.9-7ubuntu5.2

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-8355 is a medium vulnerability (CVSS 5.5) in Imagemagick, published October 31, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.08%, the 81st percentile. Fixed in graphicsmagick 1.3.20-3+deb8u1.

References

Show 112 moreShow less
MoveEnter Open