Every CVE Search/ Get API key

CVE-2015-1863

Heap-based buffer overflow in wpa_supplicant 1.0 through 2.4 allows remote attackers to cause a...

5.8 MediumFix available

Heap-based buffer overflow in wpa_supplicant 1.0 through 2.4 allows remote attackers to cause a denial of service (crash), read memory, or possibly execute arbitrary code via crafted SSID information in a management frame when creating or updating P2P entries.

Exploit likelihood

5.19%Down 2.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.8

Heap-based buffer overflow in wpa_supplicant 1.0 through 2.4 allows remote attackers to cause a denial of service (crash), read memory, or possibly execute arbitrary code via crafted SSID information in a management frame when creating or updating P2P entries.

Record
CVE-2015-1863
CVSS 2.0
5.8 MediumAV:A/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Heap-based buffer overflow in wpa_supplicant 1.0 through 2.4 allows remote attackers to cause a denial of service (crash), read memory, or possibly execute arbitrary code via crafted SSID information in a management frame when creating or updating P2P entries.

Record
CVE-2015-1863
Updated
2026-11-02
EUVDEUVD-2015-1971 No score

Heap-based buffer overflow in wpa_supplicant 1.0 through 2.4 allows remote attackers to cause a denial of service (crash), read memory, or possibly execute arbitrary code via crafted SSID information in a management frame when creating or updating P2P entries.

Record
EUVD-2015-1971
Updated
2026-11-03
GitHub AdvisoriesGHSA-5mh9-2ph2-m7gj No score

Heap-based buffer overflow in wpa_supplicant 1.0 through 2.4 allows remote attackers to cause a...

Heap-based buffer overflow in wpa_supplicant 1.0 through 2.4 allows remote attackers to cause a denial of service (crash), read memory, or possibly execute arbitrary code via crafted SSID information in a management frame when creating or updating P2P entries.

Record
GHSA-5mh9-2ph2-m7gj
Weakness
CWE-119
Updated
2026-11-02
OSV No score

Heap-based buffer overflow in wpa_supplicant 1.0 through 2.4 allows remote attackers to cause a denial of service (crash), read memory, or possibly execute arbitrary code via crafted SSID information in a management frame when creating or updating P2P entries.

Record
CVE-2015-1863
Updated
2026-11-02
OSVDEBIAN-CVE-2015-1863 No score

Heap-based buffer overflow in wpa_supplicant 1.0 through 2.4 allows remote attackers to cause a denial of service (crash), read memory, or possibly execute arbitrary code via crafted SSID information in a management frame when creating or updating P2P entries.

Record
DEBIAN-CVE-2015-1863
Updated
2026-11-02
Show 5 moreShow less
OSVopenSUSE-SU-2024:10022-1 No score

hostapd-2.6-1.1 on GA media

These are all security issues fixed in the hostapd-2.6-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10022-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:10499-1 No score

wpa_supplicant-2.6-1.1 on GA media

These are all security issues fixed in the wpa_supplicant-2.6-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10499-1
Updated
2026-11-02
OSVSUSE-SU-2015:1013-1 No score

Security update for wpa_supplicant

wpa_supplicant was updated to fix three security issues:

  • CVE-2015-0210: wpa_supplicant: broken certificate subject check this adds the 'domain_match' config option from upstream (additional to the already existing domain_suffix_match)
  • CVE-2014-3686: hostapd command execution
  • CVE-2015-1863: P2P SSID processing vulnerability
Record
SUSE-SU-2015:1013-1
Updated
2026-11-02
OSVUBUNTU-CVE-2015-1863 No score

Heap-based buffer overflow in wpa_supplicant 1.0 through 2.4 allows remote attackers to cause a denial of service (crash), read memory, or possibly execute arbitrary code via crafted SSID information in a management frame when creating or updating P2P entries.

Record
UBUNTU-CVE-2015-1863
Updated
2026-11-02
OSVUSN-2577-1 No score

wpa vulnerability

It was discovered that wpa_supplicant incorrectly handled SSID information when creating or updating P2P peer entries. A remote attacker could use this issue to cause wpa_supplicant to crash, resulting in a denial of service, expose memory contents, or possibly execute arbitrary code.

Record
USN-2577-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wpa
Debian:12
before 2.3-2
2.3-2
wpa
Debian:13
before 2.3-2
2.3-2
wpa
Debian:14
before 2.3-2
2.3-2
wpa
Debian:7
before 1.0-3+deb7u2, plus listed versions
1.0-31.0-3+deb7u1
1.0-3+deb7u2
wpa
Debian:8
before 2.3-1+deb8u1, plus listed versions
2.3-1
2.3-1+deb8u1
wpa_supplicant
Red Hat:enterprise_linux:7::client
From an advisory covering 2 CVEs
before 1:2.0-17.el7_1
1:2.0-17.el7_1
wpa_supplicant-debuginfo
Red Hat:enterprise_linux:7::client
From an advisory covering 2 CVEs
before 1:2.0-17.el7_1
1:2.0-17.el7_1
wpa_supplicant
Red Hat:enterprise_linux:7::computenode
From an advisory covering 2 CVEs
before 1:2.0-17.el7_1
1:2.0-17.el7_1
wpa_supplicant-debuginfo
Red Hat:enterprise_linux:7::computenode
From an advisory covering 2 CVEs
before 1:2.0-17.el7_1
1:2.0-17.el7_1
wpa_supplicant
Red Hat:enterprise_linux:7::server
From an advisory covering 2 CVEs
before 1:2.0-17.ael7b_1
1:2.0-17.ael7b_1
Show 9 moreShow less
Affected packages
PackageAffectedFixed
wpa_supplicant-debuginfo
Red Hat:enterprise_linux:7::server
From an advisory covering 2 CVEs
before 1:2.0-17.ael7b_1
1:2.0-17.ael7b_1
wpa_supplicant
Red Hat:enterprise_linux:7::workstation
From an advisory covering 2 CVEs
before 1:2.0-17.el7_1
1:2.0-17.el7_1
wpa_supplicant-debuginfo
Red Hat:enterprise_linux:7::workstation
From an advisory covering 2 CVEs
before 1:2.0-17.el7_1
1:2.0-17.el7_1
wpa_supplicant
SUSE:Linux Enterprise Desktop 12
From an advisory covering 3 CVEs
before 2.2-8.1
2.2-8.1
wpa_supplicant
SUSE:Linux Enterprise Server 12
From an advisory covering 3 CVEs
before 2.2-8.1
2.2-8.1
wpa_supplicant
SUSE:Linux Enterprise Server for SAP Applications 12
From an advisory covering 3 CVEs
before 2.2-8.1
2.2-8.1
wpa
Ubuntu:14.04:LTS
before 2.1-0ubuntu1.2, plus listed versions
1.0-3ubuntu21.0-3ubuntu31.0-3ubuntu42.1-0ubuntu12.1-0ubuntu1.1
2.1-0ubuntu1.2
hostapd
openSUSE:Tumbleweed
From an advisory covering 9 CVEs
before 2.6-1.1
2.6-1.1
wpa_supplicant
openSUSE:Tumbleweed
From an advisory covering 13 CVEs
before 2.6-1.1
2.6-1.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-1863 is a medium vulnerability (CVSS 5.8) in Canonical Ubuntu Linux, published April 21, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.19%, the 92nd percentile. Fixed in wpa 2.3-2.

References

Show 43 moreShow less
MoveEnter Open