Every CVE Search/ Get API key

CVE-2015-8936

Cross-site scripting (XSS) vulnerability in squidGuard.cgi in squidGuard before 1.5 allows remote...

6.1 MediumFix available

Cross-site scripting (XSS) vulnerability in squidGuard.cgi in squidGuard before 1.5 allows remote attackers to inject arbitrary web script or HTML via a blocked site link.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

1.13%Down 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.1

Cross-site scripting (XSS) vulnerability in squidGuard.cgi in squidGuard before 1.5 allows remote attackers to inject arbitrary web script or HTML via a blocked site link.

Record
CVE-2015-8936
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in squidGuard.cgi in squidGuard before 1.5 allows remote attackers to inject arbitrary web script or HTML via a blocked site link.

Record
CVE-2015-8936
Updated
2026-11-02
EUVDEUVD-2015-8792 No score

Cross-site scripting (XSS) vulnerability in squidGuard.cgi in squidGuard before 1.5 allows remote attackers to inject arbitrary web script or HTML via a blocked site link.

Record
EUVD-2015-8792
Updated
2026-11-03
GitHub AdvisoriesGHSA-9369-pq2m-xxc7 6.1

Cross-site scripting (XSS) vulnerability in squidGuard.cgi in squidGuard before 1.5 allows remote...

Cross-site scripting (XSS) vulnerability in squidGuard.cgi in squidGuard before 1.5 allows remote attackers to inject arbitrary web script or HTML via a blocked site link.

Record
GHSA-9369-pq2m-xxc7
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

Cross-site scripting (XSS) vulnerability in squidGuard.cgi in squidGuard before 1.5 allows remote attackers to inject arbitrary web script or HTML via a blocked site link.

Record
CVE-2015-8936
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2015-8936 6.1

Cross-site scripting (XSS) vulnerability in squidGuard.cgi in squidGuard before 1.5 allows remote attackers to inject arbitrary web script or HTML via a blocked site link.

Record
DEBIAN-CVE-2015-8936
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
Show 6 moreShow less
OSVUBUNTU-CVE-2015-8936 6.1

Cross-site scripting (XSS) vulnerability in squidGuard.cgi in squidGuard before 1.5 allows remote attackers to inject arbitrary web script or HTML via a blocked site link.

Record
UBUNTU-CVE-2015-8936
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVMGASA-2016-0237 No score

Updated squidguard packages fix security vulnerability

The squidGuard.cgi program is vulnerable to a reflected cross site scripting vulnerability in the blocking script squidGuard.cgi. The vulnerability is triggered when a user clicks a link to a blocked site where the url has scripting instructions added (CVE-2015-8936).

In Mageia's squidguard package, both /var/www/cgi-bin/squidGuard.cgi and /usr/share/squidGuard-1.4/samples/squidGuard.cgi were affected.

Note that it is highly recommended that any remaining users of this package switch to ufdbguard, which has better compatibility with current versions of Squid.

Record
MGASA-2016-0237
Updated
2026-11-02
OSVopenSUSE-SU-2024:11404-1 No score

squidGuard-1.6.0-1.4 on GA media

These are all security issues fixed in the squidGuard-1.6.0-1.4 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11404-1
Updated
2026-11-02
OSVSUSE-SU-2016:2510-1 No score

Security update for squidGuard

squidGuard was updated to fix one security issue.

This security issue was fixed:

  • CVE-2015-8936: Reflected cross site scripting vulnerability because of insufficient escaping (bsc#985612).
Record
SUSE-SU-2016:2510-1
Updated
2026-11-02
OSVSUSE-SU-2016:2511-1 No score

Security update for squidGuard

squidGuard was updated to fix one security issue.

This security issue was fixed:

  • CVE-2015-8936: Reflected cross site scripting vulnerability because of insufficient escaping (bsc#985612).
Record
SUSE-SU-2016:2511-1
Updated
2026-11-02
OSVSUSE-SU-2017:1411-1 No score

Security update for squidGuard

squidGuard was updated to fix one security issue:

  • CVE-2015-8936: Reflected cross site scripting vulnerability because of insufficient escaping (bsc#985612).
Record
SUSE-SU-2017:1411-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
squidguard
Debian:12
before 1.5-5
1.5-5
squidguard
Debian:13
before 1.5-5
1.5-5
squidguard
Debian:7
before 1.5-1+deb7u1, plus listed versions
1.5-1
1.5-1+deb7u1
squidguard
Mageia:5
before 1.4-21.1.mga5
1.4-21.1.mga5
squidGuard
SUSE:Linux Enterprise Server 11 SP4
before 1.4-13.10.1
1.4-13.10.1
squidGuard
SUSE:Linux Enterprise Server for SAP Applications 11 SP4
before 1.4-13.10.1
1.4-13.10.1
squidGuard
SUSE:Linux Enterprise Server 12 SP1
before 1.4-27.1
1.4-27.1
squidGuard
SUSE:Linux Enterprise Server for SAP Applications 12 SP1
before 1.4-27.1
1.4-27.1
squidGuard
SUSE:Linux Enterprise Server for Raspberry Pi 12 SP2
before 1.4-29.1
1.4-29.1
squidGuard
SUSE:Linux Enterprise Server 12 SP2
before 1.4-29.1
1.4-29.1
squidGuard
SUSE:Linux Enterprise Server for SAP Applications 12 SP2
before 1.4-29.1
1.4-29.1
squidGuard
openSUSE:Tumbleweed
before 1.6.0-1.4
1.6.0-1.4

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-8936 is a medium vulnerability (CVSS 6.1) in Squidguard, published June 22, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.13%, the 66th percentile. Fixed in squidguard 1.5-5.

References

Show 12 moreShow less
MoveEnter Open