CVE-2016-2511
Cross-site scripting (XSS) vulnerability in WebSVN 2.3.3 and earlier allows remote attackers to...
Cross-site scripting (XSS) vulnerability in WebSVN 2.3.3 and earlier allows remote attackers to inject arbitrary web script or HTML via the path parameter to log.php.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
Cross-site scripting (XSS) vulnerability in WebSVN 2.3.3 and earlier allows remote attackers to inject arbitrary web script or HTML via the path parameter to log.php.
- Record
CVE-2016-2511- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in WebSVN 2.3.3 and earlier allows remote attackers to inject arbitrary web script or HTML via the path parameter to log.php.
- Record
CVE-2016-2511- Updated
- 2026-11-02
EUVDEUVD-2016-3592 No score
Cross-site scripting (XSS) vulnerability in WebSVN 2.3.3 and earlier allows remote attackers to inject arbitrary web script or HTML via the path parameter to log.php.
- Record
EUVD-2016-3592- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-8rm3-w6q8-4976
6.1
Cross-site scripting (XSS) vulnerability in WebSVN 2.3.3 and earlier allows remote attackers to...
Cross-site scripting (XSS) vulnerability in WebSVN 2.3.3 and earlier allows remote attackers to inject arbitrary web script or HTML via the path parameter to log.php.
- Record
GHSA-8rm3-w6q8-4976- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
Cross-site scripting (XSS) vulnerability in WebSVN 2.3.3 and earlier allows remote attackers to inject arbitrary web script or HTML via the path parameter to log.php.
- Record
CVE-2016-2511- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-2511
6.1
Cross-site scripting (XSS) vulnerability in WebSVN 2.3.3 and earlier allows remote attackers to inject arbitrary web script or HTML via the path parameter to log.php.
- Record
UBUNTU-CVE-2016-2511- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
websvnDebian:6.0 |
before 2.3.1-1+deb6u2, plus listed versions 2.3.1-1 |
2.3.1-1+deb6u2 |
websvnDebian:7 |
before 2.3.3-1.1+deb7u2, plus listed versions 2.3.3-1.12.3.3-1.1+deb7u1 |
2.3.3-1.1+deb7u2 |
websvnDebian:8 |
before 2.3.3-1.2+deb8u1, plus listed versions 2.3.3-1.2 |
2.3.3-1.2+deb8u1 |
websvnUbuntu:14.04:LTS |
before 2.3.3-1.1+deb7u2build0.14.04.1, plus listed versions 2.3.3-1.12.3.3-1.1+deb7u1build0.14.04.1 |
2.3.3-1.1+deb7u2build0.14.04.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-2511 is a medium vulnerability (CVSS 6.1) in Websvn, published February 24, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.71%, the 77th percentile. Fixed in websvn 2.3.1-1+deb6u2.
References
packetstormsecurity.com/files/135886/WebSVN-2.3.3-Cross-Site-Scripting.html
lists.fedoraproject.org/pipermail/package-announce/2016-March/179168.html
debian.org/security/2016/dsa-3490
seclists.org/fulldisclosure/2016/Feb/99
nvd.nist.gov/vuln/detail/CVE-2016-2511
github.com/advisories/GHSA-8rm3-w6q8-4976
ubuntu.com/security/CVE-2016-2511
cve.org/CVERecord?id=CVE-2016-2511