CVE-2016-4324
Use-after-free vulnerability in LibreOffice before 5.1.4 allows remote attackers to execute...
Use-after-free vulnerability in LibreOffice before 5.1.4 allows remote attackers to execute arbitrary code via a crafted RTF file, related to stylesheet and superscript tokens.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.8
Use-after-free vulnerability in LibreOffice before 5.1.4 allows remote attackers to execute arbitrary code via a crafted RTF file, related to stylesheet and superscript tokens.
- Record
CVE-2016-4324- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
Use-after-free vulnerability in LibreOffice before 5.1.4 allows remote attackers to execute arbitrary code via a crafted RTF file, related to stylesheet and superscript tokens.
- Record
CVE-2016-4324- Updated
- 2026-11-02
EUVDEUVD-2016-5324 No score
Use-after-free vulnerability in LibreOffice before 5.1.4 allows remote attackers to execute arbitrary code via a crafted RTF file, related to stylesheet and superscript tokens.
- Record
EUVD-2016-5324- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-fhmw-mf54-383v
7.8
Use-after-free vulnerability in LibreOffice before 5.1.4 allows remote attackers to execute...
Use-after-free vulnerability in LibreOffice before 5.1.4 allows remote attackers to execute arbitrary code via a crafted RTF file, related to stylesheet and superscript tokens.
- Record
GHSA-fhmw-mf54-383v- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
OSV
7.8
Use-after-free vulnerability in LibreOffice before 5.1.4 allows remote attackers to execute arbitrary code via a crafted RTF file, related to stylesheet and superscript tokens.
- Record
CVE-2016-4324- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2016-4324
7.8
Use-after-free vulnerability in LibreOffice before 5.1.4 allows remote attackers to execute arbitrary code via a crafted RTF file, related to stylesheet and superscript tokens.
- Record
DEBIAN-CVE-2016-4324- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Show 5 moreShow less
OSVUBUNTU-CVE-2016-4324
7.8
Use-after-free vulnerability in LibreOffice before 5.1.4 allows remote attackers to execute arbitrary code via a crafted RTF file, related to stylesheet and superscript tokens.
- Record
UBUNTU-CVE-2016-4324- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2016-0246 No score
Updated libreoffice packages fix security vulnerability
Updated libreoffice packages fix security vulnerability:
Parsing the Rich Text Format character style index was insufficiently checked for validity. Documents can be constructed which dereference an iterator to the first entry of an empty STL container (CVE-2016-4324).
- Record
MGASA-2016-0246- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10006-1 No score
libreoffice-5.2.3.3-2.2 on GA media
These are all security issues fixed in the libreoffice-5.2.3.3-2.2 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10006-1- Updated
- 2026-11-02
OSVSUSE-SU-2016:2472-1 No score
Security update for libreoffice
LibreOffice was updated to version 5.1.5.2, bringing enhancements and bug fixes.
- CVE-2016-4324: Parsing the Rich Text Format character style index was insufficiently checked for validity. Documents could be constructed which dereference an iterator to the first entry of an empty STL container. (bsc#987553)
- Don't use 'nullable' for introspection, as it isn't available on SLE 12's version of gobject-introspection. This prevents a segmentation fault in gnome-documents. (bsc#1000102)
- Record
SUSE-SU-2016:2472-1- Updated
- 2026-11-02
OSVUSN-3022-1 No score
libreoffice vulnerability
It was discovered that LibreOffice incorrectly handled RTF document files. If a user were tricked into opening a specially crafted RTF document, a remote attacker could cause LibreOffice to crash, and possibly execute arbitrary code.
- Record
USN-3022-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libreofficeDebian:12 |
before 1:5.1.4~rc1-1 | 1:5.1.4~rc1-1 |
libreofficeDebian:13 |
before 1:5.1.4~rc1-1 | 1:5.1.4~rc1-1 |
libreofficeDebian:14 |
before 1:5.1.4~rc1-1 | 1:5.1.4~rc1-1 |
libreofficeDebian:7 |
before 1:3.5.4+dfsg2-0+deb7u7, plus listed versions 1:3.5.4+dfsg-41:3.5.4+dfsg2-0+deb7u11:3.5.4+dfsg2-0+deb7u21:3.5.4+dfsg2-0+deb7u31:3.5.4+dfsg2-0+deb7u41:3.5.4+dfsg2-0+deb7u4~bpo60+11:3.5.4+dfsg2-0+deb7u51:3.5.4+dfsg2-0+deb7u6 |
1:3.5.4+dfsg2-0+deb7u7 |
libreofficeDebian:8 |
before 1:4.3.3-2+deb8u5, plus listed versions 1:4.3.3-21:4.3.3-2+deb8u11:4.3.3-2+deb8u1~bpo70+11:4.3.3-2+deb8u21:4.3.3-2+deb8u31:4.3.3-2+deb8u3~bpo70+11:4.3.3-2+deb8u4 |
1:4.3.3-2+deb8u5 |
libreofficeMageia:5 |
before 4.4.7.2-3.mga5 | 4.4.7.2-3.mga5 |
librevengeMageia:5 |
before 0.0.4-1.mga5 | 0.0.4-1.mga5 |
libcdrMageia:5 |
before 0.1.2-1.mga5 | 0.1.2-1.mga5 |
libvisioMageia:5 |
before 0.1.5-1.mga5 | 0.1.5-1.mga5 |
libwpdMageia:5 |
before 0.10.1-1.mga5 | 0.10.1-1.mga5 |
Show 4 moreShow less
| Package | Affected | Fixed |
|---|---|---|
libreofficeSUSE:Linux Enterprise Desktop 12 SP1 |
before 5.1.5.2-29.4 | 5.1.5.2-29.4 |
libreofficeSUSE:Linux Enterprise Workstation Extension 12 SP1 |
before 5.1.5.2-29.4 | 5.1.5.2-29.4 |
libreofficeUbuntu:16.04:LTS |
before 1:5.1.4-0ubuntu1, plus listed versions 1:5.0.2-0ubuntu11:5.0.2-0ubuntu21:5.0.2-0ubuntu51:5.0.2-0ubuntu71:5.0.2-0ubuntu8 Show 7 moreShow less1:5.1.0~rc3-0ubuntu21:5.1.0-0ubuntu11:5.1.1~rc2-0ubuntu11:5.1.1-0ubuntu11:5.1.1-0ubuntu31:5.1.2-0ubuntu11:5.1.3-0ubuntu1 |
1:5.1.4-0ubuntu1 |
libreofficeopenSUSE:Tumbleweed From an advisory covering 17 CVEs |
before 5.2.3.3-2.2 | 5.2.3.3-2.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-4324 is a high vulnerability (CVSS 7.8) in Libreoffice, published June 29, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.82%, the 86th percentile. Fixed in libreoffice 1:5.1.4~rc1-1.
References
debian.org/security/2016/dsa-3608
security.gentoo.org/glsa/201611-03
securitytracker.com/id/1036209
securityfocus.com/bid/91499
libreoffice.org/about-us/security/advisories/cve-2016-4324
ubuntu.com/usn/USN-3022-1
Show 29 moreShow less
talosintelligence.com/reports/TALOS-2016-0126
nvd.nist.gov/vuln/detail/CVE-2016-4324
github.com/advisories/GHSA-fhmw-mf54-383v
security-tracker.debian.org/tracker/CVE-2016-4324
advisories.mageia.org/MGASA-2016-0246.html
bugs.mageia.org/show_bug.cgi?id=18826
suse.com/support/update/announcement/2016/suse-su-20162472-1
bugzilla.suse.com/1000102
bugzilla.suse.com/987553
suse.com/security/cve/CVE-2016-4324
ubuntu.com/security/CVE-2016-4324
ubuntu.com/security/notices/USN-3022-1
cve.org/CVERecord?id=CVE-2016-4324
suse.com/security/cve/CVE-2010-2935
suse.com/security/cve/CVE-2010-2936
suse.com/security/cve/CVE-2014-0247
suse.com/security/cve/CVE-2014-3524
suse.com/security/cve/CVE-2014-3575
suse.com/security/cve/CVE-2014-3693
suse.com/security/cve/CVE-2014-8146
suse.com/security/cve/CVE-2014-8147
suse.com/security/cve/CVE-2014-9093
suse.com/security/cve/CVE-2015-4551
suse.com/security/cve/CVE-2015-45513
suse.com/security/cve/CVE-2015-5212
suse.com/security/cve/CVE-2015-5213
suse.com/security/cve/CVE-2015-5214
suse.com/security/cve/CVE-2016-0794
suse.com/security/cve/CVE-2016-0795