CVE-2016-3424
Unspecified vulnerability in Oracle MySQL 5.7.12 and earlier allows remote administrators to...
CVE-2016-3424 is a medium vulnerability (CVSS 4.9) in Oracle Mysql, published July 20, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.15%, the 82nd percentile. Fixed in mysql-5.7 5.7.13-0ubuntu0.16.04.2.
Unspecified vulnerability in Oracle MySQL 5.7.12 and earlier allows remote administrators to affect availability via vectors related to Server: Optimizer.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- High
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
4.9
Unspecified vulnerability in Oracle MySQL 5.7.12 and earlier allows remote administrators to affect availability via vectors related to Server: Optimizer.
- Record
CVE-2016-3424- CVSS 3.0
- 4.9 Medium
CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.0 Medium
AV:N/AC:L/Au:S/C:N/I:N/A:P - Updated
- 2026-11-02
CVE List No score
Unspecified vulnerability in Oracle MySQL 5.7.12 and earlier allows remote administrators to affect availability via vectors related to Server: Optimizer.
- Record
CVE-2016-3424- Updated
- 2026-11-02
EUVDEUVD-2016-4450 No score
Unspecified vulnerability in Oracle MySQL 5.7.12 and earlier allows remote administrators to affect availability via vectors related to Server: Optimizer.
- Record
EUVD-2016-4450- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-w6v5-5mgv-7pgm
4.9
Unspecified vulnerability in Oracle MySQL 5.7.12 and earlier allows remote administrators to...
Unspecified vulnerability in Oracle MySQL 5.7.12 and earlier allows remote administrators to affect availability via vectors related to Server: Optimizer.
- Record
GHSA-w6v5-5mgv-7pgm- CVSS 3.0
- 4.9 Medium
CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSV
4.9
Unspecified vulnerability in Oracle MySQL 5.7.12 and earlier allows remote administrators to affect availability via vectors related to Server: Optimizer.
- Record
CVE-2016-3424- CVSS 3.0
- 4.9 Medium
CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-3424
4.9
Unspecified vulnerability in Oracle MySQL 5.7.12 and earlier allows remote administrators to affect availability via vectors related to Server: Optimizer.
- Record
UBUNTU-CVE-2016-3424- CVSS 3.0
- 4.9 Medium
CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUSN-3040-1 No score
mysql-5.5, mysql-5.6, mysql-5.7 vulnerabilities
Multiple security issues were discovered in MySQL and this update includes new upstream MySQL versions to fix these issues.
MySQL has been updated to 5.5.50 in Ubuntu 12.04 LTS and Ubuntu 14.04 LTS. Ubuntu 15.10 has been updated to MySQL 5.6.31. Ubuntu 16.04 LTS has been updated to MySQL 5.7.13.
In addition to security fixes, the updated packages contain bug fixes, new features, and possibly incompatible changes.
Please see the following for more information: http://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-50.html http://dev.mysql.com/doc/relnotes/mysql/5.6/en/news-5-6-31.html http://dev.mysql.com/doc/relnotes/mysql/5.7/en/news-5-7-13.html http://www.oracle.com/technetwork/security-advisory/cpujul2016-2881720.html
- Record
USN-3040-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mysql-5.7Ubuntu:16.04:LTS |
before 5.7.13-0ubuntu0.16.04.2, plus listed versions 5.7.11-0ubuntu45.7.11-0ubuntu55.7.11-0ubuntu65.7.12-0ubuntu15.7.12-0ubuntu1.1 |
5.7.13-0ubuntu0.16.04.2 |
percona-server-5.6Ubuntu:16.04:LTS |
All versions, plus listed versions 5.6.22-rel71.0-0ubuntu25.6.22-rel71.0-0ubuntu45.6.22-rel71.0-0ubuntu4.1 |
None known |
percona-xtradb-cluster-5.6Ubuntu:16.04:LTS |
All versions, plus listed versions 5.6.21-25.8-0ubuntu25.6.21-25.8-0ubuntu35.6.21-25.8-0ubuntu3.15.6.21-25.8-0ubuntu3.25.6.34-26.19-0ubuntu0.16.04.15.6.34-26.19-0ubuntu0.16.04.25.6.37-26.21-0ubuntu0.16.04.15.6.37-26.21-0ubuntu0.16.04.2 |
None known |
mysql-5.5Ubuntu:14.04:LTS |
before 5.5.50-0ubuntu0.14.04.1, plus listed versions 5.5.32-0ubuntu75.5.34-0ubuntu15.5.34-0ubuntu25.5.35-0ubuntu15.5.35+dfsg-1ubuntu1 Show 9 moreShow less5.5.37-0ubuntu0.14.04.15.5.38-0ubuntu0.14.04.15.5.40-0ubuntu0.14.04.15.5.41-0ubuntu0.14.04.15.5.43-0ubuntu0.14.04.15.5.44-0ubuntu0.14.04.15.5.46-0ubuntu0.14.04.25.5.47-0ubuntu0.14.04.15.5.49-0ubuntu0.14.04.1 |
5.5.50-0ubuntu0.14.04.1 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
ubuntu.com/usn/USN-3040-1
oracle.com/technetwork/security-advisory/cpujul2016-2881720.html
securitytracker.com/id/1036362
securityfocus.com/bid/91787
securityfocus.com/bid/91976
nvd.nist.gov/vuln/detail/CVE-2016-3424
Show 20 moreShow less
github.com/advisories/GHSA-w6v5-5mgv-7pgm
ubuntu.com/security/CVE-2016-3424
ubuntu.com/security/notices/USN-3040-1
cve.org/CVERecord?id=CVE-2016-3424
ubuntu.com/security/CVE-2016-3459
ubuntu.com/security/CVE-2016-3477
ubuntu.com/security/CVE-2016-3486
ubuntu.com/security/CVE-2016-3501
ubuntu.com/security/CVE-2016-3518
ubuntu.com/security/CVE-2016-3521
ubuntu.com/security/CVE-2016-3588
ubuntu.com/security/CVE-2016-3614
ubuntu.com/security/CVE-2016-3615
ubuntu.com/security/CVE-2016-5436
ubuntu.com/security/CVE-2016-5437
ubuntu.com/security/CVE-2016-5439
ubuntu.com/security/CVE-2016-5440
ubuntu.com/security/CVE-2016-5441
ubuntu.com/security/CVE-2016-5442
ubuntu.com/security/CVE-2016-5443