CVE-2017-0357
iucode-tool: heap buffer overflow on -tr loader
A heap-overflow flaw exists in the -tr loader of iucode-tool starting with v1.4 and before v2.1.1, potentially leading to SIGSEGV, or heap corruption.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
A heap-overflow flaw exists in the -tr loader of iucode-tool starting with v1.4 and before v2.1.1, potentially leading to SIGSEGV, or heap corruption.
- Record
CVE-2017-0357- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
iucode-tool: heap buffer overflow on -tr loader
A heap-overflow flaw exists in the -tr loader of iucode-tool starting with v1.4 and before v2.1.1, potentially leading to SIGSEGV, or heap corruption.
- Record
CVE-2017-0357- Updated
- 2026-11-02
EUVDEUVD-2017-0713 No score
A heap-overflow flaw exists in the -tr loader of iucode-tool starting with v1.4 and before v2.1.1, potentially leading to SIGSEGV, or heap corruption.
- Record
EUVD-2017-0713- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-29vx-f64r-92xh
9.8
A heap-overflow flaw exists in the -tr loader of iucode-tool starting with v1.4 and before v2.1.1...
A heap-overflow flaw exists in the -tr loader of iucode-tool starting with v1.4 and before v2.1.1, potentially leading to SIGSEGV, or heap corruption.
- Record
GHSA-29vx-f64r-92xh- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSV
9.8
A heap-overflow flaw exists in the -tr loader of iucode-tool starting with v1.4 and before v2.1.1, potentially leading to SIGSEGV, or heap corruption.
- Record
CVE-2017-0357- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-0357
9.8
A heap-overflow flaw exists in the -tr loader of iucode-tool starting with v1.4 and before v2.1.1, potentially leading to SIGSEGV, or heap corruption.
- Record
DEBIAN-CVE-2017-0357- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-0357
9.8
A heap-overflow flaw exists in the -tr loader of iucode-tool starting with v1.4 and before v2.1.1, potentially leading to SIGSEGV, or heap corruption.
- Record
UBUNTU-CVE-2017-0357- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10867-1 No score
iucode-tool-2.3.1-1.13 on GA media
These are all security issues fixed in the iucode-tool-2.3.1-1.13 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10867-1- Updated
- 2026-11-02
OSVUSN-3186-1 No score
iucode-tool vulnerability
It was discovered that iucode-tool incorrectly handled certain microcodes when using the -tr loader. If a user were tricked into processing a specially crafted microcode, a remote attacker could use this issue to cause iucode-tool to crash, resulting in a denial of service, or possibly execute arbitrary code.
- Record
USN-3186-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
iucode-toolDebian:12 |
before 2.1.1-1 | 2.1.1-1 |
iucode-toolDebian:13 |
before 2.1.1-1 | 2.1.1-1 |
iucode-toolDebian:14 |
before 2.1.1-1 | 2.1.1-1 |
iucode-toolUbuntu:16.04:LTS |
before 1.5.1-1ubuntu0.1, plus listed versions 1.3-11.5-11.5.1-1 |
1.5.1-1ubuntu0.1 |
iucode-toolopenSUSE:Tumbleweed |
before 2.3.1-1.13 | 2.3.1-1.13 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-0357 is a critical vulnerability (CVSS 9.8) in Iucode-tool, published January 17, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.84%, the 86th percentile. Fixed in iucode-tool 2.1.1-1.
References
security-tracker.debian.org/tracker/CVE-2017-0357
gitlab.com/iucode-tool/iucode-tool/issues/3
securityfocus.com/bid/95432
nvd.nist.gov/vuln/detail/CVE-2017-0357
github.com/advisories/GHSA-29vx-f64r-92xh
ubuntu.com/security/CVE-2017-0357
ubuntu.com/security/notices/USN-3186-1
cve.org/CVERecord?id=CVE-2017-0357
suse.com/security/cve/CVE-2017-0357