CVE-2017-12141
In ytnef 1.9.2, a heap-based buffer overflow vulnerability was found in the function TNEFFillMapi...
In ytnef 1.9.2, a heap-based buffer overflow vulnerability was found in the function TNEFFillMapi in ytnef.c, which allows attackers to cause a denial of service via a crafted file.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
5.5
In ytnef 1.9.2, a heap-based buffer overflow vulnerability was found in the function TNEFFillMapi in ytnef.c, which allows attackers to cause a denial of service via a crafted file.
- Record
CVE-2017-12141- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
In ytnef 1.9.2, a heap-based buffer overflow vulnerability was found in the function TNEFFillMapi in ytnef.c, which allows attackers to cause a denial of service via a crafted file.
- Record
CVE-2017-12141- Updated
- 2026-11-02
EUVDEUVD-2017-3725 No score
In ytnef 1.9.2, a heap-based buffer overflow vulnerability was found in the function TNEFFillMapi in ytnef.c, which allows attackers to cause a denial of service via a crafted file.
- Record
EUVD-2017-3725- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-4qjw-wvqg-mchf
5.5
In ytnef 1.9.2, a heap-based buffer overflow vulnerability was found in the function TNEFFillMapi...
In ytnef 1.9.2, a heap-based buffer overflow vulnerability was found in the function TNEFFillMapi in ytnef.c, which allows attackers to cause a denial of service via a crafted file.
- Record
GHSA-4qjw-wvqg-mchf- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSV
5.5
In ytnef 1.9.2, a heap-based buffer overflow vulnerability was found in the function TNEFFillMapi in ytnef.c, which allows attackers to cause a denial of service via a crafted file.
- Record
CVE-2017-12141- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-12141
5.5
In ytnef 1.9.2, a heap-based buffer overflow vulnerability was found in the function TNEFFillMapi in ytnef.c, which allows attackers to cause a denial of service via a crafted file.
- Record
DEBIAN-CVE-2017-12141- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-12141
5.5
In ytnef 1.9.2, a heap-based buffer overflow vulnerability was found in the function TNEFFillMapi in ytnef.c, which allows attackers to cause a denial of service via a crafted file.
- Record
UBUNTU-CVE-2017-12141- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUSN-3667-1 No score
libytnef vulnerabilities
It was discovered that libytnef incorrectly handled certain files. An attacker could possibly use this to cause a denial of service. (CVE-2017-12141, CVE-2017-9146, CVE-2017-9471, CVE-2017-9473)
It was discovered that libytnef incorrectly handled certain files. An attacker could possibly use this to access sensitive information. (CVE-2017-9058)
- Record
USN-3667-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libytnefDebian:12 |
before 1.9.3-1 | 1.9.3-1 |
libytnefDebian:13 |
before 1.9.3-1 | 1.9.3-1 |
libytnefDebian:14 |
before 1.9.3-1 | 1.9.3-1 |
libytnefUbuntu:14.04:LTS |
before 1.5-6ubuntu0.2, plus listed versions 1.5-51.5-61.5-6ubuntu0.1 |
1.5-6ubuntu0.2 |
libytnefUbuntu:16.04:LTS |
All versions, plus listed versions 1.5-61.5-91.5-9ubuntu0.1 |
None known |
libytnefUbuntu:18.04:LTS |
All versions, plus listed versions 1.9.2-2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-12141 is a medium vulnerability (CVSS 5.5) in Ytnef Project Ytnef, published August 2, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.15%, the 66th percentile. Fixed in libytnef 1.9.3-1.
References
usn.ubuntu.com/3667-1
somevulnsofadlab.blogspot.com/2017/07/ytnefheap-buffer-overflow-in.html
github.com/Yeraze/ytnef/issues/50
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/LFJWMUEUC4ILH2HEOCYVVLQT654ZMCGQ
nvd.nist.gov/vuln/detail/CVE-2017-12141
lists.fedoraproject.org/archives/list/[email protected]/message/LFJWMUEUC4ILH2HEOCYVVLQT654ZMCGQ
Show 9 moreShow less
github.com/advisories/GHSA-4qjw-wvqg-mchf
security-tracker.debian.org/tracker/CVE-2017-12141
ubuntu.com/security/CVE-2017-12141
ubuntu.com/security/notices/USN-3667-1
cve.org/CVERecord?id=CVE-2017-12141
ubuntu.com/security/CVE-2017-9058
ubuntu.com/security/CVE-2017-9146
ubuntu.com/security/CVE-2017-9471
ubuntu.com/security/CVE-2017-9473