CVE-2017-11109
Vim 8.0 allows attackers to cause a denial of service (invalid free) or possibly have unspecified...
Vim 8.0 allows attackers to cause a denial of service (invalid free) or possibly have unspecified other impact via a crafted source (aka -S) file. NOTE: there might be a limited number of scenarios in which this has security relevance.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.8
Vim 8.0 allows attackers to cause a denial of service (invalid free) or possibly have unspecified other impact via a crafted source (aka -S) file. NOTE: there might be a limited number of scenarios in which this has security relevance.
- Record
CVE-2017-11109- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-416
- Updated
- 2026-11-02
CVE List No score
Vim 8.0 allows attackers to cause a denial of service (invalid free) or possibly have unspecified other impact via a crafted source (aka -S) file. NOTE: there might be a limited number of scenarios in which this has security relevance.
- Record
CVE-2017-11109- Updated
- 2026-11-02
EUVDEUVD-2017-2746 No score
Vim 8.0 allows attackers to cause a denial of service (invalid free) or possibly have unspecified other impact via a crafted source (aka -S) file. NOTE: there might be a limited number of scenarios in which this has security relevance.
- Record
EUVD-2017-2746- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-hv76-654r-x97r
7.8
Vim 8.0 allows attackers to cause a denial of service (invalid free) or possibly have unspecified...
Vim 8.0 allows attackers to cause a denial of service (invalid free) or possibly have unspecified other impact via a crafted source (aka -S) file. NOTE: there might be a limited number of scenarios in which this has security relevance.
- Record
GHSA-hv76-654r-x97r- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-416
- Updated
- 2026-11-02
OSV
7.8
Vim 8.0 allows attackers to cause a denial of service (invalid free) or possibly have unspecified other impact via a crafted source (aka -S) file. NOTE: there might be a limited number of scenarios in which this has security relevance.
- Record
CVE-2017-11109- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-11109
7.8
Vim 8.0 allows attackers to cause a denial of service (invalid free) or possibly have unspecified other impact via a crafted source (aka -S) file. NOTE: there might be a limited number of scenarios in which this has security relevance.
- Record
DEBIAN-CVE-2017-11109- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-11109
7.8
Vim 8.0 allows attackers to cause a denial of service (invalid free) or possibly have unspecified other impact via a crafted source (aka -S) file. NOTE: there might be a limited number of scenarios in which this has security relevance.
- Record
UBUNTU-CVE-2017-11109- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUSN-4309-1 No score
vim vulnerabilities
It was discovered that Vim incorrectly handled certain sources. An attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 12.04 ESM, Ubuntu 14.04 ESM and Ubuntu 16.04 LTS (CVE-2017-11109)
It was discovered that Vim incorrectly handled certain files. An attacker could possibly use this issue to execute arbitrary code. This issue only affected Ubuntu 12.04 ESM and Ubuntu 14.04 ESM. (CVE-2017-5953)
It was discovered that Vim incorrectly handled certain inputs. An attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 16.06 LTS. (CVE-2018-20786)
It was discovered that Vim incorrectly handled certain inputs. An attacker could possibly use this issue to cause a denial of service or execute arbitrary code. This issue only affected Ubuntu 18.04 LTS and Ubuntu 19.10. (CVE-2019-20079)
It was discovered that Vim incorrectly handled certain files. An attacker could possibly use this issue to execute arbitrary code. This issue only affected Ubuntu 12.04 ESM, Ubuntu 14.04 ESM and Ubuntu 16.04 LTS. (CVE-2017-6349, CVE-2017-6350)
- Record
USN-4309-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
vimDebian:12 |
before 2:8.0.0197-5 | 2:8.0.0197-5 |
vimDebian:13 |
before 2:8.0.0197-5 | 2:8.0.0197-5 |
vimDebian:14 |
before 2:8.0.0197-5 | 2:8.0.0197-5 |
vimDebian:7 |
before 2:7.3.547-7+deb7u4, plus listed versions 2:7.3.547-72:7.3.547-7+deb7u12:7.3.547-7+deb7u22:7.3.547-7+deb7u3 |
2:7.3.547-7+deb7u4 |
vimDebian:8 |
before 2:7.4.488-7+deb8u4, plus listed versions 2:7.4.488-72:7.4.488-7+deb8u12:7.4.488-7+deb8u22:7.4.488-7+deb8u3 |
2:7.4.488-7+deb8u4 |
vimUbuntu:Pro:14.04:LTS |
before 2:7.4.052-1ubuntu3.1+esm1, plus listed versions 2:7.4.000-1ubuntu22:7.4.052-1ubuntu12:7.4.052-1ubuntu22:7.4.052-1ubuntu32:7.4.052-1ubuntu3.1 |
2:7.4.052-1ubuntu3.1+esm1 |
vimUbuntu:16.04:LTS |
before 2:7.4.1689-3ubuntu1.4, plus listed versions 2:7.4.712-2ubuntu42:7.4.826-1ubuntu12:7.4.826-1ubuntu22:7.4.826-1ubuntu32:7.4.963-1ubuntu1 Show 6 moreShow less2:7.4.963-1ubuntu42:7.4.963-1ubuntu52:7.4.1689-3ubuntu12:7.4.1689-3ubuntu1.12:7.4.1689-3ubuntu1.22:7.4.1689-3ubuntu1.3 |
2:7.4.1689-3ubuntu1.4 |
vimUbuntu:18.04:LTS |
before 2:8.0.1453-1ubuntu1.3, plus listed versions 2:8.0.0197-4ubuntu52:8.0.1144-1ubuntu12:8.0.1401-1ubuntu12:8.0.1401-1ubuntu22:8.0.1401-1ubuntu32:8.0.1453-1ubuntu12:8.0.1453-1ubuntu1.1 |
2:8.0.1453-1ubuntu1.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-11109 is a high vulnerability (CVSS 7.8) in Vim, published July 8, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.09%, the 65th percentile. Fixed in vim 2:8.0.0197-5.
References
bugzilla.redhat.com/show_bug.cgi?id=1468492
lists.debian.org/debian-lts-announce/2019/08/msg00003.html
usn.ubuntu.com/4309-1
nvd.nist.gov/vuln/detail/CVE-2017-11109
github.com/advisories/GHSA-hv76-654r-x97r
security-tracker.debian.org/tracker/CVE-2017-11109
Show 9 moreShow less
ubuntu.com/security/CVE-2017-11109
mail-archive.com/[email protected]/msg45274.html
ubuntu.com/security/notices/USN-4309-1
cve.org/CVERecord?id=CVE-2017-11109
ubuntu.com/security/CVE-2017-5953
ubuntu.com/security/CVE-2017-6349
ubuntu.com/security/CVE-2017-6350
ubuntu.com/security/CVE-2018-20786
ubuntu.com/security/CVE-2019-20079