Every CVE Search/ Get API key

CVE-2020-11937

Resource exhaustion vulnerability in whoopsie

5.5 MediumFix available

In whoopsie, parse_report() from whoopsie.c allows a local attacker to cause a denial of service via a crafted file. The DoS is caused by resource exhaustion due to a memory leak. Fixed in 0.2.52.5ubuntu0.5, 0.2.62ubuntu0.5 and 0.2.69ubuntu0.1.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.47%Down 0.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 5.5

Resource exhaustion vulnerability in whoopsie

In whoopsie, parse_report() from whoopsie.c allows a local attacker to cause a denial of service via a crafted file. The DoS is caused by resource exhaustion due to a memory leak. Fixed in 0.2.52.5ubuntu0.5, 0.2.62ubuntu0.5 and 0.2.69ubuntu0.1.

Record
CVE-2020-11937
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-400
Updated
2026-11-02
EUVDEUVD-2020-4274 5.5

In whoopsie, parse_report() from whoopsie.c allows a local attacker to cause a denial of service via a crafted file. The DoS is caused by resource exhaustion due to a memory leak. Fixed in 0.2.52.5ubuntu0.5, 0.2.62ubuntu0.5 and 0.2.69ubuntu0.1.

Record
EUVD-2020-4274
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-fcfw-r6pj-x447 No score

In whoopsie, parse_report() from whoopsie.c allows a local attacker to cause a denial of service...

In whoopsie, parse_report() from whoopsie.c allows a local attacker to cause a denial of service via a crafted file. The DoS is caused by resource exhaustion due to a memory leak. Fixed in 0.2.52.5ubuntu0.5, 0.2.62ubuntu0.5 and 0.2.69ubuntu0.1.

Record
GHSA-fcfw-r6pj-x447
Weakness
CWE-401
Updated
2026-11-02
NVD 5.5

In whoopsie, parse_report() from whoopsie.c allows a local attacker to cause a denial of service via a crafted file. The DoS is caused by resource exhaustion due to a memory leak. Fixed in 0.2.52.5ubuntu0.5, 0.2.62ubuntu0.5 and 0.2.69ubuntu0.1.

Record
CVE-2020-11937
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
2.1 LowAV:L/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-400, CWE-401
Updated
2026-11-02
OSVUBUNTU-CVE-2020-11937 5.5

In whoopsie, parse_report() from whoopsie.c allows a local attacker to cause a denial of service via a crafted file. The DoS is caused by resource exhaustion due to a memory leak. Fixed in 0.2.52.5ubuntu0.5, 0.2.62ubuntu0.5 and 0.2.69ubuntu0.1.

Record
UBUNTU-CVE-2020-11937
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUSN-4450-1 No score

whoopsie vulnerabilities

Seong-Joong Kim discovered that Whoopsie incorrectly handled memory. A local attacker could use this issue to cause Whoopsie to consume memory, resulting in a denial of service. (CVE-2020-11937)

Seong-Joong Kim discovered that Whoopsie incorrectly handled parsing files. A local attacker could use this issue to cause Whoopsie to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2020-12135)

Seong-Joong Kim discovered that Whoopsie incorrectly handled memory. A local attacker could use this issue to cause Whoopsie to consume memory, resulting in a denial of service. (CVE-2020-15570)

Record
USN-4450-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
whoopsie
Ubuntu:16.04:LTS
before 0.2.52.5ubuntu0.5, plus listed versions
0.2.490.2.500.2.510.2.520.2.52.1
Show 8 moreShow less
0.2.52.20.2.52.30.2.52.40.2.52.50.2.52.5ubuntu0.10.2.52.5ubuntu0.20.2.52.5ubuntu0.30.2.52.5ubuntu0.4
0.2.52.5ubuntu0.5
whoopsie
Ubuntu:18.04:LTS
before 0.2.62ubuntu0.5, plus listed versions
0.2.580.2.590.2.59build10.2.600.2.62
Show 4 moreShow less
0.2.62ubuntu0.10.2.62ubuntu0.20.2.62ubuntu0.30.2.62ubuntu0.4
0.2.62ubuntu0.5
whoopsie
Ubuntu:20.04:LTS
before 0.2.69ubuntu0.1, plus listed versions
0.2.660.2.670.2.680.2.69
0.2.69ubuntu0.1
whoopsie
Ubuntu:16.04:LTS
From an advisory covering 3 CVEs
before 0.2.52.5ubuntu0.5, plus listed versions
0.2.490.2.500.2.510.2.520.2.52.1
Show 8 moreShow less
0.2.52.20.2.52.30.2.52.40.2.52.50.2.52.5ubuntu0.10.2.52.5ubuntu0.20.2.52.5ubuntu0.30.2.52.5ubuntu0.4
0.2.52.5ubuntu0.5
whoopsie
Ubuntu:18.04:LTS
From an advisory covering 3 CVEs
before 0.2.62ubuntu0.5, plus listed versions
0.2.580.2.590.2.59build10.2.600.2.62
Show 4 moreShow less
0.2.62ubuntu0.10.2.62ubuntu0.20.2.62ubuntu0.30.2.62ubuntu0.4
0.2.62ubuntu0.5
whoopsie
Ubuntu:20.04:LTS
From an advisory covering 3 CVEs
before 0.2.69ubuntu0.1, plus listed versions
0.2.660.2.670.2.680.2.69
0.2.69ubuntu0.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-11937 is a medium vulnerability (CVSS 5.5) in Canonical Whoopsie, published June 11, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.47%, the 40th percentile. Fixed in whoopsie 0.2.52.5ubuntu0.5.

References

Show 4 moreShow less
MoveEnter Open