Every CVE Search/ Get API key

CVE-2020-15704

pppd arbitrary file read information disclosure vulnerability

5.5 MediumFix available

The modprobe child process in the ./debian/patches/load_ppp_generic_if_needed patch file incorrectly handled module loading. A local non-root attacker could exploit the MODPROBE_OPTIONS environment variable to read arbitrary root files. Fixed in 2.4.5-5ubuntu1.4, 2.4.5-5.1ubuntu2.3+esm2, 2.4.7-1+2ubuntu1.16.04.3, 2.4.7-2+2ubuntu1.3, 2.4.7-2+4.1ubuntu5.1, 2.4.7-2+4.1ubuntu6. Was ZDI-CAN-11504.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

0.36%Down 0.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 5.5

pppd arbitrary file read information disclosure vulnerability

The modprobe child process in the ./debian/patches/load_ppp_generic_if_needed patch file incorrectly handled module loading. A local non-root attacker could exploit the MODPROBE_OPTIONS environment variable to read arbitrary root files. Fixed in 2.4.5-5ubuntu1.4, 2.4.5-5.1ubuntu2.3+esm2, 2.4.7-1+2ubuntu1.16.04.3, 2.4.7-2+2ubuntu1.3, 2.4.7-2+4.1ubuntu5.1, 2.4.7-2+4.1ubuntu6. Was ZDI-CAN-11504.

Record
CVE-2020-15704
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
EUVDEUVD-2020-7690 5.5

The modprobe child process in the ./debian/patches/load_ppp_generic_if_needed patch file incorrectly handled module loading. A local non-root attacker could exploit the MODPROBE_OPTIONS environment variable to read arbitrary root files. Fixed in 2.4.5-5ubuntu1.4, 2.4.5-5.1ubuntu2.3+esm2, 2.4.7-1+2ubuntu1.16.04.3, 2.4.7-2+2ubuntu1.3, 2.4.7-2+4.1ubuntu5.1, 2.4.7-2+4.1ubuntu6. Was ZDI-CAN-11504.

Record
EUVD-2020-7690
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-2q4h-xfv6-4848 No score

The modprobe child process in the ./debian/patches/load_ppp_generic_if_needed patch file...

The modprobe child process in the ./debian/patches/load_ppp_generic_if_needed patch file incorrectly handled module loading. A local non-root attacker could exploit the MODPROBE_OPTIONS environment variable to read arbitrary root files. Fixed in 2.4.5-5ubuntu1.4, 2.4.5-5.1ubuntu2.3+esm2, 2.4.7-1+2ubuntu1.16.04.3, 2.4.7-2+2ubuntu1.3, 2.4.7-2+4.1ubuntu5.1, 2.4.7-2+4.1ubuntu6. Was ZDI-CAN-11504.

Record
GHSA-2q4h-xfv6-4848
Weakness
CWE-20
Updated
2026-11-02
NVD 5.5

The modprobe child process in the ./debian/patches/load_ppp_generic_if_needed patch file incorrectly handled module loading. A local non-root attacker could exploit the MODPROBE_OPTIONS environment variable to read arbitrary root files. Fixed in 2.4.5-5ubuntu1.4, 2.4.5-5.1ubuntu2.3+esm2, 2.4.7-1+2ubuntu1.16.04.3, 2.4.7-2+2ubuntu1.3, 2.4.7-2+4.1ubuntu5.1, 2.4.7-2+4.1ubuntu6. Was ZDI-CAN-11504.

Record
CVE-2020-15704
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
2.1 LowAV:L/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-200, CWE-20
Updated
2026-11-02
OSVUBUNTU-CVE-2020-15704 5.5

The modprobe child process in the ./debian/patches/load_ppp_generic_if_needed patch file incorrectly handled module loading. A local non-root attacker could exploit the MODPROBE_OPTIONS environment variable to read arbitrary root files. Fixed in 2.4.5-5ubuntu1.4, 2.4.5-5.1ubuntu2.3+esm2, 2.4.7-1+2ubuntu1.16.04.3, 2.4.7-2+2ubuntu1.3, 2.4.7-2+4.1ubuntu5.1, 2.4.7-2+4.1ubuntu6. Was ZDI-CAN-11504.

Record
UBUNTU-CVE-2020-15704
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVUSN-4451-1 No score

ppp vulnerability

Thomas Chauchefoin working with Trend Micro´s Zero Day Initiative, discovered that ppp incorrectly handled module loading. A local attacker could use this issue to load arbitrary kernel modules and possibly execute arbitrary code.

Record
USN-4451-1
Updated
2026-11-02
OSVUSN-4451-2 No score

ppp vulnerability

USN-4451-1 fixed a vulnerability in ppp. This update provides the corresponding update for Ubuntu 12.04 ESM and Ubuntu 14.04 ESM.

Original advisory details:

Thomas Chauchefoin working with Trend Micro´s Zero Day Initiative, discovered that ppp incorrectly handled module loading. A local attacker could use this issue to load arbitrary kernel modules and possibly execute arbitrary code.

Record
USN-4451-2
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ppp
Ubuntu:Pro:14.04:LTS
before 2.4.5-5.1ubuntu2.3+esm2, plus listed versions
2.4.5-5.1ubuntu22.4.5-5.1ubuntu2.12.4.5-5.1ubuntu2.22.4.5-5.1ubuntu2.32.4.5-5.1ubuntu2.3+esm1
2.4.5-5.1ubuntu2.3+esm2
ppp
Ubuntu:16.04:LTS
before 2.4.7-1+2ubuntu1.16.04.3, plus listed versions
2.4.6-3.1ubuntu12.4.7-1+1ubuntu12.4.7-1+2ubuntu12.4.7-1+2ubuntu1.16.04.12.4.7-1+2ubuntu1.16.04.2
2.4.7-1+2ubuntu1.16.04.3
ppp
Ubuntu:18.04:LTS
before 2.4.7-2+2ubuntu1.3, plus listed versions
2.4.7-1+2ubuntu12.4.7-1+4ubuntu12.4.7-1+4ubuntu32.4.7-2+1ubuntu12.4.7-2+2ubuntu12.4.7-2+2ubuntu1.12.4.7-2+2ubuntu1.2
2.4.7-2+2ubuntu1.3
ppp
Ubuntu:20.04:LTS
before 2.4.7-2+4.1ubuntu5.1, plus listed versions
2.4.7-2+4.1ubuntu42.4.7-2+4.1ubuntu5
2.4.7-2+4.1ubuntu5.1

History

History
RecordedChangedSources
aliases, productsEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-15704 is a medium vulnerability (CVSS 5.5) in Canonical Ppp, published August 4, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.36%, the 30th percentile. Fixed in ppp 2.4.5-5.1ubuntu2.3+esm2.

References

MoveEnter Open