CVE-2018-1000528
GONICUS GOsa version before commit 56070d6289d47ba3f5918885954dcceb75606001 contains a Cross Site...
GONICUS GOsa version before commit 56070d6289d47ba3f5918885954dcceb75606001 contains a Cross Site Scripting (XSS) vulnerability in change password form (html/password.php, #308) that can result in injection of arbitrary web script or HTML. This attack appear to be exploitable via the victim must open a specially crafted web page. This vulnerability appears to have been fixed in after commit 56070d6289d47ba3f5918885954dcceb75606001.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
GONICUS GOsa version before commit 56070d6289d47ba3f5918885954dcceb75606001 contains a Cross Site Scripting (XSS) vulnerability in change password form (html/password.php, #308) that can result in injection of arbitrary web script or HTML. This attack appear to be exploitable via the victim must open a specially crafted web page. This vulnerability appears to have been fixed in after commit 56070d6289d47ba3f5918885954dcceb75606001.
- Record
CVE-2018-1000528- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
GONICUS GOsa version before commit 56070d6289d47ba3f5918885954dcceb75606001 contains a Cross Site Scripting (XSS) vulnerability in change password form (html/password.php, #308) that can result in injection of arbitrary web script or HTML. This attack appear to be exploitable via the victim must open a specially crafted web page. This vulnerability appears to have been fixed in after commit 56070d6289d47ba3f5918885954dcceb75606001.
- Record
CVE-2018-1000528- Updated
- 2026-11-02
EUVDEUVD-2018-1921 No score
GONICUS GOsa version before commit 56070d6289d47ba3f5918885954dcceb75606001 contains a Cross Site Scripting (XSS) vulnerability in change password form (html/password.php, #308) that can result in injection of arbitrary web script or HTML. This attack appear to be exploitable via the victim must open a specially crafted web page. This vulnerability appears to have been fixed in after commit 56070d6289d47ba3f5918885954dcceb75606001.
- Record
EUVD-2018-1921- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-fh4v-6j27-m5mf
6.1
GONICUS GOsa version before commit 56070d6289d47ba3f5918885954dcceb75606001 contains a Cross Site...
GONICUS GOsa version before commit 56070d6289d47ba3f5918885954dcceb75606001 contains a Cross Site Scripting (XSS) vulnerability in change password form (html/password.php, #308) that can result in injection of arbitrary web script or HTML. This attack appear to be exploitable via the victim must open a specially crafted web page. This vulnerability appears to have been fixed in after commit 56070d6289d47ba3f5918885954dcceb75606001.
- Record
GHSA-fh4v-6j27-m5mf- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
GONICUS GOsa version before commit 56070d6289d47ba3f5918885954dcceb75606001 contains a Cross Site Scripting (XSS) vulnerability in change password form (html/password.php, #308) that can result in injection of arbitrary web script or HTML. This attack appear to be exploitable via the victim must open a specially crafted web page. This vulnerability appears to have been fixed in after commit 56070d6289d47ba3f5918885954dcceb75606001.
- Record
CVE-2018-1000528- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-1000528
6.1
GONICUS GOsa version before commit 56070d6289d47ba3f5918885954dcceb75606001 contains a Cross Site Scripting (XSS) vulnerability in change password form (html/password.php, #308) that can result in injection of arbitrary web script or HTML. This attack appear to be exploitable via the victim must open a specially crafted web page. This vulnerability appears to have been fixed in after commit 56070d6289d47ba3f5918885954dcceb75606001.
- Record
DEBIAN-CVE-2018-1000528- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-1000528
6.1
GONICUS GOsa version before commit 56070d6289d47ba3f5918885954dcceb75606001 contains a Cross Site Scripting (XSS) vulnerability in change password form (html/password.php, #308) that can result in injection of arbitrary web script or HTML. This attack appear to be exploitable via the victim must open a specially crafted web page. This vulnerability appears to have been fixed in after commit 56070d6289d47ba3f5918885954dcceb75606001.
- Record
UBUNTU-CVE-2018-1000528- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVUSN-4609-1 No score
gosa vulnerabilities
Fabian Henneke discovered that GOsa incorrectly handled client cookies. An authenticated user could exploit this with a crafted cookie to perform file deletions in the context of the user account that runs the web server. (CVE-2019-14466)
It was discovered that GOsa incorrectly handled user access control. A remote attacker could use this issue to log into any account with a username containing the word "success". (CVE-2019-11187)
Fabian Henneke discovered that GOsa was vulnerable to cross-site scripting attacks via the change password form. A remote attacker could use this flaw to run arbitrary web scripts. (CVE-2018-1000528)
- Record
USN-4609-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
gosaDebian:12 |
before 2.7.4+reloaded3-5 | 2.7.4+reloaded3-5 |
gosaDebian:13 |
before 2.7.4+reloaded3-5 | 2.7.4+reloaded3-5 |
gosaDebian:14 |
before 2.7.4+reloaded3-5 | 2.7.4+reloaded3-5 |
gosaDebian:8 |
before 2.7.4+reloaded2-1+deb8u3, plus listed versions 2.7.4+reloaded2-12.7.4+reloaded2-1+deb8u12.7.4+reloaded2-1+deb8u2 |
2.7.4+reloaded2-1+deb8u3 |
gosaDebian:9 |
before 2.7.4+reloaded2-13+deb9u1, plus listed versions 2.7.4+reloaded2-13 |
2.7.4+reloaded2-13+deb9u1 |
gosaUbuntu:16.04:LTS |
before 2.7.4+reloaded2-9ubuntu1.1, plus listed versions 2.7.4+reloaded2-22.7.4+reloaded2-52.7.4+reloaded2-62.7.4+reloaded2-72.7.4+reloaded2-82.7.4+reloaded2-92.7.4+reloaded2-9ubuntu1 |
2.7.4+reloaded2-9ubuntu1.1 |
gosaUbuntu:18.04:LTS |
All versions, plus listed versions 2.7.4+reloaded2-13ubuntu12.7.4+reloaded3-2ubuntu12.7.4+reloaded3-3 |
None known |
gosaUbuntu:16.04:LTS From an advisory covering 3 CVEs |
before 2.7.4+reloaded2-9ubuntu1.1, plus listed versions 2.7.4+reloaded2-22.7.4+reloaded2-52.7.4+reloaded2-62.7.4+reloaded2-72.7.4+reloaded2-82.7.4+reloaded2-92.7.4+reloaded2-9ubuntu1 |
2.7.4+reloaded2-9ubuntu1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-1000528 is a medium vulnerability (CVSS 6.1) in Gonicus Gosa, published June 26, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 46.1%, the 98th percentile. Fixed in gosa 2.7.4+reloaded3-5.