CVE-2016-8714
An exploitable buffer overflow vulnerability exists in the LoadEncoding functionality of the R...
An exploitable buffer overflow vulnerability exists in the LoadEncoding functionality of the R programming language version 3.3.0. A specially crafted R script can cause a buffer overflow resulting in a memory corruption. An attacker can send a malicious R script to trigger this vulnerability.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.5
An exploitable buffer overflow vulnerability exists in the LoadEncoding functionality of the R programming language version 3.3.0. A specially crafted R script can cause a buffer overflow resulting in a memory corruption. An attacker can send a malicious R script to trigger this vulnerability.
- Record
CVE-2016-8714- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
EUVDEUVD-2016-9553
7.5
An exploitable buffer overflow vulnerability exists in the LoadEncoding functionality of the R programming language version 3.3.0. A specially crafted R script can cause a buffer overflow resulting in a memory corruption. An attacker can send a malicious R script to trigger this vulnerability.
- Record
EUVD-2016-9553- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-468j-7q62-ffj2
7.5
An exploitable buffer overflow vulnerability exists in the LoadEncoding functionality of the R...
An exploitable buffer overflow vulnerability exists in the LoadEncoding functionality of the R programming language version 3.3.0. A specially crafted R script can cause a buffer overflow resulting in a memory corruption. An attacker can send a malicious R script to trigger this vulnerability.
- Record
GHSA-468j-7q62-ffj2- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-119, CWE-120
- Updated
- 2026-11-02
NVD
8.8
An exploitable buffer overflow vulnerability exists in the LoadEncoding functionality of the R programming language version 3.3.0. A specially crafted R script can cause a buffer overflow resulting in a memory corruption. An attacker can send a malicious R script to trigger this vulnerability.
- Record
CVE-2016-8714- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-120
- Updated
- 2026-11-02
OSV
8.8
An exploitable buffer overflow vulnerability exists in the LoadEncoding functionality of the R programming language version 3.3.0. A specially crafted R script can cause a buffer overflow resulting in a memory corruption. An attacker can send a malicious R script to trigger this vulnerability.
- Record
CVE-2016-8714- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2016-8714
8.8
An exploitable buffer overflow vulnerability exists in the LoadEncoding functionality of the R programming language version 3.3.0. A specially crafted R script can cause a buffer overflow resulting in a memory corruption. An attacker can send a malicious R script to trigger this vulnerability.
- Record
DEBIAN-CVE-2016-8714- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-8714
8.8
An exploitable buffer overflow vulnerability exists in the LoadEncoding functionality of the R programming language version 3.3.0. A specially crafted R script can cause a buffer overflow resulting in a memory corruption. An attacker can send a malicious R script to trigger this vulnerability.
- Record
UBUNTU-CVE-2016-8714- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2017-0236 No score
Updated R-base packages fix security vulnerability
Cory Duplantis discovered a buffer overflow in the R programming language. A malformed encoding file may lead to the execution of arbitrary code during PDF generation (CVE-2016-8714).
- Record
MGASA-2017-0236- Updated
- 2026-11-02
OSVUSN-4799-1 No score
r-base vulnerability
It was discovered that a buffer overflow in R causes memory corruption. An attacker could possibly use this to cause a denial of service or execute arbitrary code.
- Record
USN-4799-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
r-baseDebian:12 |
before 3.3.3-1 | 3.3.3-1 |
r-baseDebian:13 |
before 3.3.3-1 | 3.3.3-1 |
r-baseDebian:14 |
before 3.3.3-1 | 3.3.3-1 |
r-baseDebian:7 |
before 2.15.1-4+deb7u1, plus listed versions 2.15.1-4 |
2.15.1-4+deb7u1 |
r-baseDebian:8 |
before 3.1.1-1+deb8u1, plus listed versions 3.1.1-1 |
3.1.1-1+deb8u1 |
R-baseMageia:5 |
before 3.1.2-2.1.mga5 | 3.1.2-2.1.mga5 |
r-baseUbuntu:Pro:14.04:LTS |
before 3.0.2-1ubuntu1.1~esm2, plus listed versions 3.0.1-3ubuntu13.0.2-1ubuntu1 |
3.0.2-1ubuntu1.1~esm2 |
r-baseUbuntu:Pro:16.04:LTS |
before 3.2.3-4ubuntu0.1~esm3, plus listed versions 3.2.2-13.2.2.20151203-13.2.3-13.2.3-23.2.3-4 |
3.2.3-4ubuntu0.1~esm3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, products | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-8714 is a high vulnerability (CVSS 7.5) in R-project R, published March 10, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.40%, the 84th percentile. Fixed in r-base 3.3.3-1.