Every CVE Search/ Get API key

CVE-2021-35940

Regression of CVE-2017-12613

7.1 HighFix available

An out-of-bounds array read in the apr_time_exp*() functions was fixed in the Apache Portable Runtime 1.6.3 release (CVE-2017-12613). The fix for this issue was not carried forward to the APR 1.7.x branch, and hence version 1.7.0 regressed compared to 1.6.3 and is vulnerable to the same issue.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
High

Exploit likelihood

1.19%Down 0.5 points since Aug 24, 2021
90%50%10%1%

What each source reports

NVD Score used 7.1

An out-of-bounds array read in the apr_time_exp*() functions was fixed in the Apache Portable Runtime 1.6.3 release (CVE-2017-12613). The fix for this issue was not carried forward to the APR 1.7.x branch, and hence version 1.7.0 regressed compared to 1.6.3 and is vulnerable to the same issue.

Record
CVE-2021-35940
CVSS 3.1
7.1 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H
CVSS 2.0
3.6 LowAV:L/AC:L/Au:N/C:P/I:N/A:P
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

Regression of CVE-2017-12613

An out-of-bounds array read in the apr_time_exp*() functions was fixed in the Apache Portable Runtime 1.6.3 release (CVE-2017-12613). The fix for this issue was not carried forward to the APR 1.7.x branch, and hence version 1.7.0 regressed compared to 1.6.3 and is vulnerable to the same issue.

Record
CVE-2021-35940
Updated
2026-11-02
EUVDEUVD-2021-22575 No score

An out-of-bounds array read in the apr_time_exp*() functions was fixed in the Apache Portable Runtime 1.6.3 release (CVE-2017-12613). The fix for this issue was not carried forward to the APR 1.7.x branch, and hence version 1.7.0 regressed compared to 1.6.3 and is vulnerable to the same issue.

Record
EUVD-2021-22575
Updated
2026-11-03
GitHub AdvisoriesGHSA-95qq-4mqm-pp5g 7.1

An out-of-bounds array read in the apr_time_exp*() functions was fixed in the Apache Portable...

An out-of-bounds array read in the apr_time_exp*() functions was fixed in the Apache Portable Runtime 1.6.3 release (CVE-2017-12613). The fix for this issue was not carried forward to the APR 1.7.x branch, and hence version 1.7.0 regressed compared to 1.6.3 and is vulnerable to the same issue.

Record
GHSA-95qq-4mqm-pp5g
CVSS 3.1
7.1 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H
Weakness
CWE-125
Updated
2026-11-02
OSVALPINE-CVE-2021-35940 7.1

An out-of-bounds array read in the apr_time_exp*() functions was fixed in the Apache Portable Runtime 1.6.3 release (CVE-2017-12613). The fix for this issue was not carried forward to the APR 1.7.x branch, and hence version 1.7.0 regressed compared to 1.6.3 and is vulnerable to the same issue.

Record
ALPINE-CVE-2021-35940
CVSS 3.1
7.1 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSVBELL-CVE-2021-35940 7.1

CVE-2021-35940 does not affect BellSoft software

Record
BELL-CVE-2021-35940
CVSS 3.1
7.1 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H
Updated
2026-11-02
Show 7 moreShow less
OSV 7.1

An out-of-bounds array read in the apr_time_exp*() functions was fixed in the Apache Portable Runtime 1.6.3 release (CVE-2017-12613). The fix for this issue was not carried forward to the APR 1.7.x branch, and hence version 1.7.0 regressed compared to 1.6.3 and is vulnerable to the same issue.

Record
CVE-2021-35940
CVSS 3.1
7.1 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2021-35940 7.1

An out-of-bounds array read in the apr_time_exp*() functions was fixed in the Apache Portable Runtime 1.6.3 release (CVE-2017-12613). The fix for this issue was not carried forward to the APR 1.7.x branch, and hence version 1.7.0 regressed compared to 1.6.3 and is vulnerable to the same issue.

Record
DEBIAN-CVE-2021-35940
CVSS 3.1
7.1 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2021-35940 7.1

An out-of-bounds array read in the apr_time_exp*() functions was fixed in the Apache Portable Runtime 1.6.3 release (CVE-2017-12613). The fix for this issue was not carried forward to the APR 1.7.x branch, and hence version 1.7.0 regressed compared to 1.6.3 and is vulnerable to the same issue.

Record
UBUNTU-CVE-2021-35940
CVSS 3.1
7.1 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSVBIT-apr-2021-35940 No score

Regression of CVE-2017-12613

An out-of-bounds array read in the apr_time_exp*() functions was fixed in the Apache Portable Runtime 1.6.3 release (CVE-2017-12613). The fix for this issue was not carried forward to the APR 1.7.x branch, and hence version 1.7.0 regressed compared to 1.6.3 and is vulnerable to the same issue.

Record
BIT-apr-2021-35940
Updated
2026-11-02
OSVMGASA-2021-0428 No score

Updated apr packages fix security vulnerability

An out-of-bounds array read in the apr_time_exp*() functions was fixed in the Apache Portable Runtime 1.6.3 release (CVE-2017-12613). The fix for this issue was not carried forward to the APR 1.7.x branch, and hence version 1.7.0 regressed compared to 1.6.3 and is vulnerable to the same issue. (CVE-2021-35940)

Record
MGASA-2021-0428
Updated
2026-11-02
OSVopenSUSE-SU-2024:11865-1 No score

apr-devel-1.7.0-4.1 on GA media

These are all security issues fixed in the apr-devel-1.7.0-4.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11865-1
Updated
2026-11-02
OSVUSN-5056-1 No score

apr vulnerability

It was discovered that APR incorrectly handled certain inputs. An attacker could possibly use this issue to expose sensitive information.

Record
USN-5056-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
apr
Alpine:v3.14
before 1.7.0-r1
1.7.0-r1
apr
Alpine:v3.15
before 1.7.0-r1
1.7.0-r1
apr
Alpine:v3.16
before 1.7.0-r2
1.7.0-r2
apr
Alpine:v3.17
before 1.7.0-r2
1.7.0-r2
apr
Alpine:v3.18
before 1.7.0-r2
1.7.0-r2
apr
Alpine:v3.19
before 1.7.0-r2
1.7.0-r2
apr
Alpine:v3.20
before 1.7.0-r2
1.7.0-r2
apr
Alpine:v3.21
before 1.7.0-r2
1.7.0-r2
apr
Alpine:v3.22
before 1.7.0-r2
1.7.0-r2
apr
Alpine:v3.23
before 1.7.0-r2
1.7.0-r2
Show 10 moreShow less
Affected packages
PackageAffectedFixed
apr
Alpine:v3.24
before 1.7.0-r2
1.7.0-r2
apr
Bitnami
1.7.0 up to 1.7.1
1.7.1
apr
Debian:12
before 1.7.0-7
1.7.0-7
apr
Debian:13
before 1.7.0-7
1.7.0-7
apr
Debian:14
before 1.7.0-7
1.7.0-7
apr
Mageia:8
before 1.7.0-3.2.mga8
1.7.0-3.2.mga8
apr
Ubuntu:Pro:14.04:LTS
before 1.5.0-1ubuntu0.1~esm1, plus listed versions
1.4.8-1ubuntu11.4.8-21.4.8-31.5.0-1
1.5.0-1ubuntu0.1~esm1
apr
Ubuntu:Pro:16.04:LTS
before 1.5.2-3ubuntu0.1~esm1, plus listed versions
1.5.2-3
1.5.2-3ubuntu0.1~esm1
apr
Ubuntu:22.04:LTS
before 1.7.0-6ubuntu1
1.7.0-6ubuntu1
apr
openSUSE:Tumbleweed
before 1.7.0-4.1
1.7.0-4.1

History

History
RecordedChangedSources
aliases, productsEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-35940 is a high vulnerability (CVSS 7.1) in Apache Portable Runtime, published August 23, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.19%, the 67th percentile. Fixed in apr 1.7.0-r1.

References

Show 33 moreShow less
MoveEnter Open