CVE-2022-1804
Accountsservice incorrectly drops privileges
accountsservice no longer drops permissions when writting .pam_environment
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
5.5
Accountsservice incorrectly drops privileges
accountsservice no longer drops permissions when writting .pam_environment
- Record
CVE-2022-1804- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-269
- Updated
- 2026-11-02
EUVDEUVD-2022-25083
5.5
accountsservice no longer drops permissions when writting .pam_environment
- Record
EUVD-2022-25083- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-v7v5-m765-h4w4
5.5
accountsservice no longer drops permissions when writting .pam_environment
accountsservice no longer drops permissions when writting .pam_environment
- Record
GHSA-v7v5-m765-h4w4- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-269
- Updated
- 2026-11-02
NVD
5.5
accountsservice no longer drops permissions when writting .pam_environment
- Record
CVE-2022-1804- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-269
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2022-1804
5.5
accountsservice no longer drops permissions when writting .pam_environment
- Record
UBUNTU-CVE-2022-1804- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVAZL-66686 No score
CVE-2022-1804 affecting package accountsservice 0.6.55-4
accountsservice no longer drops permissions when writting .pam_environment
- Record
AZL-66686- Updated
- 2026-11-02
OSVUSN-5439-1 No score
accountsservice vulnerability
Gunnar Hjalmarsson discovered that AccountsService incorrectly dropped privileges. A local user could possibly use this issue to cause AccountsService to crash or stop responding, resulting in a denial of service. (CVE-2022-1804)
- Record
USN-5439-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
accountsserviceAzure Linux:2 |
through 0.6.55-4 | None known |
accountsserviceUbuntu:22.04:LTS |
before 22.07.5-2ubuntu1.3, plus listed versions 0.6.55-0ubuntu140.6.55-3ubuntu10.6.55-3ubuntu20.6.55-3ubuntu40.6.55-3ubuntu50.6.55-3ubuntu622.07.5-2ubuntu1 |
22.07.5-2ubuntu1.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-1804 is a medium vulnerability (CVSS 5.5) in Canonical Accountsservice, published May 24, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.14%, the 3rd percentile. Fixed in accountsservice 22.07.5-2ubuntu1.3.