Every CVE Search/ Get API key

CVE-2021-35452

An Incorrect Access Control vulnerability exists in libde265 v1.0.8 due to a SEGV in slice.cc.

6.5 MediumFix available

An Incorrect Access Control vulnerability exists in libde265 v1.0.8 due to a SEGV in slice.cc.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.42%Up 1.0 points since Jan 11, 2022
90%50%10%1%

What each source reports

NVD Score used 6.5

An Incorrect Access Control vulnerability exists in libde265 v1.0.8 due to a SEGV in slice.cc.

Record
CVE-2021-35452
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

An Incorrect Access Control vulnerability exists in libde265 v1.0.8 due to a SEGV in slice.cc.

Record
CVE-2021-35452
Updated
2026-11-02
EUVDEUVD-2021-22094 No score

An Incorrect Access Control vulnerability exists in libde265 v1.0.8 due to a SEGV in slice.cc.

Record
EUVD-2021-22094
Updated
2026-11-03
GitHub AdvisoriesGHSA-cqfh-gggg-7mmp 6.5

An Incorrect Access Control vulnerability exists in libde265 v1.0.8 due to a SEGV in slice.cc.

An Incorrect Access Control vulnerability exists in libde265 v1.0.8 due to a SEGV in slice.cc.

Record
GHSA-cqfh-gggg-7mmp
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVALPINE-CVE-2021-35452 6.5

An Incorrect Access Control vulnerability exists in libde265 v1.0.8 due to a SEGV in slice.cc.

Record
ALPINE-CVE-2021-35452
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSV 6.5

An Incorrect Access Control vulnerability exists in libde265 v1.0.8 due to a SEGV in slice.cc.

Record
CVE-2021-35452
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVDEBIAN-CVE-2021-35452 6.5

An Incorrect Access Control vulnerability exists in libde265 v1.0.8 due to a SEGV in slice.cc.

Record
DEBIAN-CVE-2021-35452
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2021-35452 6.5

An Incorrect Access Control vulnerability exists in libde265 v1.0.8 due to a SEGV in slice.cc.

Record
UBUNTU-CVE-2021-35452
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2023-0093 No score

Updated libde265 packages fix security vulnerability

libde265 has been updated to version 1.0.11 to fix many security issues.

Record
MGASA-2023-0093
Updated
2026-11-02
OSVUSN-6627-1 No score

libde265 vulnerabilities

It was discovered that libde265 could be made to read out of bounds. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service. (CVE-2021-35452, CVE-2021-36411, CVE-2022-43238, CVE-2022-43241, CVE-2022-43242)

It was discovered that libde265 did not properly manage memory. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service or execute arbitrary code. This issue only affected Ubuntu 22.04 LTS. (CVE-2021-36408)

It was discovered that libde265 contained a logical error. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service. (CVE-2021-36409)

It was discovered that libde265 could be made to write out of bounds. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service or execute arbitrary code. (CVE-2021-36410, CVE-2022-43235, CVE-2022-43236, CVE-2022-43237, CVE-2022-43239, CVE-2022-43240, CVE-2022-43243, CVE-2022-43248, CVE-2022-43252, CVE-2022-43253)

It was discovered that libde265 could be made to write out of bounds. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service or execute arbitrary code. This issue only affected Ubuntu 22.04 LTS. (CVE-2022-1253)

Record
USN-6627-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libde265
Alpine:v3.14
before 1.0.8-r2
1.0.8-r2
libde265
Alpine:v3.15
before 1.0.8-r2
1.0.8-r2
libde265
Alpine:v3.16
before 1.0.8-r2
1.0.8-r2
libde265
Alpine:v3.17
before 1.0.8-r2
1.0.8-r2
libde265
Alpine:v3.18
before 1.0.8-r2
1.0.8-r2
libde265
Alpine:v3.19
before 1.0.8-r2
1.0.8-r2
libde265
Alpine:v3.20
before 1.0.8-r2
1.0.8-r2
libde265
Alpine:v3.21
before 1.0.8-r2
1.0.8-r2
libde265
Alpine:v3.22
before 1.0.8-r2
1.0.8-r2
libde265
Alpine:v3.23
before 1.0.8-r2
1.0.8-r2
Show 16 moreShow less
Affected packages
PackageAffectedFixed
libde265
Alpine:v3.24
before 1.0.8-r2
1.0.8-r2
libde265
Debian:12
before 1.0.8-1.1
1.0.8-1.1
libde265
Debian:13
before 1.0.8-1.1
1.0.8-1.1
libde265
Debian:14
before 1.0.8-1.1
1.0.8-1.1
libde265
Debian:10
From an advisory covering 16 CVEs
before 1.0.3-1+deb10u1, plus listed versions
1.0.3-1
1.0.3-1+deb10u1
libde265
Debian:11
From an advisory covering 46 CVEs
before 1.0.11-0+deb11u1, plus listed versions
1.0.8-11.0.8-1.11.0.9-11.0.9-1.1
1.0.11-0+deb11u1
libde265
Mageia:8
From an advisory covering 46 CVEs
before 1.0.11-1.mga8
1.0.11-1.mga8
libde265
Mageia:8
From an advisory covering 46 CVEs
before 1.0.11-1.mga8.tainted
1.0.11-1.mga8.tainted
libde265
Ubuntu:Pro:16.04:LTS
before 1.0.2-2ubuntu0.16.04.1~esm2, plus listed versions
1.0.2-1build11.0.2-21.0.2-2ubuntu0.16.04.1~esm1
1.0.2-2ubuntu0.16.04.1~esm2
libde265
Ubuntu:Pro:18.04:LTS
before 1.0.2-2ubuntu0.18.04.1~esm2, plus listed versions
1.0.2-2build11.0.2-2ubuntu0.18.04.1~esm1
1.0.2-2ubuntu0.18.04.1~esm2
libde265
Ubuntu:20.04:LTS
before 1.0.4-1ubuntu0.2, plus listed versions
1.0.3-1build11.0.4-11.0.4-1build11.0.4-1ubuntu0.1
1.0.4-1ubuntu0.2
libde265
Ubuntu:22.04:LTS
before 1.0.8-1ubuntu0.1, plus listed versions
1.0.8-1
1.0.8-1ubuntu0.1
libde265
Ubuntu:Pro:16.04:LTS
From an advisory covering 18 CVEs
before 1.0.2-2ubuntu0.16.04.1~esm2, plus listed versions
1.0.2-1build11.0.2-21.0.2-2ubuntu0.16.04.1~esm1
1.0.2-2ubuntu0.16.04.1~esm2
libde265
Ubuntu:Pro:18.04:LTS
From an advisory covering 18 CVEs
before 1.0.2-2ubuntu0.18.04.1~esm2, plus listed versions
1.0.2-2build11.0.2-2ubuntu0.18.04.1~esm1
1.0.2-2ubuntu0.18.04.1~esm2
libde265
Ubuntu:20.04:LTS
From an advisory covering 18 CVEs
before 1.0.4-1ubuntu0.2, plus listed versions
1.0.3-1build11.0.4-11.0.4-1build11.0.4-1ubuntu0.1
1.0.4-1ubuntu0.2
libde265
Ubuntu:22.04:LTS
From an advisory covering 18 CVEs
before 1.0.8-1ubuntu0.1, plus listed versions
1.0.8-1
1.0.8-1ubuntu0.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-35452 is a medium vulnerability (CVSS 6.5) in Struktur Libde265, published January 10, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.42%, the 72nd percentile. Fixed in libde265 1.0.8-r2.

References

Show 26 moreShow less
MoveEnter Open