Every CVE Search/ Get API key

CVE-2023-4508

Denial of Service in Gerbv

5.5 MediumFix available

A user able to control file input to Gerbv, between versions 2.4.0 and 2.10.0, can cause a crash and cause denial-of-service with a specially crafted Gerber RS-274X file.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.33%Up 0.3 points since Aug 25, 2023
90%50%10%1%

What each source reports

CVE List Score used 5.5

Denial of Service in Gerbv

A user able to control file input to Gerbv, between versions 2.4.0 and 2.10.0, can cause a crash and cause denial-of-service with a specially crafted Gerber RS-274X file.

Record
CVE-2023-4508
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-824
Updated
2026-11-02
EUVDEUVD-2023-54363 5.5

A user able to control file input to Gerbv, between versions 2.4.0 and 2.10.0, can cause a crash and cause denial-of-service with a specially crafted Gerber RS-274X file.

Record
EUVD-2023-54363
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-m4qj-9cr4-hrw4 5.5

A user able to control file input to Gerbv, between versions 2.4.0 and 2.10.0, can cause a crash...

A user able to control file input to Gerbv, between versions 2.4.0 and 2.10.0, can cause a crash and cause denial-of-service with a specially crafted Gerber RS-274X file.

Record
GHSA-m4qj-9cr4-hrw4
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-824
Updated
2026-11-02
NVD 5.5

A user able to control file input to Gerbv, between versions 2.4.0 and 2.10.0, can cause a crash and cause denial-of-service with a specially crafted Gerber RS-274X file.

Record
CVE-2023-4508
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-824
Updated
2026-11-02
OSV 5.5

Denial of Service in Gerbv

A user able to control file input to Gerbv, between versions 2.4.0 and 2.10.0, can cause a crash and cause denial-of-service with a specially crafted Gerber RS-274X file.

Record
CVE-2023-4508
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-824
Updated
2026-11-02
OSVDEBIAN-CVE-2023-4508 5.5

A user able to control file input to Gerbv, between versions 2.4.0 and 2.10.0, can cause a crash and cause denial-of-service with a specially crafted Gerber RS-274X file.

Record
DEBIAN-CVE-2023-4508
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2023-4508 5.5

A user able to control file input to Gerbv, between versions 2.4.0 and 2.10.0, can cause a crash and cause denial-of-service with a specially crafted Gerber RS-274X file.

Record
UBUNTU-CVE-2023-4508
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2024:13474-1 No score

gerbv-2.10.0-1.1 on GA media

These are all security issues fixed in the gerbv-2.10.0-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:13474-1
Updated
2026-11-02
OSVUSN-6760-1 No score

gerbv vulnerability

George-Andrei Iosif and David Fernandez Gonzalez discovered that Gerbv did not properly initialize a data structure when parsing certain nested RS-274X format files. If a user were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service (application crash).

Record
USN-6760-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gerbv
Debian:12
All versions, plus listed versions
2.10.0-12.10.0-22.9.6-12.9.8-1
None known
gerbv
Debian:13
before 2.10.0-1
2.10.0-1
gerbv
Debian:10
From an advisory covering 3 CVEs
before 2.7.0-1+deb10u3, plus listed versions
2.7.0-12.7.0-1+deb10u12.7.0-1+deb10u2
2.7.0-1+deb10u3
gerbv
Ubuntu:Pro:14.04:LTS
before 2.6.0-1ubuntu0.14.04.1~esm2, plus listed versions
2.6.0-12.6.0-1ubuntu0.14.04.1~esm1
2.6.0-1ubuntu0.14.04.1~esm2
gerbv
Ubuntu:Pro:16.04:LTS
before 2.6.0-1ubuntu0.16.04.1~esm2, plus listed versions
2.6.0-12.6.0-1ubuntu0.16.04.1~esm1
2.6.0-1ubuntu0.16.04.1~esm2
gerbv
Ubuntu:Pro:18.04:LTS
before 2.6.1-3ubuntu0.1~esm2, plus listed versions
2.6.1-22.6.1-32.6.1-3ubuntu0.1~esm1
2.6.1-3ubuntu0.1~esm2
gerbv
Ubuntu:20.04:LTS
before 2.7.0-1ubuntu0.2, plus listed versions
2.7.0-12.7.0-1ubuntu0.1
2.7.0-1ubuntu0.2
gerbv
Ubuntu:Pro:22.04:LTS
before 2.8.2-1ubuntu0.1~esm2, plus listed versions
2.7.0-22.7.1-12.8.0-12.8.1-12.8.2-12.8.2-1ubuntu0.1~esm1
2.8.2-1ubuntu0.1~esm2

History

History
RecordedChangedSources
affected, facts
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-4508 is a medium vulnerability (CVSS 5.5) in Gerbv, published August 24, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.33%, the 26th percentile. Fixed in gerbv 2.10.0-1.

References

Show 8 moreShow less
MoveEnter Open