Every CVE Search/ Get API key

CVE-2022-0856

libcaca is affected by a Divide By Zero issue via img2txt, which allows a remote malicious user...

6.5 MediumFix available

libcaca is affected by a Divide By Zero issue via img2txt, which allows a remote malicious user to cause a Denial of Service

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

2.75%Up 1.9 points since Mar 9, 2022
90%50%10%1%

What each source reports

NVD Score used 6.5

libcaca is affected by a Divide By Zero issue via img2txt, which allows a remote malicious user to cause a Denial of Service

Record
CVE-2022-0856
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-369
Updated
2026-11-02
CVE List No score

libcaca is affected by a Divide By Zero issue via img2txt, which allows a remote malicious user to cause a Denial of Service

Record
CVE-2022-0856
Weakness
CWE-369
Updated
2026-11-02
EUVDEUVD-2022-15899 No score

libcaca is affected by a Divide By Zero issue via img2txt, which allows a remote malicious user to cause a Denial of Service

Record
EUVD-2022-15899
Updated
2026-11-03
GitHub AdvisoriesGHSA-p2c9-9qhg-mq4q 6.5

libcaca is affected by a Divide By Zero issue via img2txt, which allows a remote malicious user...

libcaca is affected by a Divide By Zero issue via img2txt, which allows a remote malicious user to cause a Denial of Service

Record
GHSA-p2c9-9qhg-mq4q
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-369
Updated
2026-11-02
OSVDEBIAN-CVE-2022-0856 6.5

libcaca is affected by a Divide By Zero issue via img2txt, which allows a remote malicious user to cause a Denial of Service

Record
DEBIAN-CVE-2022-0856
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-03
OSVUBUNTU-CVE-2022-0856 6.5

libcaca is affected by a Divide By Zero issue via img2txt, which allows a remote malicious user to cause a Denial of Service

Record
UBUNTU-CVE-2022-0856
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 6 moreShow less
OSV No score

libcaca is affected by a Divide By Zero issue via img2txt, which allows a remote malicious user to cause a Denial of Service

Record
CVE-2022-0856
Weakness
CWE-369
Updated
2026-11-02
OSVMGASA-2022-0172 No score

Updated libcaca packages fix security vulnerability

libcaca is affected by a Divide By Zero issue via img2txt, which allows a remote malicious user to cause a Denial of Service. (CVE-2022-0856)

Record
MGASA-2022-0172
Updated
2026-11-02
OSVopenSUSE-SU-2024:12029-1 No score

caca-utils-0.99.beta19.git20171003-9.1 on GA media

These are all security issues fixed in the caca-utils-0.99.beta19.git20171003-9.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:12029-1
Updated
2026-11-02
OSVSUSE-SU-2022:1476-1 No score

Security update for libcaca

This update for libcaca fixes the following issues:

  • CVE-2022-0856: Fixed a divide by zero issue which could be exploited to cause an application crash (bsc#1197028).
Record
SUSE-SU-2022:1476-1
Updated
2026-11-02
OSVSUSE-SU-2022:1508-1 No score

Security update for libcaca

This update for libcaca fixes the following issues:

  • CVE-2022-0856: Fixed a divide by zero issue which could be exploited to cause an application crash (bsc#1197028).
Record
SUSE-SU-2022:1508-1
Updated
2026-11-02
OSVUSN-7943-1 No score

libcaca vulnerability

Han Zheng discovered that libcaca incorrectly handled certain images. An attacker could possibly use this issue to cause libcaca to crash.

Record
USN-7943-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libcaca
Debian:12
All versions, plus listed versions
0.99.beta20-30.99.beta20-3+deb12u10.99.beta20-40.99.beta20-50.99.beta20-60.99.beta20-70.99.beta20-8
None known
libcaca
Debian:13
All versions, plus listed versions
0.99.beta20-50.99.beta20-5+deb13u10.99.beta20-60.99.beta20-70.99.beta20-8
None known
libcaca
Debian:14
before 0.99.beta20-8, plus listed versions
0.99.beta20-50.99.beta20-60.99.beta20-7
0.99.beta20-8
libcaca
Mageia:8
before 0.99-0.beta19.5.3.mga8
0.99-0.beta19.5.3.mga8
libcaca
SUSE:Linux Enterprise Module for Basesystem 15 SP3
before 0.99.beta19.git20171003-150200.11.6.1
0.99.beta19.git20171003-150200.11.6.1
libcaca
SUSE:Linux Enterprise Real Time 15 SP2
before 0.99.beta19.git20171003-150200.11.6.1
0.99.beta19.git20171003-150200.11.6.1
libcaca
openSUSE:Leap 15.3
before 0.99.beta19.git20171003-150200.11.6.1
0.99.beta19.git20171003-150200.11.6.1
libcaca
openSUSE:Leap 15.4
before 0.99.beta19.git20171003-150200.11.6.1
0.99.beta19.git20171003-150200.11.6.1
libcaca
SUSE:Linux Enterprise Software Development Kit 12 SP5
before 0.99.beta18-14.9.1
0.99.beta18-14.9.1
libcaca
SUSE:Linux Enterprise Server 12 SP5
before 0.99.beta18-14.9.1
0.99.beta18-14.9.1
Show 8 moreShow less
Affected packages
PackageAffectedFixed
libcaca
SUSE:Linux Enterprise Server for SAP Applications 12 SP5
before 0.99.beta18-14.9.1
0.99.beta18-14.9.1
libcaca
Ubuntu:Pro:14.04:LTS
before 0.99.beta18-1ubuntu5.1+esm3, plus listed versions
0.99.beta18-1ubuntu20.99.beta18-1ubuntu30.99.beta18-1ubuntu40.99.beta18-1ubuntu50.99.beta18-1ubuntu5.10.99.beta18-1ubuntu5.1+esm10.99.beta18-1ubuntu5.1+esm2
0.99.beta18-1ubuntu5.1+esm3
libcaca
Ubuntu:Pro:16.04:LTS
before 0.99.beta19-2ubuntu0.16.04.2+esm2, plus listed versions
0.99.beta19-2build2~gcc5.10.99.beta19-2build2~gcc5.20.99.beta19-2ubuntu0.16.04.10.99.beta19-2ubuntu0.16.04.20.99.beta19-2ubuntu0.16.04.2+esm1
0.99.beta19-2ubuntu0.16.04.2+esm2
libcaca
Ubuntu:Pro:18.04:LTS
before 0.99.beta19-2ubuntu0.18.04.3+esm1, plus listed versions
0.99.beta19-2build2~gcc5.20.99.beta19-2build2~gcc5.30.99.beta19-2ubuntu0.18.04.10.99.beta19-2ubuntu0.18.04.20.99.beta19-2ubuntu0.18.04.3
0.99.beta19-2ubuntu0.18.04.3+esm1
libcaca
Ubuntu:Pro:20.04:LTS
before 0.99.beta19-2.1ubuntu1.20.04.2+esm1, plus listed versions
0.99.beta19-2.10.99.beta19-2.1ubuntu10.99.beta19-2.1ubuntu1.20.04.10.99.beta19-2.1ubuntu1.20.04.2
0.99.beta19-2.1ubuntu1.20.04.2+esm1
libcaca
Ubuntu:22.04:LTS
before 0.99.beta19-2.2ubuntu4.1, plus listed versions
0.99.beta19-2.2ubuntu20.99.beta19-2.2ubuntu30.99.beta19-2.2ubuntu4
0.99.beta19-2.2ubuntu4.1
libcaca
Ubuntu:24.04:LTS
before 0.99.beta20-4ubuntu0.1, plus listed versions
0.99.beta20-3build10.99.beta20-40.99.beta20-4build10.99.beta20-4build2
0.99.beta20-4ubuntu0.1
libcaca
Ubuntu:25.10
before 0.99.beta20-5ubuntu0.25.10.1, plus listed versions
0.99.beta20-5
0.99.beta20-5ubuntu0.25.10.1

History

History
RecordedChangedSources
aliases, productsEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-0856 is a medium vulnerability (CVSS 6.5) in Cacalabs Libcaca, published March 8, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.75%, the 86th percentile. Fixed in libcaca 0.99.beta20-8.

References

Show 15 moreShow less
MoveEnter Open