USN-8563-4
nginx regression
USN-8563-4 is a vulnerability with no CVSS score yet in nginx, published August 19, 2026. No source lists public exploit code. Fixed in nginx 1.18.0-6ubuntu14.20.
USN-8563-3 fixed a vulnerability in nginx. The fix introduced a regression in certain environments. This update reverts the fix for CVE-2026-42533 pending further investigation.
We apologize for the inconvenience.
Original advisory details:
It was discovered that nginx incorrectly handled certain map directives using regex matching and capture variables. A remote attacker could use this issue to cause nginx to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2026-42533)
It was discovered that nginx had a use-after-free vulnerability in the ngx_http_ssi_module module when configured with Server-Side Includes, proxy_pass, and proxy buffering disabled directives. An attacker able to intercept traffic and control responses from an upstream server could possibly use this issue to cause nginx to crash, resulting in a denial of service. (CVE-2026-56434)
It was discovered that nginx incorrectly handled certain requests in the ngx_http_slice_module module. A remote attacker could possibly use this issue to obtain sensitive information or cause nginx to crash, resulting in a denial of service. (CVE-2026-60005)
What each source reports
OSV No score
nginx regression
USN-8563-3 fixed a vulnerability in nginx. The fix introduced a regression in certain environments. This update reverts the fix for CVE-2026-42533 pending further investigation.
We apologize for the inconvenience.
Original advisory details:
It was discovered that nginx incorrectly handled certain map directives using regex matching and capture variables. A remote attacker could use this issue to cause nginx to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2026-42533)
It was discovered that nginx had a use-after-free vulnerability in the ngx_http_ssi_module module when configured with Server-Side Includes, proxy_pass, and proxy buffering disabled directives. An attacker able to intercept traffic and control responses from an upstream server could possibly use this issue to cause nginx to crash, resulting in a denial of service. (CVE-2026-56434)
It was discovered that nginx incorrectly handled certain requests in the ngx_http_slice_module module. A remote attacker could possibly use this issue to obtain sensitive information or cause nginx to crash, resulting in a denial of service. (CVE-2026-60005)
- Record
USN-8563-4- Updated
- 2026-11-02
Affected packages
| Package | Affected | Fixed |
|---|---|---|
nginxUbuntu:22.04:LTS |
before 1.18.0-6ubuntu14.20, plus listed versions 1.18.0-6ubuntu111.18.0-6ubuntu121.18.0-6ubuntu141.18.0-6ubuntu14.11.18.0-6ubuntu14.2 Show 16 moreShow less1.18.0-6ubuntu14.31.18.0-6ubuntu14.41.18.0-6ubuntu14.51.18.0-6ubuntu14.61.18.0-6ubuntu14.71.18.0-6ubuntu14.81.18.0-6ubuntu14.101.18.0-6ubuntu14.111.18.0-6ubuntu14.121.18.0-6ubuntu14.131.18.0-6ubuntu14.141.18.0-6ubuntu14.151.18.0-6ubuntu14.161.18.0-6ubuntu14.171.18.0-6ubuntu14.181.18.0-6ubuntu14.19 |
1.18.0-6ubuntu14.20 |
nginxUbuntu:24.04:LTS |
before 1.24.0-2ubuntu7.17, plus listed versions 1.24.0-1ubuntu11.24.0-2ubuntu11.24.0-2ubuntu21.24.0-2ubuntu31.24.0-2ubuntu4 Show 17 moreShow less1.24.0-2ubuntu61.24.0-2ubuntu71.24.0-2ubuntu7.11.24.0-2ubuntu7.31.24.0-2ubuntu7.41.24.0-2ubuntu7.51.24.0-2ubuntu7.61.24.0-2ubuntu7.71.24.0-2ubuntu7.81.24.0-2ubuntu7.91.24.0-2ubuntu7.101.24.0-2ubuntu7.111.24.0-2ubuntu7.121.24.0-2ubuntu7.131.24.0-2ubuntu7.141.24.0-2ubuntu7.151.24.0-2ubuntu7.16 |
1.24.0-2ubuntu7.17 |
nginxUbuntu:26.04:LTS |
before 1.28.3-2ubuntu1.10, plus listed versions 1.28.0-6ubuntu11.28.1-2ubuntu11.28.1-3ubuntu11.28.2-2ubuntu11.28.3-2ubuntu1 Show 9 moreShow less1.28.3-2ubuntu1.11.28.3-2ubuntu1.21.28.3-2ubuntu1.31.28.3-2ubuntu1.41.28.3-2ubuntu1.51.28.3-2ubuntu1.61.28.3-2ubuntu1.71.28.3-2ubuntu1.81.28.3-2ubuntu1.9 |
1.28.3-2ubuntu1.10 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-02 | created | OSV |