Every CVE Search/ Get API key

CVE-2026-61897

accountsservice: incomplete privilege drop when running Ubuntu-specific language helper scripts

7.8 HighFix available

An Ubuntu-specific patch to AccountsService before 23.13.9-8ubuntu7 only partially drops privileges before launching language helper scripts. It changes the effective UID/GID to the target user but leaves the real UID as 0 (root). A shell spawned by a helper script inherits ruid=0 and may reset its effective UID to root, enabling local privilege escalation.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.14%Unchanged since Aug 21, 2026
90%50%10%1%

What each source reports

CVE List Score used 7.8

accountsservice: incomplete privilege drop when running Ubuntu-specific language helper scripts

An Ubuntu-specific patch to AccountsService before 23.13.9-8ubuntu7 only partially drops privileges before launching language helper scripts. It changes the effective UID/GID to the target user but leaves the real UID as 0 (root). A shell spawned by a helper script inherits ruid=0 and may reset its effective UID to root, enabling local privilege escalation.

Record
CVE-2026-61897
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-273
Updated
2026-11-02
EUVDEUVD-2026-63379 7.8

An Ubuntu-specific patch to AccountsService before 23.13.9-8ubuntu7 only partially drops privileges before launching language helper scripts. It changes the effective UID/GID to the target user but leaves the real UID as 0 (root). A shell spawned by a helper script inherits ruid=0 and may reset its effective UID to root, enabling local privilege escalation.

Record
EUVD-2026-63379
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-8h74-384h-cv6c 7.8

An Ubuntu-specific patch to AccountsService before 23.13.9-8ubuntu7 only partially drops...

An Ubuntu-specific patch to AccountsService before 23.13.9-8ubuntu7 only partially drops privileges before launching language helper scripts. It changes the effective UID/GID to the target user but leaves the real UID as 0 (root). A shell spawned by a helper script inherits ruid=0 and may reset its effective UID to root, enabling local privilege escalation.

Record
GHSA-8h74-384h-cv6c
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-273
Updated
2026-11-02
NVD 7.8

An Ubuntu-specific patch to AccountsService before 23.13.9-8ubuntu7 only partially drops privileges before launching language helper scripts. It changes the effective UID/GID to the target user but leaves the real UID as 0 (root). A shell spawned by a helper script inherits ruid=0 and may reset its effective UID to root, enabling local privilege escalation.

Record
CVE-2026-61897
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-273
Updated
2026-11-02
OSVUBUNTU-CVE-2026-61897 7.8

An Ubuntu-specific patch to AccountsService before 23.13.9-8ubuntu7 only partially drops privileges before launching language helper scripts. It changes the effective UID/GID to the target user but leaves the real UID as 0 (root). A shell spawned by a helper script inherits ruid=0 and may reset its effective UID to root, enabling local privilege escalation.

Record
UBUNTU-CVE-2026-61897
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUSN-8580-1 No score

accountsservice vulnerabilities

It was discovered that the Ubuntu-specific SetLanguage patch to AccountsService incorrectly handled dropping privileges. A local attacker could use this issue to execute arbitrary commands as an administrator. (CVE-2026-61897)

It was discovered that the Ubuntu-specific SetLanguage helpers for AccountsService incorrectly handled parsing configuration files. A local attacker could use this issue to execute arbitrary commands. (CVE-2026-61898)

Record
USN-8580-1
Updated
2026-11-02
OSVUSN-8580-2 No score

accountsservice vulnerabilities

USN-8580-1 fixed vulnerabilities in AccountsService. This update provides the corresponding fixes for Ubuntu 14.04 LTS, Ubuntu 16.04 LTS, Ubuntu 18.04 LTS, and Ubuntu 20.04 LTS.

Original advisory details:

It was discovered that the Ubuntu-specific SetLanguage patch to AccountsService incorrectly handled dropping privileges. A local attacker could use this issue to execute arbitrary commands as an administrator. (CVE-2026-61897)

It was discovered that the Ubuntu-specific SetLanguage helpers for AccountsService incorrectly handled parsing configuration files. A local attacker could use this issue to execute arbitrary commands. (CVE-2026-61898)

Record
USN-8580-2
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
accountsservice
Ubuntu:Pro:14.04:LTS
before 0.6.35-0ubuntu7.3+esm4, plus listed versions
0.6.34-0ubuntu60.6.34-0ubuntu70.6.35-0ubuntu10.6.35-0ubuntu20.6.35-0ubuntu3
Show 9 moreShow less
0.6.35-0ubuntu40.6.35-0ubuntu50.6.35-0ubuntu60.6.35-0ubuntu70.6.35-0ubuntu7.10.6.35-0ubuntu7.20.6.35-0ubuntu7.30.6.35-0ubuntu7.3+esm20.6.35-0ubuntu7.3+esm3
0.6.35-0ubuntu7.3+esm4
accountsservice
Ubuntu:Pro:16.04:LTS
before 0.6.40-2ubuntu11.6+esm2, plus listed versions
0.6.40-2ubuntu50.6.40-2ubuntu60.6.40-2ubuntu70.6.40-2ubuntu80.6.40-2ubuntu9
Show 7 moreShow less
0.6.40-2ubuntu100.6.40-2ubuntu110.6.40-2ubuntu11.10.6.40-2ubuntu11.20.6.40-2ubuntu11.30.6.40-2ubuntu11.60.6.40-2ubuntu11.6+esm1
0.6.40-2ubuntu11.6+esm2
accountsservice
Ubuntu:Pro:18.04:LTS
before 0.6.45-1ubuntu1.3+esm2, plus listed versions
0.6.42-0ubuntu30.6.42-0ubuntu40.6.45-1ubuntu10.6.45-1ubuntu1.30.6.45-1ubuntu1.3+esm1
0.6.45-1ubuntu1.3+esm2
accountsservice
Ubuntu:Pro:20.04:LTS
before 0.6.55-0ubuntu12~20.04.7+esm1, plus listed versions
0.6.55-0ubuntu100.6.55-0ubuntu110.6.55-0ubuntu12~20.04.10.6.55-0ubuntu12~20.04.20.6.55-0ubuntu12~20.04.40.6.55-0ubuntu12~20.04.50.6.55-0ubuntu12~20.04.60.6.55-0ubuntu12~20.04.7
0.6.55-0ubuntu12~20.04.7+esm1
accountsservice
Ubuntu:22.04:LTS
before 22.07.5-2ubuntu1.6, plus listed versions
0.6.55-0ubuntu140.6.55-3ubuntu10.6.55-3ubuntu20.6.55-3ubuntu40.6.55-3ubuntu5
Show 5 moreShow less
0.6.55-3ubuntu622.07.5-2ubuntu122.07.5-2ubuntu1.322.07.5-2ubuntu1.422.07.5-2ubuntu1.5
22.07.5-2ubuntu1.6
accountsservice
Ubuntu:24.04:LTS
before 23.13.9-2ubuntu6.1, plus listed versions
23.13.9-2ubuntu223.13.9-2ubuntu423.13.9-2ubuntu6
23.13.9-2ubuntu6.1
accountsservice
Ubuntu:26.04:LTS
before 23.13.9-8ubuntu5.2, plus listed versions
23.13.9-7ubuntu123.13.9-8ubuntu123.13.9-8ubuntu223.13.9-8ubuntu423.13.9-8ubuntu523.13.9-8ubuntu5.1
23.13.9-8ubuntu5.2

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-61897 is a high vulnerability (CVSS 7.8) in Canonical Accountsservice, published July 21, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.14%, the 3rd percentile. Fixed in accountsservice 0.6.35-0ubuntu7.3+esm4.

References

MoveEnter Open