exim vulnerabilities (Alpine)
40 vulnerabilities.
-
eximAlpine Exim before 4.99.5 allows directory traversal to access files outside of the spool area, and... 8.4 High -
eximAlpine Exim 4.88 before 4.99.4, in some proxy configurations, mishandles certain short payloads, leading... 5.3 Medium -
eximAlpine In Exim before 4.99.2, on systems using musl libc (not glibc), an attacker can crash the... 5.9 Medium -
eximAlpine In Exim before 4.99.2, when the SPA authentication driver is used with an adversarial SPA... 4.8 Medium -
eximAlpine In Exim before 4.99.2, when utf8 operators are enabled, there is an out-of-bounds read if large... 3.7 Low -
eximAlpine In Exim before 4.99.2, when JSON lookup is enabled, an out-of-bounds heap write can occur when a... 6.5 Medium -
eximAlpine A use-after-free in Exim 4.96 through 4.98.1 could allow users (with command-line access) to... 8.1 High -
eximAlpine Exim through 4.97.1 misparses a multiline RFC 2231 header filename, and thus remote attackers can... 5.4 Medium -
eximAlpine Exim dnsdb Out-Of-Bounds Read Information Disclosure Vulnerability 3.1 Low -
eximAlpine Exim Improper Neutralization of Special Elements Remote Code Execution Vulnerability 8.1 High -
eximAlpine Exim SMTP Challenge Stack-based Buffer Overflow Remote Code Execution Vulnerability 8.1 High -
eximAlpine Exim AUTH Out-Of-Bounds Write Remote Code Execution Vulnerability 9.8 Critical -
eximAlpine Exim NTLM Challenge Out-Of-Bounds Read Information Disclosure Vulnerability 3.7 Low -
eximAlpine Exim 4 before 4.94.2 allows an off-by-two Out-of-bounds Write because "-F ''" is mishandled by... 7.8 High -
eximAlpine Exim 4 before 4.94.2 has Execution with Unnecessary Privileges. By leveraging a delete_pid_file... 6.3 Medium -
eximAlpine Exim 4 before 4.92 allows Integer Overflow to Buffer Overflow, in which an unauthenticated remote... 9.8 Critical -
eximAlpine Exim 4 before 4.94.2 allows Use After Free in smtp_reset in certain situations that may be common... 9.8 Critical -
eximAlpine Exim 4 before 4.94.2 has Improper Neutralization of Line Delimiters, relevant in non-default... 9.8 Critical -
eximAlpine Exim 4 before 4.94.2 allows Out-of-bounds Read because pdkim_finish_bodyhash does not validate... 7.5 High -
eximAlpine Exim 4 before 4.94.2 allows Buffer Underwrite that may result in unauthenticated remote attackers... 9.8 Critical -
eximAlpine Exim 4 before 4.94.2 allows Out-of-bounds Read. smtp_setup_msg may disclose sensitive information... 7.5 High -
eximAlpine Exim 4 before 4.94.2 has Improper Restriction of Write Operations within the Bounds of a Memory... 9.8 Critical -
eximAlpine Exim 4 before 4.94.2 has Improper Neutralization of Line Delimiters. An authenticated remote SMTP... 8.8 High -
eximAlpine Exim 4 before 4.94.2 has Improper Initialization that can lead to recursion-based stack... 7.5 High -
eximAlpine Exim 4 before 4.94.2 allows Integer Overflow to Buffer Overflow in receive_add_recipient via an e... 9.8 Critical -
eximAlpine Exim 4 before 4.94.2 has Improper Neutralization of Line Delimiters. Local users can alter the... 7.8 High -
eximAlpine Exim 4 before 4.94.2 allows Execution with Unnecessary Privileges. The -oP option is available to... 6.1 Medium -
eximAlpine Exim 4 before 4.94.2 allows Heap-based Buffer Overflow because it mishandles "-F '.('" on the... 7.8 High -
eximAlpine Exim 4 before 4.94.2 allows Exposure of File Descriptor to Unintended Control Sphere because... 7.8 High -
eximAlpine Exim 4 before 4.94.2 allows Heap-based Buffer Overflow in queue_run via two sender options: -R... 7.8 High -
eximAlpine Exim 4 before 4.94.2 allows Out-of-bounds Write because the main function, while setuid root,... 7.8 High -
eximAlpine Exim 4 before 4.94.2 allows Integer Overflow to Buffer Overflow because get_stdinput allows... 7.8 High -
eximAlpine Exim 4 before 4.94.2 allows Execution with Unnecessary Privileges. Because Exim operates as root... 7.8 High -
eximAlpine Exim 4 before 4.94.2 allows Execution with Unnecessary Privileges. Because Exim operates as root... 7.8 High -
eximAlpine Exim through 4.93 has an out-of-bounds read in the SPA authenticator that could result in SPA... 7.5 High -
eximAlpine Exim 4.92 through 4.92.2 allows remote code execution, a different vulnerability than CVE-2019... 9.8 Critical -
eximAlpine Exim before 4.92.2 allows remote attackers to execute arbitrary code as root via a trailing... 9.8 Critical -
eximAlpine Exim 4.85 through 4.92 (fixed in 4.92.1) allows remote code execution as root in some unusual... 9.8 Critical -
eximAlpine A flaw was found in Exim versions 4.87 to 4.91 (inclusive). Improper validation of recipient... 9.0 Critical -
eximAlpine An issue was discovered in the base64d function in the SMTP listener in Exim before 4.90.1. By... 9.8 Critical