Every CVE Search/ Get API key

CVE-2025-30232

A use-after-free in Exim 4.96 through 4.98.1 could allow users (with command-line access) to...

8.1 HighFix available

A use-after-free in Exim 4.96 through 4.98.1 could allow users (with command-line access) to escalate privileges.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.53%Up 0.5 points since Mar 28, 2025
90%50%10%1%

What each source reports

CVE List Score used 8.1

A use-after-free in Exim 4.96 through 4.98.1 could allow users (with command-line access) to escalate privileges.

Record
CVE-2025-30232
CVSS 3.1
8.1 HighCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
Weakness
CWE-416
Updated
2026-11-02
EUVDEUVD-2025-8527 8.1

A use-after-free in Exim 4.96 through 4.98.1 could allow users (with command-line access) to escalate privileges.

Record
EUVD-2025-8527
CVSS 3.1
8.1 HighCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-qw8f-786p-mp4v 8.1

A use-after-free in Exim 4.96 through 4.98.1 could allow users (with command-line access) to...

A use-after-free in Exim 4.96 through 4.98.1 could allow users (with command-line access) to escalate privileges.

Record
GHSA-qw8f-786p-mp4v
CVSS 3.1
8.1 HighCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
Weakness
CWE-416
Updated
2026-11-02
NVD 8.1

A use-after-free in Exim 4.96 through 4.98.1 could allow users (with command-line access) to escalate privileges.

Record
CVE-2025-30232
CVSS 3.1
8.1 HighCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-416
Updated
2026-11-02
OSVALPINE-CVE-2025-30232 7.8

A use-after-free in Exim 4.96 through 4.98.1 could allow users (with command-line access) to escalate privileges.

Record
ALPINE-CVE-2025-30232
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-03
OSV 8.1

A use-after-free in Exim 4.96 through 4.98.1 could allow users (with command-line access) to escalate privileges.

Record
CVE-2025-30232
CVSS 3.1
8.1 HighCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
Weakness
CWE-416
Updated
2026-11-02
Show 5 moreShow less
OSVDEBIAN-CVE-2025-30232 7.8

A use-after-free in Exim 4.96 through 4.98.1 could allow users (with command-line access) to escalate privileges.

Record
DEBIAN-CVE-2025-30232
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2025-30232 8.1

A use-after-free in Exim 4.96 through 4.98.1 could allow users (with command-line access) to escalate privileges.

Record
UBUNTU-CVE-2025-30232
CVSS 3.1
8.1 HighCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVCLSA-2026-1783707452 No score

exim: Fix of CVE-2025-30232

  • CVE-2025-30232: fix use-after-free in debug pre-trigger buffer (privilege escalation)
Record
CLSA-2026-1783707452
Updated
2026-11-02
OSVopenSUSE-SU-2025:14935-1 No score

exim-4.98.2-1.1 on GA media

These are all security issues fixed in the exim-4.98.2-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2025:14935-1
Updated
2026-11-02
OSVUSN-7373-1 No score

exim4 vulnerability

It was discovered that Exim incorrectly handled certain memory operations. A remote attacker could use this issue to cause Exim to crash, resulting in a denial of service, or possibly execute arbitrary code.

Record
USN-7373-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
exim
Alpine:v3.21
4.96 up to 4.98.2-r0
4.98.2-r0
exim
Alpine:v3.22
4.96 up to 4.98.2-r0
4.98.2-r0
exim
Alpine:v3.23
4.96 up to 4.98.2-r0
4.98.2-r0
exim
Alpine:v3.24
4.96 up to 4.98.2-r0
4.98.2-r0
exim
TuxCare:CentOS:7
before 4.97.1-1.el7.tuxcare.els3
4.97.1-1.el7.tuxcare.els3
exim-greylist
TuxCare:CentOS:7
before 4.97.1-1.el7.tuxcare.els3
4.97.1-1.el7.tuxcare.els3
exim-mon
TuxCare:CentOS:7
before 4.97.1-1.el7.tuxcare.els3
4.97.1-1.el7.tuxcare.els3
exim-mysql
TuxCare:CentOS:7
before 4.97.1-1.el7.tuxcare.els3
4.97.1-1.el7.tuxcare.els3
exim-pgsql
TuxCare:CentOS:7
before 4.97.1-1.el7.tuxcare.els3
4.97.1-1.el7.tuxcare.els3
exim-sysvinit
TuxCare:CentOS:7
before 4.97.1-1.el7.tuxcare.els3
4.97.1-1.el7.tuxcare.els3
Show 5 moreShow less
Affected packages
PackageAffectedFixed
exim4
Debian:12
before 4.96-15+deb12u7, plus listed versions
4.96-154.96-15+deb12u14.96-15+deb12u24.96-15+deb12u34.96-15+deb12u44.96-15+deb12u54.96-15+deb12u6
4.96-15+deb12u7
exim4
Debian:13
before 4.98.1-2
4.98.1-2
exim4
Debian:14
before 4.98.1-2
4.98.1-2
exim4
Ubuntu:24.04:LTS
before 4.97-4ubuntu4.3, plus listed versions
4.96-17ubuntu24.96-17ubuntu2.14.97-3ubuntu14.97-4ubuntu14.97-4ubuntu34.97-4ubuntu44.97-4ubuntu4.14.97-4ubuntu4.2
4.97-4ubuntu4.3
exim
openSUSE:Tumbleweed
From an advisory covering 2 CVEs
before 4.98.2-1.1
4.98.2-1.1

History

History
RecordedChangedSources
affected, facts
affected, aliases, referencesOSV
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-30232 is a high vulnerability (CVSS 8.1) in Exim, published March 26, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.53%, the 45th percentile. Fixed in exim 4.98.2-r0.

References

Show 8 moreShow less
MoveEnter Open