exim vulnerabilities (openSUSE)
53 vulnerabilities.
-
eximopenSUSE SUSE-specific logrotate configuration allows escalation from mail user/group to root 6.9 Medium -
eximopenSUSE A use-after-free in Exim 4.96 through 4.98.1 could allow users (with command-line access) to... 8.1 High -
eximopenSUSE Exim 4.98 before 4.98.1, when SQLite hints and ETRN serialization are used, allows remote SQL... 7.5 High -
eximopenSUSE Exim through 4.97.1 misparses a multiline RFC 2231 header filename, and thus remote attackers can... 5.4 Medium -
eximopenSUSE Exim through 4.97 allows SMTP smuggling in certain configurations. Remote attackers can use a... 5.3 Medium -
eximopenSUSE Exim dnsdb Out-Of-Bounds Read Information Disclosure Vulnerability 3.1 Low -
eximopenSUSE Exim Improper Neutralization of Special Elements Remote Code Execution Vulnerability 8.1 High -
eximopenSUSE Exim SMTP Challenge Stack-based Buffer Overflow Remote Code Execution Vulnerability 8.1 High -
eximopenSUSE Exim AUTH Out-Of-Bounds Write Remote Code Execution Vulnerability 9.8 Critical -
eximopenSUSE Exim NTLM Challenge Out-Of-Bounds Read Information Disclosure Vulnerability 3.7 Low -
eximopenSUSE Exim Regex use after free 4.6 Medium -
eximopenSUSE Exim 4 before 4.94.2 allows an off-by-two Out-of-bounds Write because "-F ''" is mishandled by... 7.8 High -
eximopenSUSE Exim 4 before 4.92 allows Integer Overflow to Buffer Overflow, in which an unauthenticated remote... 9.8 Critical -
eximopenSUSE Exim 4 before 4.94.2 allows Use After Free in smtp_reset in certain situations that may be common... 9.8 Critical -
eximopenSUSE Exim 4 before 4.94.2 has Improper Neutralization of Line Delimiters, relevant in non-default... 9.8 Critical -
eximopenSUSE Exim 4 before 4.94.2 allows Out-of-bounds Read because pdkim_finish_bodyhash does not validate... 7.5 High -
eximopenSUSE Exim 4 before 4.94.2 allows Buffer Underwrite that may result in unauthenticated remote attackers... 9.8 Critical -
eximopenSUSE Exim 4 before 4.94.2 allows Out-of-bounds Read. smtp_setup_msg may disclose sensitive information... 7.5 High -
eximopenSUSE Exim 4 before 4.94.2 has Improper Restriction of Write Operations within the Bounds of a Memory... 9.8 Critical -
eximopenSUSE Exim 4 before 4.94.2 has Improper Neutralization of Line Delimiters. An authenticated remote SMTP... 8.8 High -
eximopenSUSE Exim 4 before 4.94.2 has Improper Initialization that can lead to recursion-based stack... 7.5 High -
eximopenSUSE Exim 4 before 4.94.2 allows Integer Overflow to Buffer Overflow in receive_add_recipient via an e... 9.8 Critical -
eximopenSUSE Exim 4 before 4.94.2 has Improper Neutralization of Line Delimiters. Local users can alter the... 7.8 High -
eximopenSUSE Exim 4 before 4.94.2 allows Execution with Unnecessary Privileges. The -oP option is available to... 6.1 Medium -
eximopenSUSE Exim 4 before 4.94.2 allows Heap-based Buffer Overflow because it mishandles "-F '.('" on the... 7.8 High -
eximopenSUSE Exim 4 before 4.94.2 allows Exposure of File Descriptor to Unintended Control Sphere because... 7.8 High -
eximopenSUSE Exim 4 before 4.94.2 allows Heap-based Buffer Overflow in queue_run via two sender options: -R... 7.8 High -
eximopenSUSE Exim 4 before 4.94.2 allows Out-of-bounds Write because the main function, while setuid root,... 7.8 High -
eximopenSUSE Exim 4 before 4.94.2 allows Integer Overflow to Buffer Overflow because get_stdinput allows... 7.8 High -
eximopenSUSE Exim 4 before 4.94.2 allows Execution with Unnecessary Privileges. Because Exim operates as root... 7.8 High -
eximopenSUSE Exim 4 before 4.94.2 allows Execution with Unnecessary Privileges. Because Exim operates as root... 7.8 High -
eximopenSUSE Exim through 4.93 has an out-of-bounds read in the SPA authenticator that could result in SPA... 7.5 High -
eximopenSUSE Local privilege escalation in exim package from user mail to root 8.4 High -
eximopenSUSE Exim 4.92 through 4.92.2 allows remote code execution, a different vulnerability than CVE-2019... 9.8 Critical -
eximopenSUSE Exim before 4.92.2 allows remote attackers to execute arbitrary code as root via a trailing... 9.8 Critical -
eximopenSUSE Exim 4.85 through 4.92 (fixed in 4.92.1) allows remote code execution as root in some unusual... 9.8 Critical -
eximopenSUSE A flaw was found in Exim versions 4.87 to 4.91 (inclusive). Improper validation of recipient... 9.0 Critical -
eximopenSUSE An issue was discovered in the base64d function in the SMTP listener in Exim before 4.90.1. By... 9.8 Critical -
eximopenSUSE The receive_msg function in receive.c in the SMTP daemon in Exim 4.88 and 4.89 allows remote... 7.5 High -
eximopenSUSE The receive_msg function in receive.c in the SMTP daemon in Exim 4.88 and 4.89 allows remote... 9.8 Critical -
eximopenSUSE Exim supports the use of multiple "-p" command line arguments which are malloc()'ed and never... 4.0 Medium -
eximopenSUSE Exim before 4.87.1 might allow remote attackers to obtain the private DKIM signing key via... 5.9 Medium -
eximopenSUSE Exim before 4.86.2, when installed setuid root, allows local users to gain privileges via the... 7.0 High -
eximopenSUSE The dmarc_process function in dmarc.c in Exim before 4.82.1, when EXPERIMENTAL_DMARC is enabled,... 6.8 Medium -
eximopenSUSE expand.c in Exim before 4.83 expands mathematical comparisons twice, which allows local users to... 4.6 Medium -
eximopenSUSE Heap-based buffer overflow in the dkim_exim_query_dns_txt function in dkim.c in Exim 4.70 through... 6.8 Medium -
eximopenSUSE The DKIM implementation in Exim 4.7x before 4.76 permits matching for DKIM identities to apply to... 7.5 High -
eximopenSUSE Format string vulnerability in the dkim_exim_verify_finish function in src/dkim.c in Exim before... 7.5 High -
eximopenSUSE The open_log function in log.c in Exim 4.72 and earlier does not check the return value from (1)... 6.9 Medium -
eximopenSUSE Exim 4.72 and earlier allows local users to gain privileges by leveraging the ability of the exim... 7.8 High - Show olderLoading…