bind-libs-lite vulnerabilities (Red Hat)
64 vulnerabilities.
-
bind-libs-liteRed Hat Validating resolver can abort while caching a mismatched NOQNAME proof 7.5 High -
bind-libs-liteRed Hat Use-after-free in query_addnoqnameproof() via the DNS64 filter64 path 7.5 High -
bind-libs-liteRed Hat Remote assertion failure via 16-bit length truncation in `dns_ncache_add()` 7.5 High -
bind-libs-liteRed Hat DNSSEC Validation Bypass via Out-of-Zone NSEC Next Field 8.6 High -
bind-libs-liteRed Hat Unexpected exit in certain situations with NSEC and NSEC3 both present 7.5 High -
bind-libs-liteRed Hat Cache poisoning possible with label count discrepancy, RRSIG, and wildcards 7.5 High -
bind-libs-liteRed Hat Potential memory usage beyond configured limits 7.5 High -
bind-libs-liteRed Hat Incorrect acceptance of NSEC3 records 6.8 Medium -
bind-libs-liteRed Hat Invalid handling of CLASS != IN 7.5 High -
bind-libs-liteRed Hat BIND 9 server memory exhaustion during GSS-API TKEY negotiation 7.5 High -
bind-libs-liteRed Hat Excessive NSEC3 iterations cause high CPU load during insecure delegation validation 7.5 High -
bind-libs-liteRed Hat Cache poisoning attacks with unsolicited RRs 8.6 High -
bind-libs-liteRed Hat Many records in the additional section cause CPU exhaustion 7.5 High -
bind-libs-liteRed Hat SIG(0) can be used to exhaust CPU resources 7.5 High -
bind-libs-liteRed Hat BIND's database will be slow if a very large number of RRs exist at the same name 7.5 High -
bind-libs-liteRed Hat The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
bind-libs-liteRed Hat Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
bind-libs-liteRed Hat Parsing large DNS messages may cause excessive CPU load 7.5 High -
bind-libs-liteRed Hat A stack exhaustion flaw in control channel code may cause named to terminate unexpectedly 7.5 High -
bind-libs-liteRed Hat named's configured cache size limit can be significantly exceeded 7.5 High -
bind-libs-liteRed Hat An UPDATE message flood may cause named to exhaust all available memory 7.5 High -
bind-libs-liteRed Hat Memory leaks in EdDSA DNSSEC verification code 7.5 High -
bind-libs-liteRed Hat Memory leak in ECDSA DNSSEC verification code 7.5 High -
bind-libs-liteRed Hat Processing large delegations may severely degrade resolver performance 5.3 Medium -
bind-libs-liteRed Hat DNS forwarders - cache poisoning vulnerability 6.8 Medium -
bind-libs-liteRed Hat Lame cache can be abused to severely degrade resolver performance 5.3 Medium -
bind-libs-liteRed Hat An assertion check can fail while answering queries for DNAME records that require the DNAME to be processed to resolve itself 7.5 High -
bind-libs-liteRed Hat A broken inbound incremental zone update (IXFR) can cause named to terminate unexpectedly 6.5 Medium -
bind-libs-liteRed Hat A vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack 8.1 High -
bind-libs-liteRed Hat update-policy rules of type "subdomain" are enforced incorrectly 4.3 Medium -
bind-libs-liteRed Hat A flaw in native PKCS#11 code can lead to a remotely triggerable assertion failure in pk11.c 7.5 High -
bind-libs-liteRed Hat A truncated TSIG response can lead to an assertion failure 6.5 Medium -
bind-libs-liteRed Hat A buffer boundary check assertion in rdataset.c can fail incorrectly during zone transfer 4.9 Medium -
bind-libs-liteRed Hat A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c 7.5 High -
bind-libs-liteRed Hat BIND does not sufficiently limit the number of fetches performed when processing referrals 8.6 High -
bind-libs-liteRed Hat TCP-pipelined queries can bypass tcp-clients limit 7.5 High -
bind-libs-liteRed Hat An oversight while backporting a feature leads to an assertion failure in buffer.c:420 5.9 Medium -
bind-libs-liteRed Hat A race condition when discarding malformed packets can cause BIND to exit with an assertion failure 5.9 Medium -
bind-libs-liteRed Hat Limiting simultaneous TCP clients was ineffective 7.5 High -
bind-libs-liteRed Hat Zone transfer controls for writable DLZ zones were not effective 5.3 Medium -
bind-libs-liteRed Hat An assertion failure can occur if a trust anchor rolls over to an unsupported key algorithm when using managed-keys 4.9 Medium -
bind-libs-liteRed Hat Update policies krb5-subdomain and ms-subdomain do not enforce controls promised in their documentation 6.5 Medium -
bind-libs-liteRed Hat A flaw in the "deny-answer-aliases" feature can cause an assertion failure in named 7.5 High -
bind-libs-liteRed Hat Improper fetch cleanup sequencing in the resolver can cause named to crash 7.5 High -
bind-libs-liteRed Hat An error in TSIG authentication can permit unauthorized dynamic updates 7.5 High -
bind-libs-liteRed Hat An error in TSIG authentication can permit unauthorized zone transfers 5.3 Medium -
bind-libs-liteRed Hat A response packet can cause a resolver to terminate when processing an answer containing a CNAME or DNAME 7.5 High -
bind-libs-liteRed Hat An error handling synthesized records could cause an assertion failure when using DNS64 with "break-dnssec yes;" 5.9 Medium -
bind-libs-liteRed Hat Combination of DNS64 and RPZ Can Lead to Crash 7.5 High -
bind-libs-liteRed Hat named in ISC BIND 9.x before 9.9.9-P5, 9.10.x before 9.10.4-P5, and 9.11.x before 9.11.0-P2... 7.5 High - Show olderLoading…