bind-doc vulnerabilities (TuxCare)
35 vulnerabilities.
-
bind-docTuxCare NSEC3 insecure-referral proof can use unrelated cached NSEC3 RRsets 5.9 Medium -
bind-docTuxCare Message parser retains every identical singleton RDATA, enabling wire-to-work amplification 5.3 Medium -
bind-docTuxCare Resource Exhaustion via Excessive DNSSEC Cryptographic Material Matching 5.3 Medium -
bind-docTuxCare Unauthenticated IXFR deltas are applied to the live zone before TSIG verification 6.5 Medium -
bind-docTuxCare Validating resolver can abort while caching a mismatched NOQNAME proof 7.5 High -
bind-docTuxCare Use-after-free in query_addnoqnameproof() via the DNS64 filter64 path 7.5 High -
bind-docTuxCare Out-of-zone database nodes can become authoritative zone cuts 5.8 Medium -
bind-docTuxCare checkwildcard() accepts an out-of-zone NSEC as a wildcard-nonexistence proof 5.9 Medium -
bind-docTuxCare qpcache NOQNAME proof use-after-free crashes recursive resolver 5.9 Medium -
bind-docTuxCare Remote assertion failure via 16-bit length truncation in `dns_ncache_add()` 7.5 High -
bind-docTuxCare DNSSEC Validation Bypass via Out-of-Zone NSEC Next Field 8.6 High -
bind-docTuxCare Unexpected exit in certain situations with NSEC and NSEC3 both present 7.5 High -
bind-docTuxCare Cache poisoning possible with label count discrepancy, RRSIG, and wildcards 7.5 High -
bind-docTuxCare Potential memory usage beyond configured limits 7.5 High -
bind-docTuxCare Potential wildcard CNAME RPZ policy bypass 7.5 High -
bind-docTuxCare Incorrect acceptance of NSEC3 records 6.8 Medium -
bind-docTuxCare Unbounded resend loop in BIND 9 resolver 5.3 Medium -
bind-docTuxCare Invalid handling of CLASS != IN 7.5 High -
bind-docTuxCare Amplification vulnerabilities via self-pointed glue records 5.3 Medium -
bind-docTuxCare BIND 9 server memory exhaustion during GSS-API TKEY negotiation 7.5 High -
bind-docTuxCare Excessive NSEC3 iterations cause high CPU load during insecure delegation validation 7.5 High -
bind-docTuxCare Resource exhaustion via malformed DNSKEY handling 7.5 High -
bind-docTuxCare Cache poisoning due to weak PRNG 8.6 High -
bind-docTuxCare Cache poisoning attacks with unsolicited RRs 8.6 High -
bind-docTuxCare Many records in the additional section cause CPU exhaustion 7.5 High -
bind-docTuxCare Assertion failure when serving both stale cache data and authoritative zone content 7.5 High -
bind-docTuxCare SIG(0) can be used to exhaust CPU resources 7.5 High -
bind-docTuxCare BIND's database will be slow if a very large number of RRs exist at the same name 7.5 High -
bind-docTuxCare Update of bind No score -
bind-docTuxCare Specific recursive query patterns may lead to an out-of-memory condition 7.5 High -
bind-docTuxCare Enabling both DNS64 and serve-stale may cause an assertion failure during recursive resolution 7.5 High -
bind-docTuxCare Querying RFC 1918 reverse zones may cause an assertion failure when "nxdomain-redirect" is enabled 7.5 High -
bind-docTuxCare The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
bind-docTuxCare Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
bind-docTuxCare Parsing large DNS messages may cause excessive CPU load 7.5 High