bind-export-devel vulnerabilities (TuxCare)
29 vulnerabilities.
-
bind-export-develTuxCare Validating resolver can abort while caching a mismatched NOQNAME proof 7.5 High -
bind-export-develTuxCare Use-after-free in query_addnoqnameproof() via the DNS64 filter64 path 7.5 High -
bind-export-develTuxCare Remote assertion failure via 16-bit length truncation in `dns_ncache_add()` 7.5 High -
bind-export-develTuxCare DNSSEC Validation Bypass via Out-of-Zone NSEC Next Field 8.6 High -
bind-export-develTuxCare Unexpected exit in certain situations with NSEC and NSEC3 both present 7.5 High -
bind-export-develTuxCare Potential memory usage beyond configured limits 7.5 High -
bind-export-develTuxCare Incorrect acceptance of NSEC3 records 6.8 Medium -
bind-export-develTuxCare Invalid handling of CLASS != IN 7.5 High -
bind-export-develTuxCare Amplification vulnerabilities via self-pointed glue records 5.3 Medium -
bind-export-develTuxCare BIND 9 server memory exhaustion during GSS-API TKEY negotiation 7.5 High -
bind-export-develTuxCare Excessive NSEC3 iterations cause high CPU load during insecure delegation validation 7.5 High -
bind-export-develTuxCare Cache poisoning attacks with unsolicited RRs 8.6 High -
bind-export-develTuxCare Many records in the additional section cause CPU exhaustion 7.5 High -
bind-export-develTuxCare SIG(0) can be used to exhaust CPU resources 7.5 High -
bind-export-develTuxCare BIND's database will be slow if a very large number of RRs exist at the same name 7.5 High -
bind-export-develTuxCare Update of bind No score -
bind-export-develTuxCare Specific recursive query patterns may lead to an out-of-memory condition 7.5 High -
bind-export-develTuxCare The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
bind-export-develTuxCare Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
bind-export-develTuxCare Parsing large DNS messages may cause excessive CPU load 7.5 High -
bind-export-develTuxCare A stack exhaustion flaw in control channel code may cause named to terminate unexpectedly 7.5 High -
bind-export-develTuxCare named's configured cache size limit can be significantly exceeded 7.5 High -
bind-export-develTuxCare An UPDATE message flood may cause named to exhaust all available memory 7.5 High -
bind-export-develTuxCare Memory leaks in EdDSA DNSSEC verification code 7.5 High -
bind-export-develTuxCare Memory leak in ECDSA DNSSEC verification code 7.5 High -
bind-export-develTuxCare Processing large delegations may severely degrade resolver performance 5.3 Medium -
bind-export-develTuxCare DNS forwarders - cache poisoning vulnerability 6.8 Medium -
bind-export-develTuxCare Lame cache can be abused to severely degrade resolver performance 5.3 Medium -
bind-export-develTuxCare A broken inbound incremental zone update (IXFR) can cause named to terminate unexpectedly 6.5 Medium