bind-export-libs vulnerabilities (TuxCare)
29 vulnerabilities.
-
bind-export-libsTuxCare Validating resolver can abort while caching a mismatched NOQNAME proof 7.5 High -
bind-export-libsTuxCare Use-after-free in query_addnoqnameproof() via the DNS64 filter64 path 7.5 High -
bind-export-libsTuxCare Remote assertion failure via 16-bit length truncation in `dns_ncache_add()` 7.5 High -
bind-export-libsTuxCare DNSSEC Validation Bypass via Out-of-Zone NSEC Next Field 8.6 High -
bind-export-libsTuxCare Unexpected exit in certain situations with NSEC and NSEC3 both present 7.5 High -
bind-export-libsTuxCare Potential memory usage beyond configured limits 7.5 High -
bind-export-libsTuxCare Incorrect acceptance of NSEC3 records 6.8 Medium -
bind-export-libsTuxCare Invalid handling of CLASS != IN 7.5 High -
bind-export-libsTuxCare Amplification vulnerabilities via self-pointed glue records 5.3 Medium -
bind-export-libsTuxCare BIND 9 server memory exhaustion during GSS-API TKEY negotiation 7.5 High -
bind-export-libsTuxCare Excessive NSEC3 iterations cause high CPU load during insecure delegation validation 7.5 High -
bind-export-libsTuxCare Cache poisoning attacks with unsolicited RRs 8.6 High -
bind-export-libsTuxCare Many records in the additional section cause CPU exhaustion 7.5 High -
bind-export-libsTuxCare SIG(0) can be used to exhaust CPU resources 7.5 High -
bind-export-libsTuxCare BIND's database will be slow if a very large number of RRs exist at the same name 7.5 High -
bind-export-libsTuxCare Update of bind No score -
bind-export-libsTuxCare Specific recursive query patterns may lead to an out-of-memory condition 7.5 High -
bind-export-libsTuxCare The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
bind-export-libsTuxCare Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
bind-export-libsTuxCare Parsing large DNS messages may cause excessive CPU load 7.5 High -
bind-export-libsTuxCare A stack exhaustion flaw in control channel code may cause named to terminate unexpectedly 7.5 High -
bind-export-libsTuxCare named's configured cache size limit can be significantly exceeded 7.5 High -
bind-export-libsTuxCare An UPDATE message flood may cause named to exhaust all available memory 7.5 High -
bind-export-libsTuxCare Memory leaks in EdDSA DNSSEC verification code 7.5 High -
bind-export-libsTuxCare Memory leak in ECDSA DNSSEC verification code 7.5 High -
bind-export-libsTuxCare Processing large delegations may severely degrade resolver performance 5.3 Medium -
bind-export-libsTuxCare DNS forwarders - cache poisoning vulnerability 6.8 Medium -
bind-export-libsTuxCare Lame cache can be abused to severely degrade resolver performance 5.3 Medium -
bind-export-libsTuxCare A broken inbound incremental zone update (IXFR) can cause named to terminate unexpectedly 6.5 Medium