bind-libs-lite vulnerabilities (TuxCare)
29 vulnerabilities.
-
bind-libs-liteTuxCare Validating resolver can abort while caching a mismatched NOQNAME proof 7.5 High -
bind-libs-liteTuxCare Use-after-free in query_addnoqnameproof() via the DNS64 filter64 path 7.5 High -
bind-libs-liteTuxCare Remote assertion failure via 16-bit length truncation in `dns_ncache_add()` 7.5 High -
bind-libs-liteTuxCare DNSSEC Validation Bypass via Out-of-Zone NSEC Next Field 8.6 High -
bind-libs-liteTuxCare Unexpected exit in certain situations with NSEC and NSEC3 both present 7.5 High -
bind-libs-liteTuxCare Potential memory usage beyond configured limits 7.5 High -
bind-libs-liteTuxCare Incorrect acceptance of NSEC3 records 6.8 Medium -
bind-libs-liteTuxCare Invalid handling of CLASS != IN 7.5 High -
bind-libs-liteTuxCare Amplification vulnerabilities via self-pointed glue records 5.3 Medium -
bind-libs-liteTuxCare BIND 9 server memory exhaustion during GSS-API TKEY negotiation 7.5 High -
bind-libs-liteTuxCare Excessive NSEC3 iterations cause high CPU load during insecure delegation validation 7.5 High -
bind-libs-liteTuxCare Cache poisoning attacks with unsolicited RRs 8.6 High -
bind-libs-liteTuxCare Many records in the additional section cause CPU exhaustion 7.5 High -
bind-libs-liteTuxCare SIG(0) can be used to exhaust CPU resources 7.5 High -
bind-libs-liteTuxCare BIND's database will be slow if a very large number of RRs exist at the same name 7.5 High -
bind-libs-liteTuxCare Update of bind No score -
bind-libs-liteTuxCare Specific recursive query patterns may lead to an out-of-memory condition 7.5 High -
bind-libs-liteTuxCare The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
bind-libs-liteTuxCare Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
bind-libs-liteTuxCare Parsing large DNS messages may cause excessive CPU load 7.5 High -
bind-libs-liteTuxCare A stack exhaustion flaw in control channel code may cause named to terminate unexpectedly 7.5 High -
bind-libs-liteTuxCare named's configured cache size limit can be significantly exceeded 7.5 High -
bind-libs-liteTuxCare An UPDATE message flood may cause named to exhaust all available memory 7.5 High -
bind-libs-liteTuxCare Memory leaks in EdDSA DNSSEC verification code 7.5 High -
bind-libs-liteTuxCare Memory leak in ECDSA DNSSEC verification code 7.5 High -
bind-libs-liteTuxCare Processing large delegations may severely degrade resolver performance 5.3 Medium -
bind-libs-liteTuxCare DNS forwarders - cache poisoning vulnerability 6.8 Medium -
bind-libs-liteTuxCare Lame cache can be abused to severely degrade resolver performance 5.3 Medium -
bind-libs-liteTuxCare A broken inbound incremental zone update (IXFR) can cause named to terminate unexpectedly 6.5 Medium