bind-pkcs11-devel vulnerabilities (TuxCare)
29 vulnerabilities.
bind-pkcs11-develTuxCareValidating resolver can abort while caching a mismatched NOQNAME proof7.5 Highbind-pkcs11-develTuxCareUse-after-free in query_addnoqnameproof() via the DNS64 filter64 path7.5 Highbind-pkcs11-develTuxCareRemote assertion failure via 16-bit length truncation in `dns_ncache_add()`7.5 Highbind-pkcs11-develTuxCareDNSSEC Validation Bypass via Out-of-Zone NSEC Next Field8.6 Highbind-pkcs11-develTuxCareUnexpected exit in certain situations with NSEC and NSEC3 both present7.5 Highbind-pkcs11-develTuxCarePotential memory usage beyond configured limits7.5 Highbind-pkcs11-develTuxCareIncorrect acceptance of NSEC3 records6.8 Mediumbind-pkcs11-develTuxCareInvalid handling of CLASS != IN7.5 Highbind-pkcs11-develTuxCareAmplification vulnerabilities via self-pointed glue records5.3 Mediumbind-pkcs11-develTuxCareBIND 9 server memory exhaustion during GSS-API TKEY negotiation7.5 Highbind-pkcs11-develTuxCareExcessive NSEC3 iterations cause high CPU load during insecure delegation validation7.5 Highbind-pkcs11-develTuxCareCache poisoning attacks with unsolicited RRs8.6 Highbind-pkcs11-develTuxCareMany records in the additional section cause CPU exhaustion7.5 Highbind-pkcs11-develTuxCareSIG(0) can be used to exhaust CPU resources7.5 Highbind-pkcs11-develTuxCareBIND's database will be slow if a very large number of RRs exist at the same name7.5 Highbind-pkcs11-develTuxCareUpdate of bindNo scorebind-pkcs11-develTuxCareSpecific recursive query patterns may lead to an out-of-memory condition7.5 Highbind-pkcs11-develTuxCareThe Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is...7.5 Highbind-pkcs11-develTuxCareCertain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers...7.5 Highbind-pkcs11-develTuxCareParsing large DNS messages may cause excessive CPU load7.5 Highbind-pkcs11-develTuxCareA stack exhaustion flaw in control channel code may cause named to terminate unexpectedly7.5 Highbind-pkcs11-develTuxCarenamed's configured cache size limit can be significantly exceeded7.5 Highbind-pkcs11-develTuxCareAn UPDATE message flood may cause named to exhaust all available memory7.5 Highbind-pkcs11-develTuxCareMemory leaks in EdDSA DNSSEC verification code7.5 Highbind-pkcs11-develTuxCareMemory leak in ECDSA DNSSEC verification code7.5 Highbind-pkcs11-develTuxCareProcessing large delegations may severely degrade resolver performance5.3 Mediumbind-pkcs11-develTuxCareDNS forwarders - cache poisoning vulnerability6.8 Mediumbind-pkcs11-develTuxCareLame cache can be abused to severely degrade resolver performance5.3 Mediumbind-pkcs11-develTuxCareA broken inbound incremental zone update (IXFR) can cause named to terminate unexpectedly6.5 Medium