bind-sdb-chroot vulnerabilities (TuxCare)
29 vulnerabilities.
-
bind-sdb-chrootTuxCare Validating resolver can abort while caching a mismatched NOQNAME proof 7.5 High -
bind-sdb-chrootTuxCare Use-after-free in query_addnoqnameproof() via the DNS64 filter64 path 7.5 High -
bind-sdb-chrootTuxCare Remote assertion failure via 16-bit length truncation in `dns_ncache_add()` 7.5 High -
bind-sdb-chrootTuxCare DNSSEC Validation Bypass via Out-of-Zone NSEC Next Field 8.6 High -
bind-sdb-chrootTuxCare Unexpected exit in certain situations with NSEC and NSEC3 both present 7.5 High -
bind-sdb-chrootTuxCare Potential memory usage beyond configured limits 7.5 High -
bind-sdb-chrootTuxCare Incorrect acceptance of NSEC3 records 6.8 Medium -
bind-sdb-chrootTuxCare Invalid handling of CLASS != IN 7.5 High -
bind-sdb-chrootTuxCare Amplification vulnerabilities via self-pointed glue records 5.3 Medium -
bind-sdb-chrootTuxCare BIND 9 server memory exhaustion during GSS-API TKEY negotiation 7.5 High -
bind-sdb-chrootTuxCare Excessive NSEC3 iterations cause high CPU load during insecure delegation validation 7.5 High -
bind-sdb-chrootTuxCare Cache poisoning attacks with unsolicited RRs 8.6 High -
bind-sdb-chrootTuxCare Many records in the additional section cause CPU exhaustion 7.5 High -
bind-sdb-chrootTuxCare SIG(0) can be used to exhaust CPU resources 7.5 High -
bind-sdb-chrootTuxCare BIND's database will be slow if a very large number of RRs exist at the same name 7.5 High -
bind-sdb-chrootTuxCare Update of bind No score -
bind-sdb-chrootTuxCare Specific recursive query patterns may lead to an out-of-memory condition 7.5 High -
bind-sdb-chrootTuxCare The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
bind-sdb-chrootTuxCare Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
bind-sdb-chrootTuxCare Parsing large DNS messages may cause excessive CPU load 7.5 High -
bind-sdb-chrootTuxCare A stack exhaustion flaw in control channel code may cause named to terminate unexpectedly 7.5 High -
bind-sdb-chrootTuxCare named's configured cache size limit can be significantly exceeded 7.5 High -
bind-sdb-chrootTuxCare An UPDATE message flood may cause named to exhaust all available memory 7.5 High -
bind-sdb-chrootTuxCare Memory leaks in EdDSA DNSSEC verification code 7.5 High -
bind-sdb-chrootTuxCare Memory leak in ECDSA DNSSEC verification code 7.5 High -
bind-sdb-chrootTuxCare Processing large delegations may severely degrade resolver performance 5.3 Medium -
bind-sdb-chrootTuxCare DNS forwarders - cache poisoning vulnerability 6.8 Medium -
bind-sdb-chrootTuxCare Lame cache can be abused to severely degrade resolver performance 5.3 Medium -
bind-sdb-chrootTuxCare A broken inbound incremental zone update (IXFR) can cause named to terminate unexpectedly 6.5 Medium