bind9 vulnerabilities (TuxCare)
34 vulnerabilities.
-
bind9TuxCare Fix of 8 CVEs No score -
bind9TuxCare NSEC3 insecure-referral proof can use unrelated cached NSEC3 RRsets 5.9 Medium -
bind9TuxCare Message parser retains every identical singleton RDATA, enabling wire-to-work amplification 5.3 Medium -
bind9TuxCare Resource Exhaustion via Excessive DNSSEC Cryptographic Material Matching 5.3 Medium -
bind9TuxCare Unauthenticated IXFR deltas are applied to the live zone before TSIG verification 6.5 Medium -
bind9TuxCare Validating resolver can abort while caching a mismatched NOQNAME proof 7.5 High -
bind9TuxCare Use-after-free in query_addnoqnameproof() via the DNS64 filter64 path 7.5 High -
bind9TuxCare Out-of-zone database nodes can become authoritative zone cuts 5.8 Medium -
bind9TuxCare checkwildcard() accepts an out-of-zone NSEC as a wildcard-nonexistence proof 5.9 Medium -
bind9TuxCare qpcache NOQNAME proof use-after-free crashes recursive resolver 5.9 Medium -
bind9TuxCare DNSSEC Validation Bypass via Out-of-Zone NSEC Next Field 8.6 High -
bind9TuxCare Unexpected exit in certain situations with NSEC and NSEC3 both present 7.5 High -
bind9TuxCare Cache poisoning possible with label count discrepancy, RRSIG, and wildcards 7.5 High -
bind9TuxCare Key Record using PRIVATEDNS algorithm may lead to unexpected exit 6.5 Medium -
bind9TuxCare Incorrect acceptance of NSEC3 records 6.8 Medium -
bind9TuxCare Invalid handling of CLASS != IN 7.5 High -
bind9TuxCare BIND 9 server memory exhaustion during GSS-API TKEY negotiation 7.5 High -
bind9TuxCare Excessive NSEC3 iterations cause high CPU load during insecure delegation validation 7.5 High -
bind9TuxCare Resource exhaustion via malformed DNSKEY handling 7.5 High -
bind9TuxCare Cache poisoning attacks with unsolicited RRs 8.6 High -
bind9TuxCare SIG(0) can be used to exhaust CPU resources 7.5 High -
bind9TuxCare BIND's database will be slow if a very large number of RRs exist at the same name 7.5 High -
bind9TuxCare Specific recursive query patterns may lead to an out-of-memory condition 7.5 High -
bind9TuxCare The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
bind9TuxCare Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
bind9TuxCare Parsing large DNS messages may cause excessive CPU load 7.5 High -
bind9TuxCare A stack exhaustion flaw in control channel code may cause named to terminate unexpectedly 7.5 High -
bind9TuxCare named's configured cache size limit can be significantly exceeded 7.5 High -
bind9TuxCare Memory leak in ECDSA DNSSEC verification code 7.5 High -
bind9TuxCare Processing large delegations may severely degrade resolver performance 5.3 Medium -
bind9TuxCare DNS forwarders - cache poisoning vulnerability 6.8 Medium -
bind9TuxCare Lame cache can be abused to severely degrade resolver performance 5.3 Medium -
bind9TuxCare ISC BIND 9.x before 9.9.9-P2, 9.10.x before 9.10.4-P2, and 9.11.x before 9.11.0b2, when lwresd or... 5.9 Medium -
bind9TuxCare ISC BIND through 9.9.9-P1, 9.10.x through 9.10.4-P1, and 9.11.x through 9.11.0b1 allows primary... 6.5 Medium