CVE-2018-20358
An invalid memory address dereference was discovered in the lt_prediction function of libfaad...
An invalid memory address dereference was discovered in the lt_prediction function of libfaad/lt_predict.c in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. The vulnerability causes a segmentation fault and application crash, which leads to denial of service.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
5.5
An invalid memory address dereference was discovered in the lt_prediction function of libfaad/lt_predict.c in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. The vulnerability causes a segmentation fault and application crash, which leads to denial of service.
- Record
CVE-2018-20358- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
An invalid memory address dereference was discovered in the lt_prediction function of libfaad/lt_predict.c in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. The vulnerability causes a segmentation fault and application crash, which leads to denial of service.
- Record
CVE-2018-20358- Updated
- 2026-11-02
EUVDEUVD-2018-12916 No score
An invalid memory address dereference was discovered in the lt_prediction function of libfaad/lt_predict.c in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. The vulnerability causes a segmentation fault and application crash, which leads to denial of service.
- Record
EUVD-2018-12916- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-r7r2-hqhp-35g8
5.5
An invalid memory address dereference was discovered in the lt_prediction function of libfaad...
An invalid memory address dereference was discovered in the lt_prediction function of libfaad/lt_predict.c in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. The vulnerability causes a segmentation fault and application crash, which leads to denial of service.
- Record
GHSA-r7r2-hqhp-35g8- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSVALPINE-CVE-2018-20358
5.5
An invalid memory address dereference was discovered in the lt_prediction function of libfaad/lt_predict.c in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. The vulnerability causes a segmentation fault and application crash, which leads to denial of service.
- Record
ALPINE-CVE-2018-20358- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-03
OSV
5.5
An invalid memory address dereference was discovered in the lt_prediction function of libfaad/lt_predict.c in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. The vulnerability causes a segmentation fault and application crash, which leads to denial of service.
- Record
CVE-2018-20358- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-20358
5.5
An invalid memory address dereference was discovered in the lt_prediction function of libfaad/lt_predict.c in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. The vulnerability causes a segmentation fault and application crash, which leads to denial of service.
- Record
DEBIAN-CVE-2018-20358- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-20358
5.5
An invalid memory address dereference was discovered in the lt_prediction function of libfaad/lt_predict.c in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. The vulnerability causes a segmentation fault and application crash, which leads to denial of service.
- Record
UBUNTU-CVE-2018-20358- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2025:15214-1 No score
faad2-2.11.2-2.1 on GA media
These are all security issues fixed in the faad2-2.11.2-2.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2025:15214-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
faad2Alpine:v3.10 |
before 2.9.0-r0 | 2.9.0-r0 |
faad2Alpine:v3.11 |
before 2.9.0-r0 | 2.9.0-r0 |
faad2Alpine:v3.12 |
before 2.9.0-r0 | 2.9.0-r0 |
faad2Alpine:v3.13 |
before 2.9.0-r0 | 2.9.0-r0 |
faad2Alpine:v3.14 |
before 2.9.0-r0 | 2.9.0-r0 |
faad2Alpine:v3.15 |
before 2.9.0-r0 | 2.9.0-r0 |
faad2Alpine:v3.16 |
before 2.9.0-r0 | 2.9.0-r0 |
faad2Alpine:v3.17 |
before 2.9.0-r0 | 2.9.0-r0 |
faad2Alpine:v3.18 |
before 2.9.0-r0 | 2.9.0-r0 |
faad2Alpine:v3.19 |
before 2.9.0-r0 | 2.9.0-r0 |
Show 16 moreShow less
| Package | Affected | Fixed |
|---|---|---|
faad2Alpine:v3.20 |
before 2.9.0-r0 | 2.9.0-r0 |
faad2Alpine:v3.21 |
before 2.9.0-r0 | 2.9.0-r0 |
faad2Alpine:v3.22 |
before 2.9.0-r0 | 2.9.0-r0 |
faad2Alpine:v3.23 |
before 2.9.0-r0 | 2.9.0-r0 |
faad2Alpine:v3.24 |
before 2.9.0-r0 | 2.9.0-r0 |
faad2Alpine:v3.7 |
before 2.9.0-r0 | 2.9.0-r0 |
faad2Alpine:v3.8 |
before 2.9.0-r0 | 2.9.0-r0 |
faad2Alpine:v3.9 |
before 2.9.0-r0 | 2.9.0-r0 |
faad2Debian:12 |
before 2.8.8-2 | 2.8.8-2 |
faad2Debian:13 |
before 2.8.8-2 | 2.8.8-2 |
faad2Debian:14 |
before 2.8.8-2 | 2.8.8-2 |
faad2Debian:9 From an advisory covering 14 CVEs |
before 2.8.0~cvs20161113-1+deb9u2, plus listed versions 2.8.0~cvs20161113-12.8.0~cvs20161113-1+deb9u1 |
2.8.0~cvs20161113-1+deb9u2 |
faad2Ubuntu:Pro:14.04:LTS |
All versions, plus listed versions 2.7-82.7-8+deb7u1build0.14.04.12.7-8+deb8u3build0.14.04.1~esm12.7-8+deb8u3ubuntu0.1~esm1 |
None known |
faad2Ubuntu:Pro:16.04:LTS |
All versions, plus listed versions 2.8.0~cvs20150510-12.8.0~cvs20150510-1ubuntu0.12.8.0~cvs20150510-1ubuntu0.1+esm1 |
None known |
faad2Ubuntu:Pro:18.04:LTS |
All versions, plus listed versions 2.8.1-22.8.5-12.8.6-12.8.8-12.8.8-1ubuntu0.1~esm1 |
None known |
faad2openSUSE:Tumbleweed From an advisory covering 8 CVEs |
before 2.11.2-2.1 | 2.11.2-2.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| affected | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-20358 is a medium vulnerability (CVSS 5.5) in Audiocoding Freeware Advanced Audio Decoder 2, published December 22, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.15%, the 67th percentile. Fixed in faad2 2.9.0-r0.
References
github.com/knik0/faad2/issues/31
debian.org/security/2019/dsa-4522
seclists.org/bugtraq/2019/Sep/28
security.gentoo.org/glsa/202006-17
nvd.nist.gov/vuln/detail/CVE-2018-20358
github.com/advisories/GHSA-r7r2-hqhp-35g8
Show 12 moreShow less
security.alpinelinux.org/vuln/CVE-2018-20358
security-tracker.debian.org/tracker/CVE-2018-20358
ubuntu.com/security/CVE-2018-20358
cve.org/CVERecord?id=CVE-2018-20358
suse.com/security/cve/CVE-2018-20194
suse.com/security/cve/CVE-2018-20196
suse.com/security/cve/CVE-2018-20199
suse.com/security/cve/CVE-2018-20358
suse.com/security/cve/CVE-2018-20359
suse.com/security/cve/CVE-2018-20362
suse.com/security/cve/CVE-2019-15296
suse.com/security/cve/CVE-2019-6956