Every CVE Search/ Get API key

CVE-2018-20358

An invalid memory address dereference was discovered in the lt_prediction function of libfaad...

5.5 MediumFix available

An invalid memory address dereference was discovered in the lt_prediction function of libfaad/lt_predict.c in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. The vulnerability causes a segmentation fault and application crash, which leads to denial of service.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.15%Down 0.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 5.5

An invalid memory address dereference was discovered in the lt_prediction function of libfaad/lt_predict.c in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. The vulnerability causes a segmentation fault and application crash, which leads to denial of service.

Record
CVE-2018-20358
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

An invalid memory address dereference was discovered in the lt_prediction function of libfaad/lt_predict.c in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. The vulnerability causes a segmentation fault and application crash, which leads to denial of service.

Record
CVE-2018-20358
Updated
2026-11-02
EUVDEUVD-2018-12916 No score

An invalid memory address dereference was discovered in the lt_prediction function of libfaad/lt_predict.c in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. The vulnerability causes a segmentation fault and application crash, which leads to denial of service.

Record
EUVD-2018-12916
Updated
2026-11-03
GitHub AdvisoriesGHSA-r7r2-hqhp-35g8 5.5

An invalid memory address dereference was discovered in the lt_prediction function of libfaad...

An invalid memory address dereference was discovered in the lt_prediction function of libfaad/lt_predict.c in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. The vulnerability causes a segmentation fault and application crash, which leads to denial of service.

Record
GHSA-r7r2-hqhp-35g8
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-119
Updated
2026-11-02
OSVALPINE-CVE-2018-20358 5.5

An invalid memory address dereference was discovered in the lt_prediction function of libfaad/lt_predict.c in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. The vulnerability causes a segmentation fault and application crash, which leads to denial of service.

Record
ALPINE-CVE-2018-20358
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-03
OSV 5.5

An invalid memory address dereference was discovered in the lt_prediction function of libfaad/lt_predict.c in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. The vulnerability causes a segmentation fault and application crash, which leads to denial of service.

Record
CVE-2018-20358
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2018-20358 5.5

An invalid memory address dereference was discovered in the lt_prediction function of libfaad/lt_predict.c in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. The vulnerability causes a segmentation fault and application crash, which leads to denial of service.

Record
DEBIAN-CVE-2018-20358
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2018-20358 5.5

An invalid memory address dereference was discovered in the lt_prediction function of libfaad/lt_predict.c in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. The vulnerability causes a segmentation fault and application crash, which leads to denial of service.

Record
UBUNTU-CVE-2018-20358
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2025:15214-1 No score

faad2-2.11.2-2.1 on GA media

These are all security issues fixed in the faad2-2.11.2-2.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2025:15214-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
faad2
Alpine:v3.10
before 2.9.0-r0
2.9.0-r0
faad2
Alpine:v3.11
before 2.9.0-r0
2.9.0-r0
faad2
Alpine:v3.12
before 2.9.0-r0
2.9.0-r0
faad2
Alpine:v3.13
before 2.9.0-r0
2.9.0-r0
faad2
Alpine:v3.14
before 2.9.0-r0
2.9.0-r0
faad2
Alpine:v3.15
before 2.9.0-r0
2.9.0-r0
faad2
Alpine:v3.16
before 2.9.0-r0
2.9.0-r0
faad2
Alpine:v3.17
before 2.9.0-r0
2.9.0-r0
faad2
Alpine:v3.18
before 2.9.0-r0
2.9.0-r0
faad2
Alpine:v3.19
before 2.9.0-r0
2.9.0-r0
Show 16 moreShow less
Affected packages
PackageAffectedFixed
faad2
Alpine:v3.20
before 2.9.0-r0
2.9.0-r0
faad2
Alpine:v3.21
before 2.9.0-r0
2.9.0-r0
faad2
Alpine:v3.22
before 2.9.0-r0
2.9.0-r0
faad2
Alpine:v3.23
before 2.9.0-r0
2.9.0-r0
faad2
Alpine:v3.24
before 2.9.0-r0
2.9.0-r0
faad2
Alpine:v3.7
before 2.9.0-r0
2.9.0-r0
faad2
Alpine:v3.8
before 2.9.0-r0
2.9.0-r0
faad2
Alpine:v3.9
before 2.9.0-r0
2.9.0-r0
faad2
Debian:12
before 2.8.8-2
2.8.8-2
faad2
Debian:13
before 2.8.8-2
2.8.8-2
faad2
Debian:14
before 2.8.8-2
2.8.8-2
faad2
Debian:9
From an advisory covering 14 CVEs
before 2.8.0~cvs20161113-1+deb9u2, plus listed versions
2.8.0~cvs20161113-12.8.0~cvs20161113-1+deb9u1
2.8.0~cvs20161113-1+deb9u2
faad2
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
2.7-82.7-8+deb7u1build0.14.04.12.7-8+deb8u3build0.14.04.1~esm12.7-8+deb8u3ubuntu0.1~esm1
None known
faad2
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
2.8.0~cvs20150510-12.8.0~cvs20150510-1ubuntu0.12.8.0~cvs20150510-1ubuntu0.1+esm1
None known
faad2
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
2.8.1-22.8.5-12.8.6-12.8.8-12.8.8-1ubuntu0.1~esm1
None known
faad2
openSUSE:Tumbleweed
From an advisory covering 8 CVEs
before 2.11.2-2.1
2.11.2-2.1

History

History
RecordedChangedSources
affected, facts
affectedOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-20358 is a medium vulnerability (CVSS 5.5) in Audiocoding Freeware Advanced Audio Decoder 2, published December 22, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.15%, the 67th percentile. Fixed in faad2 2.9.0-r0.

References

Show 12 moreShow less
MoveEnter Open