Every CVE Search/ Get API key

CVE-2015-2269

Moodle XSS Vulnerability

3.5 LowPublic exploitFix available

Multiple cross-site scripting (XSS) vulnerabilities in lib/javascript-static.js in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 allow remote authenticated users to inject arbitrary web script or HTML via a (1) alt or (2) title attribute in an IMG element.

Exploit likelihood

3.26%Up 0.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 3.5

Multiple cross-site scripting (XSS) vulnerabilities in lib/javascript-static.js in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 allow remote authenticated users to inject arbitrary web script or HTML via a (1) alt or (2) title attribute in an IMG element.

Record
CVE-2015-2269
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Multiple cross-site scripting (XSS) vulnerabilities in lib/javascript-static.js in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 allow remote authenticated users to inject arbitrary web script or HTML via a (1) alt or (2) title attribute in an IMG element.

Record
CVE-2015-2269
Updated
2026-11-02
EUVDEUVD-2022-3601 No score

Multiple cross-site scripting (XSS) vulnerabilities in lib/javascript-static.js in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 allow remote authenticated users to inject arbitrary web script or HTML via a (1) alt or (2) title attribute in an IMG element.

Record
EUVD-2022-3601
Updated
2026-11-03
GitHub AdvisoriesGHSA-cp39-43xr-2wrp No score

Moodle XSS Vulnerability

Multiple cross-site scripting (XSS) vulnerabilities in lib/javascript-static.js in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 allow remote authenticated users to inject arbitrary web script or HTML via a (1) alt or (2) title attribute in an IMG element.

Record
GHSA-cp39-43xr-2wrp
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-cp39-43xr-2wrp No score

Moodle XSS Vulnerability

Multiple cross-site scripting (XSS) vulnerabilities in lib/javascript-static.js in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 allow remote authenticated users to inject arbitrary web script or HTML via a (1) alt or (2) title attribute in an IMG element.

Record
GHSA-cp39-43xr-2wrp
Weakness
CWE-79
Updated
2026-11-02
OSVMGASA-2015-0110 No score

Updated moodle packages fix security vulnerabilities

Updated moodle package fixes security vulnerabilities:

In Moodle before 2.6.9, by modifying URL a logged in user can view the list of another user's contacts, number of unread messages and list of their courses (CVE-2015-2266).

In Moodle before 2.6.9, authentication in mdeploy can be bypassed. It is theoretically possible to extract files anywhere on the system where the web server has write access. The attacking user must know details about the system and already have significant permissions on the site (CVE-2015-2267).

In Moodle before 2.6.9, a non-optimal regular expression in the "Convert links to URLs" filter could be exploited to create extra server load or make particular pages unavailable (CVE-2015-2268).

In Moodle before 2.6.9, it is possible to create HTML injection through blocks with configurable titles, however this could only be exploited by users who are already marked as XSS-trusted (CVE-2015-2269).

In Moodle before 2.6.9, for the custom themes that use blocks regions in the base layout the blocks for inaccessible courses could be displayed together with sensitive course-related information. Most of the themes, including all standard Moodle themes, are not affected (CVE-2015-2270).

In Moodle before 2.6.9, users without proper permission are able to mark tags as inappropriate. Since this capability is given to authenticated users by default, this is not an issue for most sites (CVE-2015-2271).

In Moodle before 2.6.9, even when user's password is forced to be changed on login, user could still use it for authentication in order to create the web service token and therefore extend the life of the temporary password via web services (CVE-2015-2272).

In Moodle before 2.6.9, Quiz statistics report did not properly escape student responses and could be used for XSS attack (CVE-2015-2273).

Record
MGASA-2015-0110
Updated
2026-11-02
OSVUBUNTU-CVE-2015-2269 No score

Multiple cross-site scripting (XSS) vulnerabilities in lib/javascript-static.js in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 allow remote authenticated users to inject arbitrary web script or HTML via a (1) alt or (2) title attribute in an IMG element.

Record
UBUNTU-CVE-2015-2269
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
through 2.5.9 None known
moodle/moodle
Packagist
2.6.0 up to 2.6.9
2.6.9
moodle/moodle
Packagist
2.7.0 up to 2.7.6
2.7.6
moodle/moodle
Packagist
2.8.0 up to 2.8.4
2.8.4
moodle/moodle
Packagist
through 2.5.9, plus listed versions
v2.3.10v2.3.11v2.3.4v2.3.5v2.3.6
Show 28 moreShow less
v2.3.7v2.3.8v2.3.9v2.4.0v2.4.0-rc1v2.4.1v2.4.10v2.4.11v2.4.2v2.4.3v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-betav2.5.0-rc1v2.5.1v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8v2.5.9
None known
moodle/moodle
Packagist
2.6.0 up to 2.6.9, plus listed versions
v2.6.0v2.6.1v2.6.2v2.6.3v2.6.4
Show 4 moreShow less
v2.6.5v2.6.6v2.6.7v2.6.8
2.6.9
moodle/moodle
Packagist
2.7.0 up to 2.7.6, plus listed versions
v2.7.0v2.7.1v2.7.2v2.7.3v2.7.4v2.7.5
2.7.6
moodle/moodle
Packagist
2.8.0 up to 2.8.4, plus listed versions
v2.8.0v2.8.1v2.8.2v2.8.3
2.8.4
moodle
Mageia:4
before 2.6.10-1.mga4
2.6.10-1.mga4

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBMoodle 2.5.9/2.6.8/2.7.5/2.8.3 - Block Title Handler Cross-Site Scripting2015-03-17

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-2269 is a low vulnerability (CVSS 3.5) in Moodle, published March 18, 2015. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 3.26%, the 88th percentile. Fixed in moodle/moodle 2.6.9.

References

Show 15 moreShow less
MoveEnter Open