CVE-2015-2266
Moodle allows attackers to obtain sensitive personal-contact and unread-message-count information
message/index.php in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 does not consider the moodle/site:readallmessages capability before accessing arbitrary conversations, which allows remote authenticated users to obtain sensitive personal-contact and unread-message-count information via a modified URL.
Exploit likelihood
What each source reports
NVD Score used
4.0
message/index.php in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 does not consider the moodle/site:readallmessages capability before accessing arbitrary conversations, which allows remote authenticated users to obtain sensitive personal-contact and unread-message-count information via a modified URL.
- Record
CVE-2015-2266- CVSS 2.0
- 4.0 Medium
AV:N/AC:L/Au:S/C:P/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
CVE List No score
message/index.php in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 does not consider the moodle/site:readallmessages capability before accessing arbitrary conversations, which allows remote authenticated users to obtain sensitive personal-contact and unread-message-count information via a modified URL.
- Record
CVE-2015-2266- Updated
- 2026-11-02
EUVDEUVD-2022-2115 No score
message/index.php in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 does not consider the moodle/site:readallmessages capability before accessing arbitrary conversations, which allows remote authenticated users to obtain sensitive personal-contact and unread-message-count information via a modified URL.
- Record
EUVD-2022-2115- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-35pr-gqm6-r366 No score
Moodle allows attackers to obtain sensitive personal-contact and unread-message-count information
message/index.php in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 does not consider the moodle/site:readallmessages capability before accessing arbitrary conversations, which allows remote authenticated users to obtain sensitive personal-contact and unread-message-count information via a modified URL.
- Record
GHSA-35pr-gqm6-r366- Weakness
- CWE-200
- Updated
- 2026-11-02
OSVGHSA-35pr-gqm6-r366 No score
Moodle allows attackers to obtain sensitive personal-contact and unread-message-count information
message/index.php in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 does not consider the moodle/site:readallmessages capability before accessing arbitrary conversations, which allows remote authenticated users to obtain sensitive personal-contact and unread-message-count information via a modified URL.
- Record
GHSA-35pr-gqm6-r366- Weakness
- CWE-200
- Updated
- 2026-11-02
OSVMGASA-2015-0110 No score
Updated moodle packages fix security vulnerabilities
Updated moodle package fixes security vulnerabilities:
In Moodle before 2.6.9, by modifying URL a logged in user can view the list of another user's contacts, number of unread messages and list of their courses (CVE-2015-2266).
In Moodle before 2.6.9, authentication in mdeploy can be bypassed. It is theoretically possible to extract files anywhere on the system where the web server has write access. The attacking user must know details about the system and already have significant permissions on the site (CVE-2015-2267).
In Moodle before 2.6.9, a non-optimal regular expression in the "Convert links to URLs" filter could be exploited to create extra server load or make particular pages unavailable (CVE-2015-2268).
In Moodle before 2.6.9, it is possible to create HTML injection through blocks with configurable titles, however this could only be exploited by users who are already marked as XSS-trusted (CVE-2015-2269).
In Moodle before 2.6.9, for the custom themes that use blocks regions in the base layout the blocks for inaccessible courses could be displayed together with sensitive course-related information. Most of the themes, including all standard Moodle themes, are not affected (CVE-2015-2270).
In Moodle before 2.6.9, users without proper permission are able to mark tags as inappropriate. Since this capability is given to authenticated users by default, this is not an issue for most sites (CVE-2015-2271).
In Moodle before 2.6.9, even when user's password is forced to be changed on login, user could still use it for authentication in order to create the web service token and therefore extend the life of the temporary password via web services (CVE-2015-2272).
In Moodle before 2.6.9, Quiz statistics report did not properly escape student responses and could be used for XSS attack (CVE-2015-2273).
- Record
MGASA-2015-0110- Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-2266 No score
message/index.php in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 does not consider the moodle/site:readallmessages capability before accessing arbitrary conversations, which allows remote authenticated users to obtain sensitive personal-contact and unread-message-count information via a modified URL.
- Record
UBUNTU-CVE-2015-2266- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moodle/moodlePackagist |
before 2.6.9 | 2.6.9 |
moodle/moodlePackagist |
2.7.0 up to 2.7.6 | 2.7.6 |
moodle/moodlePackagist |
2.8.0 up to 2.8.4 | 2.8.4 |
moodle/moodlePackagist |
before 2.6.9, plus listed versions v2.3.10v2.3.11v2.3.4v2.3.5v2.3.6 Show 39 moreShow lessv2.3.7v2.3.8v2.3.9v2.4.0v2.4.0-rc1v2.4.1v2.4.10v2.4.11v2.4.2v2.4.3v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-betav2.5.0-rc1v2.5.1v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8v2.5.9v2.6.0v2.6.0-betav2.6.0-rc1v2.6.1v2.6.2v2.6.3v2.6.4v2.6.5v2.6.6v2.6.7v2.6.8 |
2.6.9 |
moodle/moodlePackagist |
2.7.0 up to 2.7.6, plus listed versions v2.7.0v2.7.1v2.7.2v2.7.3v2.7.4v2.7.5 |
2.7.6 |
moodle/moodlePackagist |
2.8.0 up to 2.8.4, plus listed versions v2.8.0v2.8.1v2.8.2v2.8.3 |
2.8.4 |
moodleMageia:4 From an advisory covering 8 CVEs |
before 2.6.10-1.mga4 | 2.6.10-1.mga4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-2266 is a medium vulnerability (CVSS 4.0) in Moodle, published March 18, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.67%, the 76th percentile. Fixed in moodle/moodle 2.6.9.
References
git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-49204
moodle.org/mod/forum/discuss.php?d=307380
openwall.com/lists/oss-security/2015/03/16/1
nvd.nist.gov/vuln/detail/CVE-2015-2266
github.com/moodle/moodle/commit/2924ba1c73f9ed3d525987807f9d289b3eb38154
github.com/moodle/moodle/commit/553319be03c4ef8e62499841c8d5d94c6786ed6d
Show 18 moreShow less
github.com/moodle/moodle/commit/c35df119a560e22d9e17f833b736b710b96431d9
github.com/moodle/moodle/commit/eb45017b61e35bcab8c35e2c544b1e4144ca1f16
github.com/advisories/GHSA-35pr-gqm6-r366
github.com/moodle/moodle
advisories.mageia.org/MGASA-2015-0110.html
bugs.mageia.org/show_bug.cgi?id=15501
moodle.org/mod/forum/discuss.php?d=307381
moodle.org/mod/forum/discuss.php?d=307382
moodle.org/mod/forum/discuss.php?d=307383
moodle.org/mod/forum/discuss.php?d=307384
moodle.org/mod/forum/discuss.php?d=307385
moodle.org/mod/forum/discuss.php?d=307386
moodle.org/mod/forum/discuss.php?d=307387
docs.moodle.org/dev/Moodle_2.6.10_release_notes
moodle.org/mod/forum/discuss.php?d=305077
ubuntu.com/security/CVE-2015-2266
openwall.com/lists/oss-security/2015/03/16
cve.org/CVERecord?id=CVE-2015-2266