CVE-2016-1901
Integer overflow in the authenticate_post function in CGit before 0.12 allows remote attackers to...
CVE-2016-1901 is a critical vulnerability (CVSS 9.8) in Cgit Project Cgit, published January 20, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.79%, the 89th percentile. Fixed in cgit 0.11.2.git2.3.2-1.1.
Integer overflow in the authenticate_post function in CGit before 0.12 allows remote attackers to have unspecified impact via a large value in the Content-Length HTTP header, which triggers a buffer overflow.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
Integer overflow in the authenticate_post function in CGit before 0.12 allows remote attackers to have unspecified impact via a large value in the Content-Length HTTP header, which triggers a buffer overflow.
- Record
CVE-2016-1901- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
Integer overflow in the authenticate_post function in CGit before 0.12 allows remote attackers to have unspecified impact via a large value in the Content-Length HTTP header, which triggers a buffer overflow.
- Record
CVE-2016-1901- Updated
- 2026-11-02
EUVDEUVD-2016-2995 No score
Integer overflow in the authenticate_post function in CGit before 0.12 allows remote attackers to have unspecified impact via a large value in the Content-Length HTTP header, which triggers a buffer overflow.
- Record
EUVD-2016-2995- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-r786-p84w-55j2
9.8
Integer overflow in the authenticate_post function in CGit before 0.12 allows remote attackers to...
Integer overflow in the authenticate_post function in CGit before 0.12 allows remote attackers to have unspecified impact via a large value in the Content-Length HTTP header, which triggers a buffer overflow.
- Record
GHSA-r786-p84w-55j2- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSV
9.8
Integer overflow in the authenticate_post function in CGit before 0.12 allows remote attackers to have unspecified impact via a large value in the Content-Length HTTP header, which triggers a buffer overflow.
- Record
CVE-2016-1901- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2016-1901
9.8
Integer overflow in the authenticate_post function in CGit before 0.12 allows remote attackers to have unspecified impact via a large value in the Content-Length HTTP header, which triggers a buffer overflow.
- Record
DEBIAN-CVE-2016-1901- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-1901
9.8
Integer overflow in the authenticate_post function in CGit before 0.12 allows remote attackers to have unspecified impact via a large value in the Content-Length HTTP header, which triggers a buffer overflow.
- Record
UBUNTU-CVE-2016-1901- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2016-0047 No score
Updated cgit packages fix security vulnerability
Reflected Cross Site Scripting and Header Injection in Mimetype Query String in cgit before 0.12 (CVE-2016-1899).
Stored Cross Site Scripting and Header Injection in Filename Parameter in cgit before 0.12 (CVE-2016-1900).
Integer Overflow resulting in Buffer Overflow in cgit before 0.12 (CVE-2016-1901).
- Record
MGASA-2016-0047- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10137-1 No score
cgit-1.0-1.3 on GA media
These are all security issues fixed in the cgit-1.0-1.3 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10137-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
cgitDebian:12 |
before 0.11.2.git2.3.2-1.1 | 0.11.2.git2.3.2-1.1 |
cgitDebian:13 |
before 0.11.2.git2.3.2-1.1 | 0.11.2.git2.3.2-1.1 |
cgitDebian:14 |
before 0.11.2.git2.3.2-1.1 | 0.11.2.git2.3.2-1.1 |
cgitDebian:8 |
before 0.10.2.git2.0.1-3+deb8u1, plus listed versions 0.10.2.git2.0.1-3 |
0.10.2.git2.0.1-3+deb8u1 |
cgitMageia:5 |
before 0.12-1.mga5 | 0.12-1.mga5 |
cgitopenSUSE:Tumbleweed |
before 1.0-1.3 | 1.0-1.3 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | affected | |
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
openwall.com/lists/oss-security/2016/01/14/3
lists.opensuse.org/opensuse-updates/2016-01/msg00084.html
lists.zx2c4.com/pipermail/cgit/2016-January/002817.html
lists.fedoraproject.org/pipermail/package-announce/2016-January/176198.html
git.zx2c4.com/cgit/commit?id=4458abf64172a62b92810c2293450106e6dfc763
lists.opensuse.org/opensuse-updates/2016-01/msg00067.html
Show 19 moreShow less
openwall.com/lists/oss-security/2016/01/14/6
debian.org/security/2016/dsa-3545
lists.fedoraproject.org/pipermail/package-announce/2016-January/176167.html
nvd.nist.gov/vuln/detail/CVE-2016-1901
github.com/advisories/GHSA-r786-p84w-55j2
security-tracker.debian.org/tracker/CVE-2016-1901
advisories.mageia.org/MGASA-2016-0047.html
bugs.mageia.org/show_bug.cgi?id=17495
ubuntu.com/security/CVE-2016-1901
cve.org/CVERecord?id=CVE-2016-1901
suse.com/security/cve/CVE-2011-2711
suse.com/security/cve/CVE-2012-4465
suse.com/security/cve/CVE-2012-4548
suse.com/security/cve/CVE-2013-2117
suse.com/security/cve/CVE-2016-1899
suse.com/security/cve/CVE-2016-1900
suse.com/security/cve/CVE-2016-1901
suse.com/security/cve/CVE-2016-2315
suse.com/security/cve/CVE-2016-2324