Every CVE Search/ Get API key

CVE-2016-1901

Integer overflow in the authenticate_post function in CGit before 0.12 allows remote attackers to...

9.8 CriticalFix available

CVE-2016-1901 is a critical vulnerability (CVSS 9.8) in Cgit Project Cgit, published January 20, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.79%, the 89th percentile. Fixed in cgit 0.11.2.git2.3.2-1.1.

Integer overflow in the authenticate_post function in CGit before 0.12 allows remote attackers to have unspecified impact via a large value in the Content-Length HTTP header, which triggers a buffer overflow.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

3.79%Up 1.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.8

Integer overflow in the authenticate_post function in CGit before 0.12 allows remote attackers to have unspecified impact via a large value in the Content-Length HTTP header, which triggers a buffer overflow.

Record
CVE-2016-1901
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Integer overflow in the authenticate_post function in CGit before 0.12 allows remote attackers to have unspecified impact via a large value in the Content-Length HTTP header, which triggers a buffer overflow.

Record
CVE-2016-1901
Updated
2026-11-02
EUVDEUVD-2016-2995 No score

Integer overflow in the authenticate_post function in CGit before 0.12 allows remote attackers to have unspecified impact via a large value in the Content-Length HTTP header, which triggers a buffer overflow.

Record
EUVD-2016-2995
Updated
2026-11-03
GitHub AdvisoriesGHSA-r786-p84w-55j2 9.8

Integer overflow in the authenticate_post function in CGit before 0.12 allows remote attackers to...

Integer overflow in the authenticate_post function in CGit before 0.12 allows remote attackers to have unspecified impact via a large value in the Content-Length HTTP header, which triggers a buffer overflow.

Record
GHSA-r786-p84w-55j2
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-119
Updated
2026-11-02
OSV 9.8

Integer overflow in the authenticate_post function in CGit before 0.12 allows remote attackers to have unspecified impact via a large value in the Content-Length HTTP header, which triggers a buffer overflow.

Record
CVE-2016-1901
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2016-1901 9.8

Integer overflow in the authenticate_post function in CGit before 0.12 allows remote attackers to have unspecified impact via a large value in the Content-Length HTTP header, which triggers a buffer overflow.

Record
DEBIAN-CVE-2016-1901
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2016-1901 9.8

Integer overflow in the authenticate_post function in CGit before 0.12 allows remote attackers to have unspecified impact via a large value in the Content-Length HTTP header, which triggers a buffer overflow.

Record
UBUNTU-CVE-2016-1901
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2016-0047 No score

Updated cgit packages fix security vulnerability

Reflected Cross Site Scripting and Header Injection in Mimetype Query String in cgit before 0.12 (CVE-2016-1899).

Stored Cross Site Scripting and Header Injection in Filename Parameter in cgit before 0.12 (CVE-2016-1900).

Integer Overflow resulting in Buffer Overflow in cgit before 0.12 (CVE-2016-1901).

Record
MGASA-2016-0047
Updated
2026-11-02
OSVopenSUSE-SU-2024:10137-1 No score

cgit-1.0-1.3 on GA media

These are all security issues fixed in the cgit-1.0-1.3 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10137-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
cgit
Debian:12
before 0.11.2.git2.3.2-1.1
0.11.2.git2.3.2-1.1
cgit
Debian:13
before 0.11.2.git2.3.2-1.1
0.11.2.git2.3.2-1.1
cgit
Debian:14
before 0.11.2.git2.3.2-1.1
0.11.2.git2.3.2-1.1
cgit
Debian:8
before 0.10.2.git2.0.1-3+deb8u1, plus listed versions
0.10.2.git2.0.1-3
0.10.2.git2.0.1-3+deb8u1
cgit
Mageia:5
before 0.12-1.mga5
0.12-1.mga5
cgit
openSUSE:Tumbleweed
before 1.0-1.3
1.0-1.3

History

History
WhenChangedSources
2026-11-03affected
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 19 moreShow less
MoveEnter Open