Every CVE Search/ Get API key

CVE-2016-7405

ADOdb Library SQL Injection

9.8 CriticalFix available

The qstr method in the PDO driver in the ADOdb Library for PHP before 5.x before 5.20.7 might allow remote attackers to conduct SQL injection attacks via vectors related to incorrect quoting.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.98%Up 1.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.8

The qstr method in the PDO driver in the ADOdb Library for PHP before 5.x before 5.20.7 might allow remote attackers to conduct SQL injection attacks via vectors related to incorrect quoting.

Record
CVE-2016-7405
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-89
Updated
2026-11-02
CVE List No score

The qstr method in the PDO driver in the ADOdb Library for PHP before 5.x before 5.20.7 might allow remote attackers to conduct SQL injection attacks via vectors related to incorrect quoting.

Record
CVE-2016-7405
Updated
2026-11-02
EUVDEUVD-2022-2169 No score

The qstr method in the PDO driver in the ADOdb Library for PHP before 5.x before 5.20.7 might allow remote attackers to conduct SQL injection attacks via vectors related to incorrect quoting.

Record
EUVD-2022-2169
Updated
2026-11-03
GitHub AdvisoriesGHSA-3fj4-q72x-x2g9 9.8

ADOdb Library SQL Injection

The qstr method in the PDO driver in the ADOdb Library for PHP before 5.x before 5.20.7 might allow remote attackers to conduct SQL injection attacks via vectors related to incorrect quoting.

Record
GHSA-3fj4-q72x-x2g9
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-89
Updated
2026-11-02
OSV 9.8

The qstr method in the PDO driver in the ADOdb Library for PHP before 5.x before 5.20.7 might allow remote attackers to conduct SQL injection attacks via vectors related to incorrect quoting.

Record
CVE-2016-7405
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2016-7405 9.8

The qstr method in the PDO driver in the ADOdb Library for PHP before 5.x before 5.20.7 might allow remote attackers to conduct SQL injection attacks via vectors related to incorrect quoting.

Record
DEBIAN-CVE-2016-7405
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVGHSA-3fj4-q72x-x2g9 9.8

ADOdb Library SQL Injection

The qstr method in the PDO driver in the ADOdb Library for PHP before 5.x before 5.20.7 might allow remote attackers to conduct SQL injection attacks via vectors related to incorrect quoting.

Record
GHSA-3fj4-q72x-x2g9
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-89
Updated
2026-11-02
OSVUBUNTU-CVE-2016-7405 9.8

The qstr method in the PDO driver in the ADOdb Library for PHP before 5.x before 5.20.7 might allow remote attackers to conduct SQL injection attacks via vectors related to incorrect quoting.

Record
UBUNTU-CVE-2016-7405
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2016-0363 No score

Updated php-adodb packages fix security vulnerabilities

The qstr method in the PDO driver in the ADOdb Library for PHP before 5.x before 5.20.7 might allow remote attackers to conduct SQL injection attacks via vectors related to incorrect quoting. (CVE-2016-7405)

Cross Site Scripting vulnerability in test script (CVE-2016-4855)

Record
MGASA-2016-0363
Updated
2026-11-02
OSVUSN-6825-1 No score

libphp-adodb vulnerabilities

It was discovered that the PDO driver in ADOdb was incorrectly handling string quotes. A remote attacker could possibly use this issue to perform SQL injection attacks. This issue only affected Ubuntu 16.04 LTS. (CVE-2016-7405)

It was discovered that ADOdb was incorrectly handling GET parameters in test.php. A remote attacker could possibly use this issue to execute cross-site scripting (XSS) attacks. This issue only affected Ubuntu 16.04 LTS. (CVE-2016-4855)

Emmet Leahy discovered that ADOdb was incorrectly handling string quotes in PostgreSQL connections. A remote attacker could possibly use this issue to bypass authentication. (CVE-2021-3850)

Record
USN-6825-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
adodb/adodb-php
Packagist
5.0 up to 5.20.7
5.20.7
libphp-adodb
Debian:12
before 5.20.6-1
5.20.6-1
libphp-adodb
Debian:13
before 5.20.6-1
5.20.6-1
libphp-adodb
Debian:14
before 5.20.6-1
5.20.6-1
libphp-adodb
Debian:7
before 5.15-1+deb7u1, plus listed versions
5.15-1
5.15-1+deb7u1
adodb/adodb-php
Packagist
5.0 up to 5.20.7, plus listed versions
v5.19v5.20.0v5.20.1v5.20.2v5.20.3v5.20.4v5.20.5v5.20.6
5.20.7
php-adodb
Mageia:5
before 5.18-5.1.mga5
5.18-5.1.mga5
libphp-adodb
Ubuntu:Pro:16.04:LTS
before 5.20.3-1ubuntu1+esm1, plus listed versions
5.18a-15.20.1-15.20.2-15.20.2-25.20.3-15.20.3-1ubuntu1
5.20.3-1ubuntu1+esm1
libphp-adodb
Ubuntu:Pro:18.04:LTS
before 5.20.9-1ubuntu0.1~esm1, plus listed versions
5.20.9-1
5.20.9-1ubuntu0.1~esm1
libphp-adodb
Ubuntu:Pro:20.04:LTS
before 5.20.16-1ubuntu0.1~esm1, plus listed versions
5.20.14-15.20.15-15.20.16-1
5.20.16-1ubuntu0.1~esm1
libphp-adodb
Ubuntu:22.04:LTS
before 5.20.19-1ubuntu0.1, plus listed versions
5.20.19-1
5.20.19-1ubuntu0.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-7405 is a critical vulnerability (CVSS 9.8) in Adodb Project Adodb, published September 13, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.98%, the 87th percentile. Fixed in adodb/adodb-php 5.20.7.

References

Show 17 moreShow less
MoveEnter Open