CVE-2016-4855
ADOdb Cross-site scripting vulnerability in old test script
Cross-site scripting vulnerability in ADOdb versions prior to 5.20.6 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
Cross-site scripting vulnerability in ADOdb versions prior to 5.20.6 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
CVE-2016-4855- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting vulnerability in ADOdb versions prior to 5.20.6 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
CVE-2016-4855- Updated
- 2026-11-02
EUVDEUVD-2022-4154 No score
Cross-site scripting vulnerability in ADOdb versions prior to 5.20.6 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
EUVD-2022-4154- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-hhfw-xxhm-pf32
6.1
ADOdb Cross-site scripting vulnerability in old test script
Cross-site scripting vulnerability in ADOdb versions prior to 5.20.6 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
GHSA-hhfw-xxhm-pf32- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
Cross-site scripting vulnerability in ADOdb versions prior to 5.20.6 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
CVE-2016-4855- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2016-4855
6.1
Cross-site scripting vulnerability in ADOdb versions prior to 5.20.6 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
DEBIAN-CVE-2016-4855- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
Show 4 moreShow less
OSVGHSA-hhfw-xxhm-pf32
6.1
ADOdb Cross-site scripting vulnerability in old test script
Cross-site scripting vulnerability in ADOdb versions prior to 5.20.6 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
GHSA-hhfw-xxhm-pf32- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-4855
6.1
Cross-site scripting vulnerability in ADOdb versions prior to 5.20.6 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
UBUNTU-CVE-2016-4855- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVMGASA-2016-0363 No score
Updated php-adodb packages fix security vulnerabilities
The qstr method in the PDO driver in the ADOdb Library for PHP before 5.x before 5.20.7 might allow remote attackers to conduct SQL injection attacks via vectors related to incorrect quoting. (CVE-2016-7405)
Cross Site Scripting vulnerability in test script (CVE-2016-4855)
- Record
MGASA-2016-0363- Updated
- 2026-11-02
OSVUSN-6825-1 No score
libphp-adodb vulnerabilities
It was discovered that the PDO driver in ADOdb was incorrectly handling string quotes. A remote attacker could possibly use this issue to perform SQL injection attacks. This issue only affected Ubuntu 16.04 LTS. (CVE-2016-7405)
It was discovered that ADOdb was incorrectly handling GET parameters in test.php. A remote attacker could possibly use this issue to execute cross-site scripting (XSS) attacks. This issue only affected Ubuntu 16.04 LTS. (CVE-2016-4855)
Emmet Leahy discovered that ADOdb was incorrectly handling string quotes in PostgreSQL connections. A remote attacker could possibly use this issue to bypass authentication. (CVE-2021-3850)
- Record
USN-6825-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
adodb/adodb-phpPackagist |
before 5.20.6 | 5.20.6 |
libphp-adodbDebian:12 |
before 5.20.6-1 | 5.20.6-1 |
libphp-adodbDebian:13 |
before 5.20.6-1 | 5.20.6-1 |
libphp-adodbDebian:14 |
before 5.20.6-1 | 5.20.6-1 |
libphp-adodbDebian:7 |
before 5.15-1+deb7u1, plus listed versions 5.15-1 |
5.15-1+deb7u1 |
adodb/adodb-phpPackagist |
before 5.20.6, plus listed versions v5.19v5.20.0v5.20.1v5.20.2v5.20.3v5.20.4v5.20.5 |
5.20.6 |
php-adodbMageia:5 |
before 5.18-5.1.mga5 | 5.18-5.1.mga5 |
libphp-adodbUbuntu:14.04:LTS |
before 5.15-1+deb7u1build0.14.04.1, plus listed versions 5.15-1 |
5.15-1+deb7u1build0.14.04.1 |
libphp-adodbUbuntu:Pro:16.04:LTS |
before 5.20.3-1ubuntu1+esm1, plus listed versions 5.18a-15.20.1-15.20.2-15.20.2-25.20.3-15.20.3-1ubuntu1 |
5.20.3-1ubuntu1+esm1 |
libphp-adodbUbuntu:Pro:18.04:LTS |
before 5.20.9-1ubuntu0.1~esm1, plus listed versions 5.20.9-1 |
5.20.9-1ubuntu0.1~esm1 |
libphp-adodbUbuntu:Pro:20.04:LTS |
before 5.20.16-1ubuntu0.1~esm1, plus listed versions 5.20.14-15.20.15-15.20.16-1 |
5.20.16-1ubuntu0.1~esm1 |
libphp-adodbUbuntu:22.04:LTS |
before 5.20.19-1ubuntu0.1, plus listed versions 5.20.19-1 |
5.20.19-1ubuntu0.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-4855 is a medium vulnerability (CVSS 6.1) in Adodb, published September 13, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.95%, the 80th percentile. Fixed in adodb/adodb-php 5.20.6.
References
github.com/ADOdb/ADOdb/issues/274
securityfocus.com/bid/92753
security.gentoo.org/glsa/201701-59
jvn.jp/en/jp/JVN48237713/index.html
nvd.nist.gov/vuln/detail/CVE-2016-4855
github.com/ADOdb/ADOdb/commit/ecb93d8c1fd3bbde62aca9c3a13c32f077da2da8
Show 15 moreShow less
github.com/FriendsOfPHP/security-advisories/blob/master/adodb/adodb-php/CVE-2016-4855.yaml
github.com/advisories/GHSA-hhfw-xxhm-pf32
security-tracker.debian.org/tracker/CVE-2016-4855
github.com/ADOdb/ADOdb
advisories.mageia.org/MGASA-2016-0363.html
bugs.mageia.org/show_bug.cgi?id=19307
openwall.com/lists/oss-security/2016/09/15/1
lwn.net/Alerts/700508
lwn.net/Vulnerabilities/701151
ubuntu.com/security/CVE-2016-4855
jvn.jp/en/jp/JVN48237713
cve.org/CVERecord?id=CVE-2016-4855
ubuntu.com/security/notices/USN-6825-1
ubuntu.com/security/CVE-2016-7405
ubuntu.com/security/CVE-2021-3850