Every CVE Search/ Get API key

CVE-2016-4855

ADOdb Cross-site scripting vulnerability in old test script

6.1 MediumFix available

Cross-site scripting vulnerability in ADOdb versions prior to 5.20.6 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

1.95%Up 0.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.1

Cross-site scripting vulnerability in ADOdb versions prior to 5.20.6 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
CVE-2016-4855
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting vulnerability in ADOdb versions prior to 5.20.6 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
CVE-2016-4855
Updated
2026-11-02
EUVDEUVD-2022-4154 No score

Cross-site scripting vulnerability in ADOdb versions prior to 5.20.6 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
EUVD-2022-4154
Updated
2026-11-03
GitHub AdvisoriesGHSA-hhfw-xxhm-pf32 6.1

ADOdb Cross-site scripting vulnerability in old test script

Cross-site scripting vulnerability in ADOdb versions prior to 5.20.6 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
GHSA-hhfw-xxhm-pf32
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

Cross-site scripting vulnerability in ADOdb versions prior to 5.20.6 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
CVE-2016-4855
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2016-4855 6.1

Cross-site scripting vulnerability in ADOdb versions prior to 5.20.6 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
DEBIAN-CVE-2016-4855
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
Show 4 moreShow less
OSVGHSA-hhfw-xxhm-pf32 6.1

ADOdb Cross-site scripting vulnerability in old test script

Cross-site scripting vulnerability in ADOdb versions prior to 5.20.6 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
GHSA-hhfw-xxhm-pf32
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVUBUNTU-CVE-2016-4855 6.1

Cross-site scripting vulnerability in ADOdb versions prior to 5.20.6 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
UBUNTU-CVE-2016-4855
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVMGASA-2016-0363 No score

Updated php-adodb packages fix security vulnerabilities

The qstr method in the PDO driver in the ADOdb Library for PHP before 5.x before 5.20.7 might allow remote attackers to conduct SQL injection attacks via vectors related to incorrect quoting. (CVE-2016-7405)

Cross Site Scripting vulnerability in test script (CVE-2016-4855)

Record
MGASA-2016-0363
Updated
2026-11-02
OSVUSN-6825-1 No score

libphp-adodb vulnerabilities

It was discovered that the PDO driver in ADOdb was incorrectly handling string quotes. A remote attacker could possibly use this issue to perform SQL injection attacks. This issue only affected Ubuntu 16.04 LTS. (CVE-2016-7405)

It was discovered that ADOdb was incorrectly handling GET parameters in test.php. A remote attacker could possibly use this issue to execute cross-site scripting (XSS) attacks. This issue only affected Ubuntu 16.04 LTS. (CVE-2016-4855)

Emmet Leahy discovered that ADOdb was incorrectly handling string quotes in PostgreSQL connections. A remote attacker could possibly use this issue to bypass authentication. (CVE-2021-3850)

Record
USN-6825-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
adodb/adodb-php
Packagist
before 5.20.6
5.20.6
libphp-adodb
Debian:12
before 5.20.6-1
5.20.6-1
libphp-adodb
Debian:13
before 5.20.6-1
5.20.6-1
libphp-adodb
Debian:14
before 5.20.6-1
5.20.6-1
libphp-adodb
Debian:7
before 5.15-1+deb7u1, plus listed versions
5.15-1
5.15-1+deb7u1
adodb/adodb-php
Packagist
before 5.20.6, plus listed versions
v5.19v5.20.0v5.20.1v5.20.2v5.20.3v5.20.4v5.20.5
5.20.6
php-adodb
Mageia:5
before 5.18-5.1.mga5
5.18-5.1.mga5
libphp-adodb
Ubuntu:14.04:LTS
before 5.15-1+deb7u1build0.14.04.1, plus listed versions
5.15-1
5.15-1+deb7u1build0.14.04.1
libphp-adodb
Ubuntu:Pro:16.04:LTS
before 5.20.3-1ubuntu1+esm1, plus listed versions
5.18a-15.20.1-15.20.2-15.20.2-25.20.3-15.20.3-1ubuntu1
5.20.3-1ubuntu1+esm1
libphp-adodb
Ubuntu:Pro:18.04:LTS
before 5.20.9-1ubuntu0.1~esm1, plus listed versions
5.20.9-1
5.20.9-1ubuntu0.1~esm1
libphp-adodb
Ubuntu:Pro:20.04:LTS
before 5.20.16-1ubuntu0.1~esm1, plus listed versions
5.20.14-15.20.15-15.20.16-1
5.20.16-1ubuntu0.1~esm1
libphp-adodb
Ubuntu:22.04:LTS
before 5.20.19-1ubuntu0.1, plus listed versions
5.20.19-1
5.20.19-1ubuntu0.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-4855 is a medium vulnerability (CVSS 6.1) in Adodb, published September 13, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.95%, the 80th percentile. Fixed in adodb/adodb-php 5.20.6.

References

Show 15 moreShow less
MoveEnter Open