Every CVE Search/ Get API key

CVE-2014-9087

Integer underflow in the ksba_oid_to_str function in Libksba before 1.3.2, as used in GnuPG,...

7.5 HighFix available

Integer underflow in the ksba_oid_to_str function in Libksba before 1.3.2, as used in GnuPG, allows remote attackers to cause a denial of service (crash) via a crafted OID in a (1) S/MIME message or (2) ECC based OpenPGP data, which triggers a buffer overflow.

Exploit likelihood

5.66%Up 3.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Integer underflow in the ksba_oid_to_str function in Libksba before 1.3.2, as used in GnuPG, allows remote attackers to cause a denial of service (crash) via a crafted OID in a (1) S/MIME message or (2) ECC based OpenPGP data, which triggers a buffer overflow.

Record
CVE-2014-9087
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-191
Updated
2026-11-02
CVE List No score

Integer underflow in the ksba_oid_to_str function in Libksba before 1.3.2, as used in GnuPG, allows remote attackers to cause a denial of service (crash) via a crafted OID in a (1) S/MIME message or (2) ECC based OpenPGP data, which triggers a buffer overflow.

Record
CVE-2014-9087
Updated
2026-11-02
EUVDEUVD-2014-8913 No score

Integer underflow in the ksba_oid_to_str function in Libksba before 1.3.2, as used in GnuPG, allows remote attackers to cause a denial of service (crash) via a crafted OID in a (1) S/MIME message or (2) ECC based OpenPGP data, which triggers a buffer overflow.

Record
EUVD-2014-8913
Updated
2026-11-03
GitHub AdvisoriesGHSA-vqgr-f24j-7rxx No score

Integer underflow in the ksba_oid_to_str function in Libksba before 1.3.2, as used in GnuPG,...

Integer underflow in the ksba_oid_to_str function in Libksba before 1.3.2, as used in GnuPG, allows remote attackers to cause a denial of service (crash) via a crafted OID in a (1) S/MIME message or (2) ECC based OpenPGP data, which triggers a buffer overflow.

Record
GHSA-vqgr-f24j-7rxx
Weakness
CWE-191
Updated
2026-11-02
OSV No score

Integer underflow in the ksba_oid_to_str function in Libksba before 1.3.2, as used in GnuPG, allows remote attackers to cause a denial of service (crash) via a crafted OID in a (1) S/MIME message or (2) ECC based OpenPGP data, which triggers a buffer overflow.

Record
CVE-2014-9087
Updated
2026-11-02
OSVDEBIAN-CVE-2014-9087 No score

Integer underflow in the ksba_oid_to_str function in Libksba before 1.3.2, as used in GnuPG, allows remote attackers to cause a denial of service (crash) via a crafted OID in a (1) S/MIME message or (2) ECC based OpenPGP data, which triggers a buffer overflow.

Record
DEBIAN-CVE-2014-9087
Updated
2026-11-02
Show 4 moreShow less
OSVMGASA-2014-0498 No score

Updated libksba packages fix security vulnerability

By using special crafted S/MIME messages or ECC based OpenPGP data, it is possible to create a buffer overflow, which could lead to a denial of service (CVE-2014-9087).

Record
MGASA-2014-0498
Updated
2026-11-02
OSVopenSUSE-SU-2024:10126-1 No score

libksba-devel-1.3.5-1.3 on GA media

These are all security issues fixed in the libksba-devel-1.3.5-1.3 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10126-1
Updated
2026-11-02
OSVUBUNTU-CVE-2014-9087 No score

Integer underflow in the ksba_oid_to_str function in Libksba before 1.3.2, as used in GnuPG, allows remote attackers to cause a denial of service (crash) via a crafted OID in a (1) S/MIME message or (2) ECC based OpenPGP data, which triggers a buffer overflow.

Record
UBUNTU-CVE-2014-9087
Updated
2026-11-02
OSVUSN-2427-1 No score

libksba vulnerability

Hanno Böck discovered that Libksba incorrectly handled certain S/MIME messages or ECC based OpenPGP data. An attacker could use this issue to cause Libksba to crash, resulting in a denial of service, or possibly execute arbitrary code.

Record
USN-2427-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libksba
Debian:12
before 1.3.2-1
1.3.2-1
libksba
Debian:13
before 1.3.2-1
1.3.2-1
libksba
Debian:14
before 1.3.2-1
1.3.2-1
libksba
Debian:6.0
before 1.0.7-2+deb6u1, plus listed versions
1.0.7-2
1.0.7-2+deb6u1
libksba
Debian:7
before 1.2.0-2+deb7u1, plus listed versions
1.2.0-2
1.2.0-2+deb7u1
libksba
Mageia:3
before 1.3.2-1.mga3
1.3.2-1.mga3
libksba
Mageia:4
before 1.3.2-1.mga4
1.3.2-1.mga4
libksba
Ubuntu:14.04:LTS
before 1.3.0-3ubuntu0.14.04.1, plus listed versions
1.3.0-21.3.0-2ubuntu11.3.0-3
1.3.0-3ubuntu0.14.04.1
libksba
openSUSE:Tumbleweed
From an advisory covering 3 CVEs
before 1.3.5-1.3
1.3.5-1.3

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-9087 is a high vulnerability (CVSS 7.5) in Gnupg, published November 26, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.66%, the 93rd percentile. Fixed in libksba 1.3.2-1.

References

Show 16 moreShow less
MoveEnter Open