CVE-2014-9087
Integer underflow in the ksba_oid_to_str function in Libksba before 1.3.2, as used in GnuPG,...
Integer underflow in the ksba_oid_to_str function in Libksba before 1.3.2, as used in GnuPG, allows remote attackers to cause a denial of service (crash) via a crafted OID in a (1) S/MIME message or (2) ECC based OpenPGP data, which triggers a buffer overflow.
Exploit likelihood
What each source reports
NVD Score used
7.5
Integer underflow in the ksba_oid_to_str function in Libksba before 1.3.2, as used in GnuPG, allows remote attackers to cause a denial of service (crash) via a crafted OID in a (1) S/MIME message or (2) ECC based OpenPGP data, which triggers a buffer overflow.
- Record
CVE-2014-9087- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-191
- Updated
- 2026-11-02
CVE List No score
Integer underflow in the ksba_oid_to_str function in Libksba before 1.3.2, as used in GnuPG, allows remote attackers to cause a denial of service (crash) via a crafted OID in a (1) S/MIME message or (2) ECC based OpenPGP data, which triggers a buffer overflow.
- Record
CVE-2014-9087- Updated
- 2026-11-02
EUVDEUVD-2014-8913 No score
Integer underflow in the ksba_oid_to_str function in Libksba before 1.3.2, as used in GnuPG, allows remote attackers to cause a denial of service (crash) via a crafted OID in a (1) S/MIME message or (2) ECC based OpenPGP data, which triggers a buffer overflow.
- Record
EUVD-2014-8913- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-vqgr-f24j-7rxx No score
Integer underflow in the ksba_oid_to_str function in Libksba before 1.3.2, as used in GnuPG,...
Integer underflow in the ksba_oid_to_str function in Libksba before 1.3.2, as used in GnuPG, allows remote attackers to cause a denial of service (crash) via a crafted OID in a (1) S/MIME message or (2) ECC based OpenPGP data, which triggers a buffer overflow.
- Record
GHSA-vqgr-f24j-7rxx- Weakness
- CWE-191
- Updated
- 2026-11-02
OSV No score
Integer underflow in the ksba_oid_to_str function in Libksba before 1.3.2, as used in GnuPG, allows remote attackers to cause a denial of service (crash) via a crafted OID in a (1) S/MIME message or (2) ECC based OpenPGP data, which triggers a buffer overflow.
- Record
CVE-2014-9087- Updated
- 2026-11-02
OSVDEBIAN-CVE-2014-9087 No score
Integer underflow in the ksba_oid_to_str function in Libksba before 1.3.2, as used in GnuPG, allows remote attackers to cause a denial of service (crash) via a crafted OID in a (1) S/MIME message or (2) ECC based OpenPGP data, which triggers a buffer overflow.
- Record
DEBIAN-CVE-2014-9087- Updated
- 2026-11-02
Show 4 moreShow less
OSVMGASA-2014-0498 No score
Updated libksba packages fix security vulnerability
By using special crafted S/MIME messages or ECC based OpenPGP data, it is possible to create a buffer overflow, which could lead to a denial of service (CVE-2014-9087).
- Record
MGASA-2014-0498- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10126-1 No score
libksba-devel-1.3.5-1.3 on GA media
These are all security issues fixed in the libksba-devel-1.3.5-1.3 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10126-1- Updated
- 2026-11-02
OSVUBUNTU-CVE-2014-9087 No score
Integer underflow in the ksba_oid_to_str function in Libksba before 1.3.2, as used in GnuPG, allows remote attackers to cause a denial of service (crash) via a crafted OID in a (1) S/MIME message or (2) ECC based OpenPGP data, which triggers a buffer overflow.
- Record
UBUNTU-CVE-2014-9087- Updated
- 2026-11-02
OSVUSN-2427-1 No score
libksba vulnerability
Hanno Böck discovered that Libksba incorrectly handled certain S/MIME messages or ECC based OpenPGP data. An attacker could use this issue to cause Libksba to crash, resulting in a denial of service, or possibly execute arbitrary code.
- Record
USN-2427-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libksbaDebian:12 |
before 1.3.2-1 | 1.3.2-1 |
libksbaDebian:13 |
before 1.3.2-1 | 1.3.2-1 |
libksbaDebian:14 |
before 1.3.2-1 | 1.3.2-1 |
libksbaDebian:6.0 |
before 1.0.7-2+deb6u1, plus listed versions 1.0.7-2 |
1.0.7-2+deb6u1 |
libksbaDebian:7 |
before 1.2.0-2+deb7u1, plus listed versions 1.2.0-2 |
1.2.0-2+deb7u1 |
libksbaMageia:3 |
before 1.3.2-1.mga3 | 1.3.2-1.mga3 |
libksbaMageia:4 |
before 1.3.2-1.mga4 | 1.3.2-1.mga4 |
libksbaUbuntu:14.04:LTS |
before 1.3.0-3ubuntu0.14.04.1, plus listed versions 1.3.0-21.3.0-2ubuntu11.3.0-3 |
1.3.0-3ubuntu0.14.04.1 |
libksbaopenSUSE:Tumbleweed From an advisory covering 3 CVEs |
before 1.3.5-1.3 | 1.3.5-1.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-9087 is a high vulnerability (CVSS 7.5) in Gnupg, published November 26, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.66%, the 93rd percentile. Fixed in libksba 1.3.2-1.
References
blog.fuzzing-project.org/2-Buffer-overflow-and-other-minor-issues-in-GnuPG-and-libksba-TFPA-0012014.html
mandriva.com/security/advisories?name=MDVSA-2015:151
secunia.com/advisories/60233
debian.org/security/2014/dsa-3078
advisories.mageia.org/MGASA-2014-0498.html
mandriva.com/security/advisories?name=MDVSA-2014:234
Show 16 moreShow less
securityfocus.com/bid/71285
secunia.com/advisories/60073
secunia.com/advisories/60189
lists.gnupg.org/pipermail/gnupg-announce/2014q4/000359.html
ubuntu.com/usn/USN-2427-1
nvd.nist.gov/vuln/detail/CVE-2014-9087
github.com/advisories/GHSA-vqgr-f24j-7rxx
security-tracker.debian.org/tracker/CVE-2014-9087
bugs.mageia.org/show_bug.cgi?id=14663
openwall.com/lists/oss-security/2014/11/26/3
ubuntu.com/security/CVE-2014-9087
ubuntu.com/security/notices/USN-2427-1
cve.org/CVERecord?id=CVE-2014-9087
suse.com/security/cve/CVE-2014-9087
suse.com/security/cve/CVE-2016-4574
suse.com/security/cve/CVE-2016-4579