CVE-2016-2090
Off-by-one vulnerability in the fgetwln function in libbsd before 0.8.2 allows attackers to have...
Off-by-one vulnerability in the fgetwln function in libbsd before 0.8.2 allows attackers to have unspecified impact via unknown vectors, which trigger a heap-based buffer overflow.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
Off-by-one vulnerability in the fgetwln function in libbsd before 0.8.2 allows attackers to have unspecified impact via unknown vectors, which trigger a heap-based buffer overflow.
- Record
CVE-2016-2090- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
Off-by-one vulnerability in the fgetwln function in libbsd before 0.8.2 allows attackers to have unspecified impact via unknown vectors, which trigger a heap-based buffer overflow.
- Record
CVE-2016-2090- Updated
- 2026-11-02
EUVDEUVD-2016-3195 No score
Off-by-one vulnerability in the fgetwln function in libbsd before 0.8.2 allows attackers to have unspecified impact via unknown vectors, which trigger a heap-based buffer overflow.
- Record
EUVD-2016-3195- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-q44v-89pv-h73p
9.8
Off-by-one vulnerability in the fgetwln function in libbsd before 0.8.2 allows attackers to have...
Off-by-one vulnerability in the fgetwln function in libbsd before 0.8.2 allows attackers to have unspecified impact via unknown vectors, which trigger a heap-based buffer overflow.
- Record
GHSA-q44v-89pv-h73p- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSVALPINE-CVE-2016-2090
9.8
Off-by-one vulnerability in the fgetwln function in libbsd before 0.8.2 allows attackers to have unspecified impact via unknown vectors, which trigger a heap-based buffer overflow.
- Record
ALPINE-CVE-2016-2090- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVBELL-CVE-2016-2090
9.8
CVE-2016-2090 does not affect BellSoft software
- Record
BELL-CVE-2016-2090- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Show 4 moreShow less
OSV
9.8
Off-by-one vulnerability in the fgetwln function in libbsd before 0.8.2 allows attackers to have unspecified impact via unknown vectors, which trigger a heap-based buffer overflow.
- Record
CVE-2016-2090- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2016-2090
9.8
Off-by-one vulnerability in the fgetwln function in libbsd before 0.8.2 allows attackers to have unspecified impact via unknown vectors, which trigger a heap-based buffer overflow.
- Record
DEBIAN-CVE-2016-2090- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-2090
9.8
Off-by-one vulnerability in the fgetwln function in libbsd before 0.8.2 allows attackers to have unspecified impact via unknown vectors, which trigger a heap-based buffer overflow.
- Record
UBUNTU-CVE-2016-2090- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUSN-4243-1 No score
libbsd vulnerabilities
It was discovered that libbsd incorrectly handled certain inputs. An attacker could possibly use this issue to execute arbitrary code. This issue only affected Ubuntu 14.04 ESM. (CVE-2016-2090)
It was discovered that libbsd incorrectly handled certain strings. An attacker could possibly use this issue to access sensitive information. (CVE-2019-20367)
- Record
USN-4243-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libbsdAlpine:v3.2 |
before 0.6.0-r2 | 0.6.0-r2 |
libbsdAlpine:v3.3 |
before 0.8.2-r0 | 0.8.2-r0 |
libbsdAlpine:v3.4 |
before 0.8.2 | 0.8.2 |
libbsdDebian:12 |
before 0.8.2-1 | 0.8.2-1 |
libbsdDebian:13 |
before 0.8.2-1 | 0.8.2-1 |
libbsdDebian:14 |
before 0.8.2-1 | 0.8.2-1 |
libbsdDebian:8 |
before 0.7.0-2+deb8u1, plus listed versions 0.7.0-2 |
0.7.0-2+deb8u1 |
libbsdUbuntu:Pro:14.04:LTS |
before 0.6.0-2ubuntu1+esm1, plus listed versions 0.6.0-10.6.0-1ubuntu10.6.0-2ubuntu1 |
0.6.0-2ubuntu1+esm1 |
libbsdUbuntu:16.04:LTS |
before 0.8.2-1ubuntu0.1, plus listed versions 0.7.0-20.8.0-20.8.1-10.8.2-1 |
0.8.2-1ubuntu0.1 |
libbsdUbuntu:18.04:LTS |
before 0.8.7-1ubuntu0.1, plus listed versions 0.8.6-10.8.6-20.8.6-30.8.7-1 |
0.8.7-1ubuntu0.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-2090 is a critical vulnerability (CVSS 9.8) in Freedesktop Libbsd, published January 13, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.21%, the 88th percentile. Fixed in libbsd 0.6.0-r2.
References
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/7KJE5SPSX7HEKLZ34LUTZLXWPEL2K353
blog.fuzzing-project.org/36-Heap-buffer-overflow-in-fgetwln-function-of-libbsd.html
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DIQKQ42Z7553D46QY3IMIQKS52QTNIHY
bugs.freedesktop.org/show_bug.cgi?id=93881
openwall.com/lists/oss-security/2016/01/28/5
cgit.freedesktop.org/libbsd/commit?id=c8f0723d2b4520bdd6b9eb7c3e7976de726d7ff7
Show 14 moreShow less
security.gentoo.org/glsa/201607-13
lists.debian.org/debian-lts-announce/2019/12/msg00036.html
usn.ubuntu.com/4243-1
nvd.nist.gov/vuln/detail/CVE-2016-2090
lists.fedoraproject.org/archives/list/[email protected]/message/7KJE5SPSX7HEKLZ34LUTZLXWPEL2K353
lists.fedoraproject.org/archives/list/[email protected]/message/DIQKQ42Z7553D46QY3IMIQKS52QTNIHY
github.com/advisories/GHSA-q44v-89pv-h73p
security.alpinelinux.org/vuln/CVE-2016-2090
docs.bell-sw.com/security/cves/CVE-2016-2090
security-tracker.debian.org/tracker/CVE-2016-2090
ubuntu.com/security/CVE-2016-2090
ubuntu.com/security/notices/USN-4243-1
cve.org/CVERecord?id=CVE-2016-2090
ubuntu.com/security/CVE-2019-20367