Every CVE Search/ Get API key

CVE-2016-2090

Off-by-one vulnerability in the fgetwln function in libbsd before 0.8.2 allows attackers to have...

9.8 CriticalFix available

Off-by-one vulnerability in the fgetwln function in libbsd before 0.8.2 allows attackers to have unspecified impact via unknown vectors, which trigger a heap-based buffer overflow.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

3.21%Up 1.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.8

Off-by-one vulnerability in the fgetwln function in libbsd before 0.8.2 allows attackers to have unspecified impact via unknown vectors, which trigger a heap-based buffer overflow.

Record
CVE-2016-2090
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Off-by-one vulnerability in the fgetwln function in libbsd before 0.8.2 allows attackers to have unspecified impact via unknown vectors, which trigger a heap-based buffer overflow.

Record
CVE-2016-2090
Updated
2026-11-02
EUVDEUVD-2016-3195 No score

Off-by-one vulnerability in the fgetwln function in libbsd before 0.8.2 allows attackers to have unspecified impact via unknown vectors, which trigger a heap-based buffer overflow.

Record
EUVD-2016-3195
Updated
2026-11-03
GitHub AdvisoriesGHSA-q44v-89pv-h73p 9.8

Off-by-one vulnerability in the fgetwln function in libbsd before 0.8.2 allows attackers to have...

Off-by-one vulnerability in the fgetwln function in libbsd before 0.8.2 allows attackers to have unspecified impact via unknown vectors, which trigger a heap-based buffer overflow.

Record
GHSA-q44v-89pv-h73p
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-119
Updated
2026-11-02
OSVALPINE-CVE-2016-2090 9.8

Off-by-one vulnerability in the fgetwln function in libbsd before 0.8.2 allows attackers to have unspecified impact via unknown vectors, which trigger a heap-based buffer overflow.

Record
ALPINE-CVE-2016-2090
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVBELL-CVE-2016-2090 9.8

CVE-2016-2090 does not affect BellSoft software

Record
BELL-CVE-2016-2090
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 4 moreShow less
OSV 9.8

Off-by-one vulnerability in the fgetwln function in libbsd before 0.8.2 allows attackers to have unspecified impact via unknown vectors, which trigger a heap-based buffer overflow.

Record
CVE-2016-2090
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2016-2090 9.8

Off-by-one vulnerability in the fgetwln function in libbsd before 0.8.2 allows attackers to have unspecified impact via unknown vectors, which trigger a heap-based buffer overflow.

Record
DEBIAN-CVE-2016-2090
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2016-2090 9.8

Off-by-one vulnerability in the fgetwln function in libbsd before 0.8.2 allows attackers to have unspecified impact via unknown vectors, which trigger a heap-based buffer overflow.

Record
UBUNTU-CVE-2016-2090
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUSN-4243-1 No score

libbsd vulnerabilities

It was discovered that libbsd incorrectly handled certain inputs. An attacker could possibly use this issue to execute arbitrary code. This issue only affected Ubuntu 14.04 ESM. (CVE-2016-2090)

It was discovered that libbsd incorrectly handled certain strings. An attacker could possibly use this issue to access sensitive information. (CVE-2019-20367)

Record
USN-4243-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libbsd
Alpine:v3.2
before 0.6.0-r2
0.6.0-r2
libbsd
Alpine:v3.3
before 0.8.2-r0
0.8.2-r0
libbsd
Alpine:v3.4
before 0.8.2
0.8.2
libbsd
Debian:12
before 0.8.2-1
0.8.2-1
libbsd
Debian:13
before 0.8.2-1
0.8.2-1
libbsd
Debian:14
before 0.8.2-1
0.8.2-1
libbsd
Debian:8
before 0.7.0-2+deb8u1, plus listed versions
0.7.0-2
0.7.0-2+deb8u1
libbsd
Ubuntu:Pro:14.04:LTS
before 0.6.0-2ubuntu1+esm1, plus listed versions
0.6.0-10.6.0-1ubuntu10.6.0-2ubuntu1
0.6.0-2ubuntu1+esm1
libbsd
Ubuntu:16.04:LTS
before 0.8.2-1ubuntu0.1, plus listed versions
0.7.0-20.8.0-20.8.1-10.8.2-1
0.8.2-1ubuntu0.1
libbsd
Ubuntu:18.04:LTS
before 0.8.7-1ubuntu0.1, plus listed versions
0.8.6-10.8.6-20.8.6-30.8.7-1
0.8.7-1ubuntu0.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-2090 is a critical vulnerability (CVSS 9.8) in Freedesktop Libbsd, published January 13, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.21%, the 88th percentile. Fixed in libbsd 0.6.0-r2.

References

Show 14 moreShow less
MoveEnter Open