Every CVE Search/ Get API key

CVE-2014-5025

Cross-site scripting (XSS) vulnerability in data_sources.php in Cacti 0.8.8b allows remote...

3.5 LowFix available

Cross-site scripting (XSS) vulnerability in data_sources.php in Cacti 0.8.8b allows remote authenticated users with console access to inject arbitrary web script or HTML via the name_cache parameter in a ds_edit action.

Exploit likelihood

1.78%Up 0.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 3.5

Cross-site scripting (XSS) vulnerability in data_sources.php in Cacti 0.8.8b allows remote authenticated users with console access to inject arbitrary web script or HTML via the name_cache parameter in a ds_edit action.

Record
CVE-2014-5025
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in data_sources.php in Cacti 0.8.8b allows remote authenticated users with console access to inject arbitrary web script or HTML via the name_cache parameter in a ds_edit action.

Record
CVE-2014-5025
Updated
2026-11-02
EUVDEUVD-2014-4924 No score

Cross-site scripting (XSS) vulnerability in data_sources.php in Cacti 0.8.8b allows remote authenticated users with console access to inject arbitrary web script or HTML via the name_cache parameter in a ds_edit action.

Record
EUVD-2014-4924
Updated
2026-11-03
GitHub AdvisoriesGHSA-v7rc-xv6x-99vc No score

Cross-site scripting (XSS) vulnerability in data_sources.php in Cacti 0.8.8b allows remote...

Cross-site scripting (XSS) vulnerability in data_sources.php in Cacti 0.8.8b allows remote authenticated users with console access to inject arbitrary web script or HTML via the name_cache parameter in a ds_edit action.

Record
GHSA-v7rc-xv6x-99vc
Weakness
CWE-79
Updated
2026-11-02
OSV No score

Cross-site scripting (XSS) vulnerability in data_sources.php in Cacti 0.8.8b allows remote authenticated users with console access to inject arbitrary web script or HTML via the name_cache parameter in a ds_edit action.

Record
CVE-2014-5025
Updated
2026-11-02
OSVDEBIAN-CVE-2014-5025 No score

Cross-site scripting (XSS) vulnerability in data_sources.php in Cacti 0.8.8b allows remote authenticated users with console access to inject arbitrary web script or HTML via the name_cache parameter in a ds_edit action.

Record
DEBIAN-CVE-2014-5025
Updated
2026-11-02
OSVMGASA-2014-0403 No score

Updated cacti package fixes multiple security vulnerabilities

Updated cacti package fixes security vulnerabilities:

Multiple security issues (cross-site scripting, missing input sanitising and SQL injection) have been discovered in Cacti, a web interface for graphing of monitoring systems (CVE-2014-5025, CVE-2014-5026, CVE-2014-5261, CVE-2014-5262).

Record
MGASA-2014-0403
Updated
2026-11-02
OSVopenSUSE-SU-2024:10084-1 No score

cacti-0.8.8h-1.2 on GA media

These are all security issues fixed in the cacti-0.8.8h-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10084-1
Updated
2026-11-02
OSVUBUNTU-CVE-2014-5025 No score

Cross-site scripting (XSS) vulnerability in data_sources.php in Cacti 0.8.8b allows remote authenticated users with console access to inject arbitrary web script or HTML via the name_cache parameter in a ds_edit action.

Record
UBUNTU-CVE-2014-5025
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
cacti
Debian:12
before 0.8.8b+dfsg-7
0.8.8b+dfsg-7
cacti
Debian:13
before 0.8.8b+dfsg-7
0.8.8b+dfsg-7
cacti
Debian:14
before 0.8.8b+dfsg-7
0.8.8b+dfsg-7
cacti
Debian:6.0
From an advisory covering 4 CVEs
before 0.8.7g-1+squeeze5, plus listed versions
0.8.7g-10.8.7g-1+squeeze10.8.7g-1+squeeze20.8.7g-1+squeeze30.8.7g-1+squeeze4
0.8.7g-1+squeeze5
cacti
Debian:7
From an advisory covering 4 CVEs
before 0.8.8a+dfsg-5+deb7u4, plus listed versions
0.8.8a+dfsg-50.8.8a+dfsg-5+deb7u10.8.8a+dfsg-5+deb7u20.8.8a+dfsg-5+deb7u3
0.8.8a+dfsg-5+deb7u4
cacti
Mageia:4
From an advisory covering 4 CVEs
before 0.8.8b-3.2.mga4
0.8.8b-3.2.mga4
cacti
Ubuntu:14.04:LTS
before 0.8.8b+dfsg-5ubuntu0.1, plus listed versions
0.8.8b+dfsg-30.8.8b+dfsg-5
0.8.8b+dfsg-5ubuntu0.1
cacti
openSUSE:Tumbleweed
From an advisory covering 18 CVEs
before 0.8.8h-1.2
0.8.8h-1.2

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-5025 is a low vulnerability (CVSS 3.5) in Cacti, published August 20, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.78%, the 78th percentile. Fixed in cacti 0.8.8b+dfsg-7.

References

Show 26 moreShow less
MoveEnter Open