CVE-2014-5025
Cross-site scripting (XSS) vulnerability in data_sources.php in Cacti 0.8.8b allows remote...
Cross-site scripting (XSS) vulnerability in data_sources.php in Cacti 0.8.8b allows remote authenticated users with console access to inject arbitrary web script or HTML via the name_cache parameter in a ds_edit action.
Exploit likelihood
What each source reports
NVD Score used
3.5
Cross-site scripting (XSS) vulnerability in data_sources.php in Cacti 0.8.8b allows remote authenticated users with console access to inject arbitrary web script or HTML via the name_cache parameter in a ds_edit action.
- Record
CVE-2014-5025- CVSS 2.0
- 3.5 Low
AV:N/AC:M/Au:S/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in data_sources.php in Cacti 0.8.8b allows remote authenticated users with console access to inject arbitrary web script or HTML via the name_cache parameter in a ds_edit action.
- Record
CVE-2014-5025- Updated
- 2026-11-02
EUVDEUVD-2014-4924 No score
Cross-site scripting (XSS) vulnerability in data_sources.php in Cacti 0.8.8b allows remote authenticated users with console access to inject arbitrary web script or HTML via the name_cache parameter in a ds_edit action.
- Record
EUVD-2014-4924- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-v7rc-xv6x-99vc No score
Cross-site scripting (XSS) vulnerability in data_sources.php in Cacti 0.8.8b allows remote...
Cross-site scripting (XSS) vulnerability in data_sources.php in Cacti 0.8.8b allows remote authenticated users with console access to inject arbitrary web script or HTML via the name_cache parameter in a ds_edit action.
- Record
GHSA-v7rc-xv6x-99vc- Weakness
- CWE-79
- Updated
- 2026-11-02
OSV No score
Cross-site scripting (XSS) vulnerability in data_sources.php in Cacti 0.8.8b allows remote authenticated users with console access to inject arbitrary web script or HTML via the name_cache parameter in a ds_edit action.
- Record
CVE-2014-5025- Updated
- 2026-11-02
OSVDEBIAN-CVE-2014-5025 No score
Cross-site scripting (XSS) vulnerability in data_sources.php in Cacti 0.8.8b allows remote authenticated users with console access to inject arbitrary web script or HTML via the name_cache parameter in a ds_edit action.
- Record
DEBIAN-CVE-2014-5025- Updated
- 2026-11-02
OSVMGASA-2014-0403 No score
Updated cacti package fixes multiple security vulnerabilities
Updated cacti package fixes security vulnerabilities:
Multiple security issues (cross-site scripting, missing input sanitising and SQL injection) have been discovered in Cacti, a web interface for graphing of monitoring systems (CVE-2014-5025, CVE-2014-5026, CVE-2014-5261, CVE-2014-5262).
- Record
MGASA-2014-0403- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10084-1 No score
cacti-0.8.8h-1.2 on GA media
These are all security issues fixed in the cacti-0.8.8h-1.2 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10084-1- Updated
- 2026-11-02
OSVUBUNTU-CVE-2014-5025 No score
Cross-site scripting (XSS) vulnerability in data_sources.php in Cacti 0.8.8b allows remote authenticated users with console access to inject arbitrary web script or HTML via the name_cache parameter in a ds_edit action.
- Record
UBUNTU-CVE-2014-5025- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
cactiDebian:12 |
before 0.8.8b+dfsg-7 | 0.8.8b+dfsg-7 |
cactiDebian:13 |
before 0.8.8b+dfsg-7 | 0.8.8b+dfsg-7 |
cactiDebian:14 |
before 0.8.8b+dfsg-7 | 0.8.8b+dfsg-7 |
cactiDebian:6.0 From an advisory covering 4 CVEs |
before 0.8.7g-1+squeeze5, plus listed versions 0.8.7g-10.8.7g-1+squeeze10.8.7g-1+squeeze20.8.7g-1+squeeze30.8.7g-1+squeeze4 |
0.8.7g-1+squeeze5 |
cactiDebian:7 From an advisory covering 4 CVEs |
before 0.8.8a+dfsg-5+deb7u4, plus listed versions 0.8.8a+dfsg-50.8.8a+dfsg-5+deb7u10.8.8a+dfsg-5+deb7u20.8.8a+dfsg-5+deb7u3 |
0.8.8a+dfsg-5+deb7u4 |
cactiMageia:4 From an advisory covering 4 CVEs |
before 0.8.8b-3.2.mga4 | 0.8.8b-3.2.mga4 |
cactiUbuntu:14.04:LTS |
before 0.8.8b+dfsg-5ubuntu0.1, plus listed versions 0.8.8b+dfsg-30.8.8b+dfsg-5 |
0.8.8b+dfsg-5ubuntu0.1 |
cactiopenSUSE:Tumbleweed From an advisory covering 18 CVEs |
before 0.8.8h-1.2 | 0.8.8h-1.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-5025 is a low vulnerability (CVSS 3.5) in Cacti, published August 20, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.78%, the 78th percentile. Fixed in cacti 0.8.8b+dfsg-7.
References
debian.org/security/2014/dsa-3007
bugs.cacti.net/view.php?id=2456
openwall.com/lists/oss-security/2014/07/22/9
securityfocus.com/bid/68759
lists.opensuse.org/opensuse-updates/2015-03/msg00034.html
exchange.xforce.ibmcloud.com/vulnerabilities/94814
Show 26 moreShow less
security.gentoo.org/glsa/201509-03
nvd.nist.gov/vuln/detail/CVE-2014-5025
github.com/advisories/GHSA-v7rc-xv6x-99vc
security-tracker.debian.org/tracker/CVE-2014-5025
advisories.mageia.org/MGASA-2014-0403.html
bugs.mageia.org/show_bug.cgi?id=13930
ubuntu.com/security/CVE-2014-5025
cve.org/CVERecord?id=CVE-2014-5025
suse.com/security/cve/CVE-2013-5588
suse.com/security/cve/CVE-2013-5589
suse.com/security/cve/CVE-2014-2326
suse.com/security/cve/CVE-2014-2327
suse.com/security/cve/CVE-2014-2328
suse.com/security/cve/CVE-2014-2708
suse.com/security/cve/CVE-2014-2709
suse.com/security/cve/CVE-2014-4002
suse.com/security/cve/CVE-2014-5025
suse.com/security/cve/CVE-2014-5026
suse.com/security/cve/CVE-2015-4342
suse.com/security/cve/CVE-2015-4634
suse.com/security/cve/CVE-2015-8369
suse.com/security/cve/CVE-2015-8377
suse.com/security/cve/CVE-2015-8604
suse.com/security/cve/CVE-2016-2313
suse.com/security/cve/CVE-2016-3172
suse.com/security/cve/CVE-2016-3659