CVE-2006-1515
Buffer overflow in the addnewword function in typespeed 0.4.4 and earlier might allow remote...
Buffer overflow in the addnewword function in typespeed 0.4.4 and earlier might allow remote attackers to execute arbitrary code via unknown vectors.
Exploit likelihood
What each source reports
NVD Score used
7.5
Buffer overflow in the addnewword function in typespeed 0.4.4 and earlier might allow remote attackers to execute arbitrary code via unknown vectors.
- Record
CVE-2006-1515- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
Buffer overflow in the addnewword function in typespeed 0.4.4 and earlier might allow remote attackers to execute arbitrary code via unknown vectors.
- Record
CVE-2006-1515- Updated
- 2026-11-02
EUVDEUVD-2006-1519 No score
Buffer overflow in the addnewword function in typespeed 0.4.4 and earlier might allow remote attackers to execute arbitrary code via unknown vectors.
- Record
EUVD-2006-1519- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-fm88-64rw-9r9g No score
Buffer overflow in the addnewword function in typespeed 0.4.4 and earlier might allow remote...
Buffer overflow in the addnewword function in typespeed 0.4.4 and earlier might allow remote attackers to execute arbitrary code via unknown vectors.
- Record
GHSA-fm88-64rw-9r9g- Updated
- 2026-11-02
OSV No score
Buffer overflow in the addnewword function in typespeed 0.4.4 and earlier might allow remote attackers to execute arbitrary code via unknown vectors.
- Record
CVE-2006-1515- Updated
- 2026-11-02
OSVDEBIAN-CVE-2006-1515 No score
Buffer overflow in the addnewword function in typespeed 0.4.4 and earlier might allow remote attackers to execute arbitrary code via unknown vectors.
- Record
DEBIAN-CVE-2006-1515- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
typespeedDebian:12 |
before 0.4.4-10 | 0.4.4-10 |
typespeedDebian:13 |
before 0.4.4-10 | 0.4.4-10 |
typespeedDebian:14 |
before 0.4.4-10 | 0.4.4-10 |
typespeedDebian:3.0 |
before 0.4.1-2.4, plus listed versions 0.4.1-2.20.4.1-2.3 |
0.4.1-2.4 |
typespeedDebian:3.1 |
before 0.4.4-8sarge1, plus listed versions 0.4.4-8 |
0.4.4-8sarge1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2006-1515 is a high vulnerability (CVSS 7.5) in Typespeed, published May 31, 2006. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.61%, the 89th percentile. Fixed in typespeed 0.4.4-10.