Every CVE Search/ Get API key

CVE-2006-1515

Buffer overflow in the addnewword function in typespeed 0.4.4 and earlier might allow remote...

7.5 HighFix available

Buffer overflow in the addnewword function in typespeed 0.4.4 and earlier might allow remote attackers to execute arbitrary code via unknown vectors.

Exploit likelihood

3.61%Down 4.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Buffer overflow in the addnewword function in typespeed 0.4.4 and earlier might allow remote attackers to execute arbitrary code via unknown vectors.

Record
CVE-2006-1515
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Buffer overflow in the addnewword function in typespeed 0.4.4 and earlier might allow remote attackers to execute arbitrary code via unknown vectors.

Record
CVE-2006-1515
Updated
2026-11-02
EUVDEUVD-2006-1519 No score

Buffer overflow in the addnewword function in typespeed 0.4.4 and earlier might allow remote attackers to execute arbitrary code via unknown vectors.

Record
EUVD-2006-1519
Updated
2026-11-03
GitHub AdvisoriesGHSA-fm88-64rw-9r9g No score

Buffer overflow in the addnewword function in typespeed 0.4.4 and earlier might allow remote...

Buffer overflow in the addnewword function in typespeed 0.4.4 and earlier might allow remote attackers to execute arbitrary code via unknown vectors.

Record
GHSA-fm88-64rw-9r9g
Updated
2026-11-02
OSV No score

Buffer overflow in the addnewword function in typespeed 0.4.4 and earlier might allow remote attackers to execute arbitrary code via unknown vectors.

Record
CVE-2006-1515
Updated
2026-11-02
OSVDEBIAN-CVE-2006-1515 No score

Buffer overflow in the addnewword function in typespeed 0.4.4 and earlier might allow remote attackers to execute arbitrary code via unknown vectors.

Record
DEBIAN-CVE-2006-1515
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
typespeed
Debian:12
before 0.4.4-10
0.4.4-10
typespeed
Debian:13
before 0.4.4-10
0.4.4-10
typespeed
Debian:14
before 0.4.4-10
0.4.4-10
typespeed
Debian:3.0
before 0.4.1-2.4, plus listed versions
0.4.1-2.20.4.1-2.3
0.4.1-2.4
typespeed
Debian:3.1
before 0.4.4-8sarge1, plus listed versions
0.4.4-8
0.4.4-8sarge1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2006-1515 is a high vulnerability (CVSS 7.5) in Typespeed, published May 31, 2006. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.61%, the 89th percentile. Fixed in typespeed 0.4.4-10.

References

Show 4 moreShow less
MoveEnter Open